From acf655c2044885062a7168608d1cf99707c05bda Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Mon, 8 Dec 2014 08:44:08 +0100
Subject: [PATCH] imu-pipeline: updating to 0.2.1

Due to the update, imu-pipeline contains now two ROS packages and
requires patching to build if CATKIN_ENABLE_TESTING is not enabled.
---
 recipes-ros/imu-pipeline/imu-pipeline.inc     |  9 +++
 .../imu-pipeline/imu-pipeline_0.1.2.bb        | 14 -----
 .../imu-pipeline/imu-processors_0.2.1.bb      |  8 +++
 ...t-check-launch-file-if-testing-is-on.patch | 58 +++++++++++++++++++
 .../imu-pipeline/imu-transformer_0.2.1.bb     | 12 ++++
 .../packagegroups/packagegroup-ros-world.bb   |  3 +-
 6 files changed, 89 insertions(+), 15 deletions(-)
 create mode 100644 recipes-ros/imu-pipeline/imu-pipeline.inc
 delete mode 100644 recipes-ros/imu-pipeline/imu-pipeline_0.1.2.bb
 create mode 100644 recipes-ros/imu-pipeline/imu-processors_0.2.1.bb
 create mode 100644 recipes-ros/imu-pipeline/imu-transformer/0001-CMakeLists.txt-check-launch-file-if-testing-is-on.patch
 create mode 100644 recipes-ros/imu-pipeline/imu-transformer_0.2.1.bb

diff --git a/recipes-ros/imu-pipeline/imu-pipeline.inc b/recipes-ros/imu-pipeline/imu-pipeline.inc
new file mode 100644
index 0000000..2e4fd25
--- /dev/null
+++ b/recipes-ros/imu-pipeline/imu-pipeline.inc
@@ -0,0 +1,9 @@
+SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
+SRC_URI[md5sum] = "095c1dd8ed0fbd5775ba6986f4e4a074"
+SRC_URI[sha256sum] = "91e0d491bd08dce8629876bf6005a1aaabcb130413ed749c4ab168e17f0118fa"
+
+S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
+
+inherit catkin
+
+ROS_SPN = "imu_pipeline"
diff --git a/recipes-ros/imu-pipeline/imu-pipeline_0.1.2.bb b/recipes-ros/imu-pipeline/imu-pipeline_0.1.2.bb
deleted file mode 100644
index d471cbc..0000000
--- a/recipes-ros/imu-pipeline/imu-pipeline_0.1.2.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-DESCRIPTION = "IMU Pipeline includes tools for processing and pre-processing IMU messages for easier use by later subscribers."
-SECTION = "devel"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
-
-DEPENDS = "roscpp sensor-msgs geometry-msgs nav-msgs tf"
-
-SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "aebca1dfdce3cb8034cd4d203485e40e"
-SRC_URI[sha256sum] = "bb49464de2f2b9c63c31e2bf61804c24a69ee448c1d76e3ff978b4bef9c7cd87"
-
-S = "${WORKDIR}/${ROS_SP}"
-
-inherit catkin
diff --git a/recipes-ros/imu-pipeline/imu-processors_0.2.1.bb b/recipes-ros/imu-pipeline/imu-processors_0.2.1.bb
new file mode 100644
index 0000000..44dd979
--- /dev/null
+++ b/recipes-ros/imu-pipeline/imu-processors_0.2.1.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Processors for sensor_msgs::Imu data"
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=6;endline=6;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "roscpp sensor-msgs geometry-msgs nav-msgs tf"
+
+require imu-pipeline.inc
diff --git a/recipes-ros/imu-pipeline/imu-transformer/0001-CMakeLists.txt-check-launch-file-if-testing-is-on.patch b/recipes-ros/imu-pipeline/imu-transformer/0001-CMakeLists.txt-check-launch-file-if-testing-is-on.patch
new file mode 100644
index 0000000..edab879
--- /dev/null
+++ b/recipes-ros/imu-pipeline/imu-transformer/0001-CMakeLists.txt-check-launch-file-if-testing-is-on.patch
@@ -0,0 +1,58 @@
+From 3a821331fb0884607b6c77865ed9fbc1e8197e20 Mon Sep 17 00:00:00 2001
+From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date: Sat, 28 Feb 2015 20:55:42 +0100
+Subject: [PATCH] CMakeLists.txt: check launch file if testing is on
+
+When building with CATKIN_ENABLE_TESTING deactivated, configure
+fails with:
+
+| -- Using CATKIN_ENABLE_TESTING: 0
+| -- catkin 0.6.14
+| -- Using these message generators: gencpp;genlisp;genpy
+| CMake Error at /opt/ros/indigo/share/roslaunch/cmake/roslaunch-extras.cmake:35 (catkin_run_tests_target):
+|   Unknown CMake command "catkin_run_tests_target".
+| Call Stack (most recent call first):
+|   CMakeLists.txt:34 (roslaunch_add_file_check)
+|
+|
+| -- Configuring incomplete, errors occurred!
+
+Configure fails as the test command 'catkin_run_tests_target' is
+only defined in catkin if CATKIN_ENABLE_TESTING is enabled.
+Hence, this commit changes CMakeLists.txt so that the command is
+only used if CATKIN_ENABLE_TESTING is enabled.
+
+Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+
+Upstream-Status: Submitted [https://github.com/ros-perception/imu_pipeline/pull/6]
+---
+ imu_transformer/CMakeLists.txt | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/imu_transformer/CMakeLists.txt b/imu_transformer/CMakeLists.txt
+index 9a498dc..7a9dfc6 100644
+--- a/imu_transformer/CMakeLists.txt
++++ b/imu_transformer/CMakeLists.txt
+@@ -5,7 +5,6 @@ find_package(catkin REQUIRED COMPONENTS
+   message_filters
+   nodelet
+   roscpp
+-  roslaunch
+   sensor_msgs
+   geometry_msgs
+   tf2
+@@ -31,7 +30,10 @@ target_link_libraries(imu_transformer_nodelet ${catkin_LIBRARIES})
+ add_executable(imu_transformer_node src/imu_transformer_node.cpp)
+ target_link_libraries(imu_transformer_node ${catkin_LIBRARIES})
+ 
+-roslaunch_add_file_check(launch)
++if(CATKIN_ENABLE_TESTING)
++  find_package(roslaunch REQUIRED)
++  roslaunch_add_file_check(launch)
++endif()
+ 
+ install(TARGETS imu_transformer_node imu_transformer_nodelet
+ 	RUNTIME DESTINATION ${CATKIN_PACKAGE_BIN_DESTINATION}
+-- 
+1.9.3
+
diff --git a/recipes-ros/imu-pipeline/imu-transformer_0.2.1.bb b/recipes-ros/imu-pipeline/imu-transformer_0.2.1.bb
new file mode 100644
index 0000000..dab47c3
--- /dev/null
+++ b/recipes-ros/imu-pipeline/imu-transformer_0.2.1.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Node/nodelet combination to transform sensor_msgs::Imu data \
+  from one frame into another."
+SECTION = "devel"
+LICENSE = "GPL"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=162b49cfbae9eadf37c9b89b2d2ac6be"
+
+DEPENDS = "geometry-msgs nodelet message-filters roscpp roslaunch sensor-msgs \
+  tf2 tf2-ros tf2-sensor-msgs topic-tools"
+
+require imu-pipeline.inc
+
+SRC_URI += "file://0001-CMakeLists.txt-check-launch-file-if-testing-is-on.patch;striplevel=2"
diff --git a/recipes-ros/packagegroups/packagegroup-ros-world.bb b/recipes-ros/packagegroups/packagegroup-ros-world.bb
index 5adba35..9352837 100644
--- a/recipes-ros/packagegroups/packagegroup-ros-world.bb
+++ b/recipes-ros/packagegroups/packagegroup-ros-world.bb
@@ -143,7 +143,8 @@ RDEPENDS_${PN} = "\
     diff-drive-controller \
     gripper-action-controller \
     gscam \
-    imu-pipeline \
+    imu-processors \
+    imu-transformer \
     joint-trajectory-controller \
     laser-assembler \
     laser-filters \
-- 
GitLab