From ab7738a3b44fed5dd2dc80bfc05aa7c6c0b254bb Mon Sep 17 00:00:00 2001
From: Stefan Herbrechtsmeier <stefan@herbrechtsmeier.net>
Date: Fri, 15 Feb 2013 16:02:38 +0100
Subject: [PATCH] ros: use include file and unify recipes

Signed-off-by: Stefan Herbrechtsmeier <stefan@herbrechtsmeier.net>
---
 recipes-ros/ros/ros.inc           |  5 +++++
 recipes-ros/ros/roslib_1.9.42.bb  | 22 +++-------------------
 recipes-ros/ros/rosunit_1.9.42.bb | 21 +++------------------
 3 files changed, 11 insertions(+), 37 deletions(-)
 create mode 100644 recipes-ros/ros/ros.inc

diff --git a/recipes-ros/ros/ros.inc b/recipes-ros/ros/ros.inc
new file mode 100644
index 0000000..ac46f06
--- /dev/null
+++ b/recipes-ros/ros/ros.inc
@@ -0,0 +1,5 @@
+SRC_URI = "https://github.com/ros/ros/archive/${PV}.tar.gz;downloadfilename=ros_${PV}.tar.gz"
+SRC_URI[md5sum] = "e38f95785dc6dcbb8f8620c9298c2752"
+SRC_URI[sha256sum] = "2d8997e1f6980c9cea85a27f39e17beb58db924283fc337c8df11fd79bcb3cb2"
+
+inherit catkin
diff --git a/recipes-ros/ros/roslib_1.9.42.bb b/recipes-ros/ros/roslib_1.9.42.bb
index 95bc1d6..619a386 100644
--- a/recipes-ros/ros/roslib_1.9.42.bb
+++ b/recipes-ros/ros/roslib_1.9.42.bb
@@ -3,24 +3,8 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-SRC_URI = "https://github.com/ros-gbp/ros-release/archive/release/roslib/1.9.42.tar.gz;downloadfilename=roslib_1.9.42.tar.gz"
-SRC_URI[md5sum] = "3234ab5475e80e2598a534ab94066b40"
-SRC_URI[sha256sum] = "9443166266ba025984552d764c0a74e7d4a79f9ef3b533c5de6d3220f4aa03e8"
+DEPENDS = "boost rospack"
 
-S = "${WORKDIR}/ros-release-release-roslib-1.9.42"
-
-DEPENDS = "catkin-native boost rospack"
-
-FILES_${PN} += "${libdir}/*"
-
-inherit cmake pythonnative
-
-EXTRA_OECMAKE = " \
-    -Drospack_DIR=${STAGING_DATADIR}/rospack/cmake/ \
-  "
-
-export BUILD_SYS
-export HOST_SYS
-export STAGING_LIBDIR
-export STAGING_INCDIR
+require ros.inc
 
+S = "${WORKDIR}/ros-${PV}/core/${BPN}"
diff --git a/recipes-ros/ros/rosunit_1.9.42.bb b/recipes-ros/ros/rosunit_1.9.42.bb
index 0a72555..3af4605 100644
--- a/recipes-ros/ros/rosunit_1.9.42.bb
+++ b/recipes-ros/ros/rosunit_1.9.42.bb
@@ -3,23 +3,8 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-SRC_URI = "https://github.com/ros-gbp/ros-release/archive/release/rosunit/1.9.42.tar.gz;downloadfilename=rosunit_1.9.42.tar.gz"
-SRC_URI[md5sum] = "1ddf9898fdde848e7ccaea88abb62296"
-SRC_URI[sha256sum] = "65ef24469c572f5b4105b95db3830a565e0de71f8f9c8982ecf80b3244ca9a33"
+require ros.inc
 
-S = "${WORKDIR}/ros-release-release-rosunit-1.9.42"
-
-DEPENDS = "catkin-native"
-
-FILES_${PN} += "${libdir}/*"
-
-inherit cmake pythonnative
-
-EXTRA_OECMAKE = " \
-  "
-
-export BUILD_SYS
-export HOST_SYS
-export STAGING_LIBDIR
-export STAGING_INCDIR
+S = "${WORKDIR}/ros-${PV}/tools/${BPN}"
 
+BBCLASSEXTEND += "native"
-- 
GitLab