From aa2ce283b68ce276af7c4192365a5fbfac4d5464 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 21 Sep 2013 13:42:35 +0200
Subject: [PATCH] removing native packages and dependencies

The native packages are not required anymore, because the needed
python scripts during compile time are also provided by the
cross-compiled packages and the python scripts are platform
independent. Only the catkin package is provided as native package.
---
 classes/catkin.bbclass                                      | 2 --
 recipes-ros/catkin/catkin_0.5.74.bb                         | 2 ++
 recipes-ros/chatter/chatter-msgs_git.bb                     | 2 +-
 recipes-ros/chatter/chatter-sender_git.bb                   | 2 +-
 recipes-ros/common-msgs/common-msgs.inc                     | 2 +-
 recipes-ros/gencpp/gencpp_0.4.14.bb                         | 2 +-
 recipes-ros/genlisp/genlisp_0.4.12.bb                       | 2 +-
 recipes-ros/genpy/genpy_0.4.14.bb                           | 2 +-
 recipes-ros/message-generation/message-generation_0.2.10.bb | 2 +-
 recipes-ros/message-runtime/message-runtime_0.4.12.bb       | 2 +-
 recipes-ros/nodelet-core/nodelet-topic-tools_1.8.1.bb       | 2 +-
 recipes-ros/ros-comm/message-filters_1.9.49.bb              | 2 +-
 recipes-ros/ros-comm/rosconsole_1.9.49.bb                   | 2 +-
 recipes-ros/ros-comm/roscpp_1.9.49.bb                       | 6 ++----
 recipes-ros/ros-comm/rosgraph-msgs_1.9.49.bb                | 2 +-
 recipes-ros/ros-comm/rosnode_1.9.49.bb                      | 2 +-
 recipes-ros/ros-comm/rostest_1.9.49.bb                      | 2 +-
 recipes-ros/ros-comm/rostopic_1.9.49.bb                     | 2 +-
 recipes-ros/ros-comm/roswtf_1.9.49.bb                       | 2 +-
 recipes-ros/ros-comm/std-srvs_1.9.49.bb                     | 2 +-
 recipes-ros/ros-comm/topic-tools_1.9.49.bb                  | 2 +-
 recipes-ros/ros/roslib_1.10.6.bb                            | 2 +-
 recipes-ros/std-msgs/std-msgs_0.5.8.bb                      | 2 +-
 23 files changed, 24 insertions(+), 26 deletions(-)

diff --git a/classes/catkin.bbclass b/classes/catkin.bbclass
index 97daff6..f2e8a02 100644
--- a/classes/catkin.bbclass
+++ b/classes/catkin.bbclass
@@ -33,5 +33,3 @@ SYSROOT_PREPROCESS_FUNCS += "catkin_sysroot_preprocess"
 catkin_sysroot_preprocess () {
     sysroot_stage_dir ${D}${prefix}/etc ${SYSROOT_DESTDIR}${prefix}/etc
 }
-
-BBCLASSEXTEND += "native"
diff --git a/recipes-ros/catkin/catkin_0.5.74.bb b/recipes-ros/catkin/catkin_0.5.74.bb
index a9025c6..f745924 100644
--- a/recipes-ros/catkin/catkin_0.5.74.bb
+++ b/recipes-ros/catkin/catkin_0.5.74.bb
@@ -27,3 +27,5 @@ RDEPENDS_${PN}_class-native = ""
 RDEPENDS_${PN} = "cmake make binutils binutils-symlinks gcc gcc-symlinks g++ g++-symlinks \
     python-catkin-pkg python-argparse python-misc python-multiprocessing \
     python-shell python-subprocess python-xml"
+
+BBCLASSEXTEND += "native"
diff --git a/recipes-ros/chatter/chatter-msgs_git.bb b/recipes-ros/chatter/chatter-msgs_git.bb
index 4e356d2..6a9941b 100644
--- a/recipes-ros/chatter/chatter-msgs_git.bb
+++ b/recipes-ros/chatter/chatter-msgs_git.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "message-generation-native message-runtime-native std-msgs roscpp-serialization"
+DEPENDS = "message-generation message-runtime std-msgs roscpp-serialization"
 
 SRC_URI = "git://github.com/bmwcarit/ros_chatter.git"
 
diff --git a/recipes-ros/chatter/chatter-sender_git.bb b/recipes-ros/chatter/chatter-sender_git.bb
index d2879f3..6566aec 100644
--- a/recipes-ros/chatter/chatter-sender_git.bb
+++ b/recipes-ros/chatter/chatter-sender_git.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "rostest-native rostest chatter-msgs roscpp"
+DEPENDS = "rostest chatter-msgs roscpp"
 
 SRC_URI = "git://github.com/bmwcarit/ros_chatter.git"
 
diff --git a/recipes-ros/common-msgs/common-msgs.inc b/recipes-ros/common-msgs/common-msgs.inc
index 7e822e5..3452f8a 100644
--- a/recipes-ros/common-msgs/common-msgs.inc
+++ b/recipes-ros/common-msgs/common-msgs.inc
@@ -2,7 +2,7 @@ SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilena
 SRC_URI[md5sum] = "49856e2d0e1006fb86822bedcc397af4"
 SRC_URI[sha256sum] = "191eddac2aea2d8b6d5e5939d11b58972bb0e4ddfeca8d3e0938c156d1447c52"
 
-DEPENDS += "cpp-common roscpp-serialization message-generation-native message-runtime-native std-msgs"
+DEPENDS += "cpp-common roscpp-serialization message-generation message-runtime std-msgs"
 
 S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
 
diff --git a/recipes-ros/gencpp/gencpp_0.4.14.bb b/recipes-ros/gencpp/gencpp_0.4.14.bb
index b11491a..6727e63 100644
--- a/recipes-ros/gencpp/gencpp_0.4.14.bb
+++ b/recipes-ros/gencpp/gencpp_0.4.14.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "genmsg-native"
+DEPENDS = "genmsg"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
 SRC_URI[md5sum] = "56f32da469434f1a2ca28fc8aa3d8eb5"
diff --git a/recipes-ros/genlisp/genlisp_0.4.12.bb b/recipes-ros/genlisp/genlisp_0.4.12.bb
index 3a794a6..99563ac 100644
--- a/recipes-ros/genlisp/genlisp_0.4.12.bb
+++ b/recipes-ros/genlisp/genlisp_0.4.12.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "genmsg-native"
+DEPENDS = "genmsg"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
 SRC_URI[md5sum] = "58b049b28c98c6e3456dd5b422c1d1f9"
diff --git a/recipes-ros/genpy/genpy_0.4.14.bb b/recipes-ros/genpy/genpy_0.4.14.bb
index b569ba9..96ed019 100644
--- a/recipes-ros/genpy/genpy_0.4.14.bb
+++ b/recipes-ros/genpy/genpy_0.4.14.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "genmsg-native"
+DEPENDS = "genmsg"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
 SRC_URI[md5sum] = "4e84c43d90f6bf5c4ed72f8a586db00a"
diff --git a/recipes-ros/message-generation/message-generation_0.2.10.bb b/recipes-ros/message-generation/message-generation_0.2.10.bb
index 199405f..7345764 100644
--- a/recipes-ros/message-generation/message-generation_0.2.10.bb
+++ b/recipes-ros/message-generation/message-generation_0.2.10.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "gencpp-native genlisp-native genmsg-native genpy-native"
+DEPENDS = "gencpp genlisp genmsg genpy"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
 SRC_URI[md5sum] = "2bd63c01f909baba3a4b0737ae5e55dd"
diff --git a/recipes-ros/message-runtime/message-runtime_0.4.12.bb b/recipes-ros/message-runtime/message-runtime_0.4.12.bb
index 1c2f0aa..9589a39 100644
--- a/recipes-ros/message-runtime/message-runtime_0.4.12.bb
+++ b/recipes-ros/message-runtime/message-runtime_0.4.12.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "gencpp-native"
+DEPENDS = "gencpp"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
 SRC_URI[md5sum] = "d32e58fd60f775e015b9572e397da891"
diff --git a/recipes-ros/nodelet-core/nodelet-topic-tools_1.8.1.bb b/recipes-ros/nodelet-core/nodelet-topic-tools_1.8.1.bb
index 5953ea7..8fc775a 100644
--- a/recipes-ros/nodelet-core/nodelet-topic-tools_1.8.1.bb
+++ b/recipes-ros/nodelet-core/nodelet-topic-tools_1.8.1.bb
@@ -3,6 +3,6 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "dynamic-reconfigure-native"
+DEPENDS = "dynamic-reconfigure"
 
 require nodelet-core.inc
diff --git a/recipes-ros/ros-comm/message-filters_1.9.49.bb b/recipes-ros/ros-comm/message-filters_1.9.49.bb
index 339948f..19b606f 100644
--- a/recipes-ros/ros-comm/message-filters_1.9.49.bb
+++ b/recipes-ros/ros-comm/message-filters_1.9.49.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "boost rosconsole roscpp rostest-native rosunit-native xmlrpcpp"
+DEPENDS = "boost rosconsole roscpp rostest rosunit xmlrpcpp"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/rosconsole_1.9.49.bb b/recipes-ros/ros-comm/rosconsole_1.9.49.bb
index 51cc89e..2aa1631 100644
--- a/recipes-ros/ros-comm/rosconsole_1.9.49.bb
+++ b/recipes-ros/ros-comm/rosconsole_1.9.49.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=6;endline=6;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "apr boost cpp-common log4cxx rostime rosunit-native"
+DEPENDS = "apr boost cpp-common log4cxx rostime rosunit"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/roscpp_1.9.49.bb b/recipes-ros/ros-comm/roscpp_1.9.49.bb
index 15ff417..31e0979 100644
--- a/recipes-ros/ros-comm/roscpp_1.9.49.bb
+++ b/recipes-ros/ros-comm/roscpp_1.9.49.bb
@@ -6,10 +6,8 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=16;endline=16;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "\
-  catkin-native cpp-common message-generation-native rosconsole roscpp-serialization \
-  roscpp-traits rosgraph-msgs roslang rostime std-msgs xmlrpcpp \
-"
+DEPENDS = "cpp-common message-generation rosconsole roscpp-serialization \
+           roscpp-traits rosgraph-msgs roslang rostime std-msgs xmlrpcpp"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/rosgraph-msgs_1.9.49.bb b/recipes-ros/ros-comm/rosgraph-msgs_1.9.49.bb
index 6a8af06..63ed892 100644
--- a/recipes-ros/ros-comm/rosgraph-msgs_1.9.49.bb
+++ b/recipes-ros/ros-comm/rosgraph-msgs_1.9.49.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "message-generation-native message-runtime-native std-msgs roscpp-serialization"
+DEPENDS = "message-generation message-runtime std-msgs roscpp-serialization"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/rosnode_1.9.49.bb b/recipes-ros/ros-comm/rosnode_1.9.49.bb
index 817425d..475b40c 100644
--- a/recipes-ros/ros-comm/rosnode_1.9.49.bb
+++ b/recipes-ros/ros-comm/rosnode_1.9.49.bb
@@ -4,7 +4,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "rostest-native"
+DEPENDS = "rostest"
 RDEPENDS_${PN} = "python-io python-xmlrpc rosgraph rostopic"
 
 require ros-comm.inc
diff --git a/recipes-ros/ros-comm/rostest_1.9.49.bb b/recipes-ros/ros-comm/rostest_1.9.49.bb
index 07927d5..61c657b 100644
--- a/recipes-ros/ros-comm/rostest_1.9.49.bb
+++ b/recipes-ros/ros-comm/rostest_1.9.49.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "boost python-nose rostest-native"
+DEPENDS = "boost python-nose"
 DEPENDS_class-native = "boost-native rosunit-native"
 
 require ros-comm.inc
diff --git a/recipes-ros/ros-comm/rostopic_1.9.49.bb b/recipes-ros/ros-comm/rostopic_1.9.49.bb
index 2108f54..ff79175 100644
--- a/recipes-ros/ros-comm/rostopic_1.9.49.bb
+++ b/recipes-ros/ros-comm/rostopic_1.9.49.bb
@@ -4,7 +4,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "rostest-native"
+DEPENDS = "rostest"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/roswtf_1.9.49.bb b/recipes-ros/ros-comm/roswtf_1.9.49.bb
index afeb36d..808e05b 100644
--- a/recipes-ros/ros-comm/roswtf_1.9.49.bb
+++ b/recipes-ros/ros-comm/roswtf_1.9.49.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "rostest-native"
+DEPENDS = "rostest"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/std-srvs_1.9.49.bb b/recipes-ros/ros-comm/std-srvs_1.9.49.bb
index adc4f72..876c27d 100644
--- a/recipes-ros/ros-comm/std-srvs_1.9.49.bb
+++ b/recipes-ros/ros-comm/std-srvs_1.9.49.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=6;endline=6;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "message-generation-native message-runtime-native"
+DEPENDS = "message-generation message-runtime"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/topic-tools_1.9.49.bb b/recipes-ros/ros-comm/topic-tools_1.9.49.bb
index 05eab9b..9765f19 100644
--- a/recipes-ros/ros-comm/topic-tools_1.9.49.bb
+++ b/recipes-ros/ros-comm/topic-tools_1.9.49.bb
@@ -4,7 +4,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "rostest-native rostest roscpp"
+DEPENDS = "rostest roscpp"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros/roslib_1.10.6.bb b/recipes-ros/ros/roslib_1.10.6.bb
index 38ce4aa..af59dcd 100644
--- a/recipes-ros/ros/roslib_1.10.6.bb
+++ b/recipes-ros/ros/roslib_1.10.6.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "boost rospack-native rospack"
+DEPENDS = "boost rospack"
 
 require ros.inc
 
diff --git a/recipes-ros/std-msgs/std-msgs_0.5.8.bb b/recipes-ros/std-msgs/std-msgs_0.5.8.bb
index 5a90361..3d0fe1f 100644
--- a/recipes-ros/std-msgs/std-msgs_0.5.8.bb
+++ b/recipes-ros/std-msgs/std-msgs_0.5.8.bb
@@ -4,7 +4,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "message-generation-native message-runtime-native"
+DEPENDS = "message-generation message-runtime"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
 SRC_URI[md5sum] = "5382be6760984ea6818858cd6f6ccf04"
-- 
GitLab