diff --git a/classes/catkin.bbclass b/classes/catkin.bbclass
index 97daff6f89ecb1ce1d63a7414d592b249e997216..f2e8a026e78002f02581f0e3ad1f2198cd6c335e 100644
--- a/classes/catkin.bbclass
+++ b/classes/catkin.bbclass
@@ -33,5 +33,3 @@ SYSROOT_PREPROCESS_FUNCS += "catkin_sysroot_preprocess"
 catkin_sysroot_preprocess () {
     sysroot_stage_dir ${D}${prefix}/etc ${SYSROOT_DESTDIR}${prefix}/etc
 }
-
-BBCLASSEXTEND += "native"
diff --git a/recipes-ros/catkin/catkin_0.5.74.bb b/recipes-ros/catkin/catkin_0.5.74.bb
index a9025c6922a0c2826eb75556009b58d6e3cbfd13..f745924e34b58d5d54fe0aaef0c5bc559cf84328 100644
--- a/recipes-ros/catkin/catkin_0.5.74.bb
+++ b/recipes-ros/catkin/catkin_0.5.74.bb
@@ -27,3 +27,5 @@ RDEPENDS_${PN}_class-native = ""
 RDEPENDS_${PN} = "cmake make binutils binutils-symlinks gcc gcc-symlinks g++ g++-symlinks \
     python-catkin-pkg python-argparse python-misc python-multiprocessing \
     python-shell python-subprocess python-xml"
+
+BBCLASSEXTEND += "native"
diff --git a/recipes-ros/chatter/chatter-msgs_git.bb b/recipes-ros/chatter/chatter-msgs_git.bb
index 4e356d2c74b2ac413230d7967c53c608ccf96b33..6a9941bb1bdcce26817bcae422848d75999061ce 100644
--- a/recipes-ros/chatter/chatter-msgs_git.bb
+++ b/recipes-ros/chatter/chatter-msgs_git.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "message-generation-native message-runtime-native std-msgs roscpp-serialization"
+DEPENDS = "message-generation message-runtime std-msgs roscpp-serialization"
 
 SRC_URI = "git://github.com/bmwcarit/ros_chatter.git"
 
diff --git a/recipes-ros/chatter/chatter-sender_git.bb b/recipes-ros/chatter/chatter-sender_git.bb
index d2879f3a52c453cf8e0ccf5029e4960eaa5e8ff9..6566aece2bcdc51c10d0cccfe1d4a7f9d0d7d00e 100644
--- a/recipes-ros/chatter/chatter-sender_git.bb
+++ b/recipes-ros/chatter/chatter-sender_git.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "rostest-native rostest chatter-msgs roscpp"
+DEPENDS = "rostest chatter-msgs roscpp"
 
 SRC_URI = "git://github.com/bmwcarit/ros_chatter.git"
 
diff --git a/recipes-ros/common-msgs/common-msgs.inc b/recipes-ros/common-msgs/common-msgs.inc
index 7e822e5da1019084410d766d06a8435c44583ec2..3452f8a5ce5ca7ad25ed629669244398cf519151 100644
--- a/recipes-ros/common-msgs/common-msgs.inc
+++ b/recipes-ros/common-msgs/common-msgs.inc
@@ -2,7 +2,7 @@ SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilena
 SRC_URI[md5sum] = "49856e2d0e1006fb86822bedcc397af4"
 SRC_URI[sha256sum] = "191eddac2aea2d8b6d5e5939d11b58972bb0e4ddfeca8d3e0938c156d1447c52"
 
-DEPENDS += "cpp-common roscpp-serialization message-generation-native message-runtime-native std-msgs"
+DEPENDS += "cpp-common roscpp-serialization message-generation message-runtime std-msgs"
 
 S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
 
diff --git a/recipes-ros/gencpp/gencpp_0.4.14.bb b/recipes-ros/gencpp/gencpp_0.4.14.bb
index b11491a79653c65bb5977ed95ea762768bab3c38..6727e63a2ba147c9d8d37c501c38b25fd092a9c6 100644
--- a/recipes-ros/gencpp/gencpp_0.4.14.bb
+++ b/recipes-ros/gencpp/gencpp_0.4.14.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "genmsg-native"
+DEPENDS = "genmsg"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
 SRC_URI[md5sum] = "56f32da469434f1a2ca28fc8aa3d8eb5"
diff --git a/recipes-ros/genlisp/genlisp_0.4.12.bb b/recipes-ros/genlisp/genlisp_0.4.12.bb
index 3a794a666bd0b96238040f9aae6480e50942cf20..99563ac591eb917b011d370507aede4cc4e34196 100644
--- a/recipes-ros/genlisp/genlisp_0.4.12.bb
+++ b/recipes-ros/genlisp/genlisp_0.4.12.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "genmsg-native"
+DEPENDS = "genmsg"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
 SRC_URI[md5sum] = "58b049b28c98c6e3456dd5b422c1d1f9"
diff --git a/recipes-ros/genpy/genpy_0.4.14.bb b/recipes-ros/genpy/genpy_0.4.14.bb
index b569ba997b714c4401250494734c093ab182b93f..96ed019d9c4d6d037125e2680da6bcf18ae8ddaa 100644
--- a/recipes-ros/genpy/genpy_0.4.14.bb
+++ b/recipes-ros/genpy/genpy_0.4.14.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "genmsg-native"
+DEPENDS = "genmsg"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
 SRC_URI[md5sum] = "4e84c43d90f6bf5c4ed72f8a586db00a"
diff --git a/recipes-ros/message-generation/message-generation_0.2.10.bb b/recipes-ros/message-generation/message-generation_0.2.10.bb
index 199405f5135a8f421572afaad4433b4dc30c5cf9..7345764be76a4d2cf6f12c39cf3af64d82f87ee7 100644
--- a/recipes-ros/message-generation/message-generation_0.2.10.bb
+++ b/recipes-ros/message-generation/message-generation_0.2.10.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "gencpp-native genlisp-native genmsg-native genpy-native"
+DEPENDS = "gencpp genlisp genmsg genpy"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
 SRC_URI[md5sum] = "2bd63c01f909baba3a4b0737ae5e55dd"
diff --git a/recipes-ros/message-runtime/message-runtime_0.4.12.bb b/recipes-ros/message-runtime/message-runtime_0.4.12.bb
index 1c2f0aac28e35b3aec55e5791ab8bdf77d4b0ed9..9589a39e872706b76bc054ef50157cf48510b16c 100644
--- a/recipes-ros/message-runtime/message-runtime_0.4.12.bb
+++ b/recipes-ros/message-runtime/message-runtime_0.4.12.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "gencpp-native"
+DEPENDS = "gencpp"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
 SRC_URI[md5sum] = "d32e58fd60f775e015b9572e397da891"
diff --git a/recipes-ros/nodelet-core/nodelet-topic-tools_1.8.1.bb b/recipes-ros/nodelet-core/nodelet-topic-tools_1.8.1.bb
index 5953ea79e8f920b319d0a89c03bcbe8c8fc79b2f..8fc775ac0113634f61e4074c06b67bf4a924bf50 100644
--- a/recipes-ros/nodelet-core/nodelet-topic-tools_1.8.1.bb
+++ b/recipes-ros/nodelet-core/nodelet-topic-tools_1.8.1.bb
@@ -3,6 +3,6 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "dynamic-reconfigure-native"
+DEPENDS = "dynamic-reconfigure"
 
 require nodelet-core.inc
diff --git a/recipes-ros/ros-comm/message-filters_1.9.49.bb b/recipes-ros/ros-comm/message-filters_1.9.49.bb
index 339948fdc37282014ebc047fe38da5376379bc6f..19b606f32aadb1c1484d6430cf65db7f48e8d0fd 100644
--- a/recipes-ros/ros-comm/message-filters_1.9.49.bb
+++ b/recipes-ros/ros-comm/message-filters_1.9.49.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "boost rosconsole roscpp rostest-native rosunit-native xmlrpcpp"
+DEPENDS = "boost rosconsole roscpp rostest rosunit xmlrpcpp"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/rosconsole_1.9.49.bb b/recipes-ros/ros-comm/rosconsole_1.9.49.bb
index 51cc89e846b605272dc1fcf0df5a3226d80bfc2d..2aa1631edc41c5c933c920fafb43028a1e7b4acb 100644
--- a/recipes-ros/ros-comm/rosconsole_1.9.49.bb
+++ b/recipes-ros/ros-comm/rosconsole_1.9.49.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=6;endline=6;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "apr boost cpp-common log4cxx rostime rosunit-native"
+DEPENDS = "apr boost cpp-common log4cxx rostime rosunit"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/roscpp_1.9.49.bb b/recipes-ros/ros-comm/roscpp_1.9.49.bb
index 15ff417a6cb27c8f0148c6a6f5ebff28d7cda9e9..31e09795c6d0a70eeab82410b7cf81f65e69eec3 100644
--- a/recipes-ros/ros-comm/roscpp_1.9.49.bb
+++ b/recipes-ros/ros-comm/roscpp_1.9.49.bb
@@ -6,10 +6,8 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=16;endline=16;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "\
-  catkin-native cpp-common message-generation-native rosconsole roscpp-serialization \
-  roscpp-traits rosgraph-msgs roslang rostime std-msgs xmlrpcpp \
-"
+DEPENDS = "cpp-common message-generation rosconsole roscpp-serialization \
+           roscpp-traits rosgraph-msgs roslang rostime std-msgs xmlrpcpp"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/rosgraph-msgs_1.9.49.bb b/recipes-ros/ros-comm/rosgraph-msgs_1.9.49.bb
index 6a8af0695042178ea19dc091e0c5328f2637c09e..63ed89253c691df40a9e60e8283205fb1da5dc20 100644
--- a/recipes-ros/ros-comm/rosgraph-msgs_1.9.49.bb
+++ b/recipes-ros/ros-comm/rosgraph-msgs_1.9.49.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "message-generation-native message-runtime-native std-msgs roscpp-serialization"
+DEPENDS = "message-generation message-runtime std-msgs roscpp-serialization"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/rosnode_1.9.49.bb b/recipes-ros/ros-comm/rosnode_1.9.49.bb
index 817425d5b048377bfcf61025281e4b1fec8f59d4..475b40c40853cbfe753a5f99d840d60a18fd4713 100644
--- a/recipes-ros/ros-comm/rosnode_1.9.49.bb
+++ b/recipes-ros/ros-comm/rosnode_1.9.49.bb
@@ -4,7 +4,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "rostest-native"
+DEPENDS = "rostest"
 RDEPENDS_${PN} = "python-io python-xmlrpc rosgraph rostopic"
 
 require ros-comm.inc
diff --git a/recipes-ros/ros-comm/rostest_1.9.49.bb b/recipes-ros/ros-comm/rostest_1.9.49.bb
index 07927d550db15c11a53a3244af864118e6047a29..61c657b0c57e5f5d875ebb43a6c21df98c9d7f73 100644
--- a/recipes-ros/ros-comm/rostest_1.9.49.bb
+++ b/recipes-ros/ros-comm/rostest_1.9.49.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "boost python-nose rostest-native"
+DEPENDS = "boost python-nose"
 DEPENDS_class-native = "boost-native rosunit-native"
 
 require ros-comm.inc
diff --git a/recipes-ros/ros-comm/rostopic_1.9.49.bb b/recipes-ros/ros-comm/rostopic_1.9.49.bb
index 2108f54f38e1acbfbfb8306056975f1175f1793d..ff7917506265a2761910575973a9347720aafaa0 100644
--- a/recipes-ros/ros-comm/rostopic_1.9.49.bb
+++ b/recipes-ros/ros-comm/rostopic_1.9.49.bb
@@ -4,7 +4,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "rostest-native"
+DEPENDS = "rostest"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/roswtf_1.9.49.bb b/recipes-ros/ros-comm/roswtf_1.9.49.bb
index afeb36dc6b71ef35cc9f86a3a9a0a4f3744138e1..808e05b4675260a7004ebf183bd59f58c85c4474 100644
--- a/recipes-ros/ros-comm/roswtf_1.9.49.bb
+++ b/recipes-ros/ros-comm/roswtf_1.9.49.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "rostest-native"
+DEPENDS = "rostest"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/std-srvs_1.9.49.bb b/recipes-ros/ros-comm/std-srvs_1.9.49.bb
index adc4f723a3666781b825875125acbb92892faa56..876c27d89395efba07e404d4ed1d9b94b1e1d0e7 100644
--- a/recipes-ros/ros-comm/std-srvs_1.9.49.bb
+++ b/recipes-ros/ros-comm/std-srvs_1.9.49.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=6;endline=6;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "message-generation-native message-runtime-native"
+DEPENDS = "message-generation message-runtime"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/topic-tools_1.9.49.bb b/recipes-ros/ros-comm/topic-tools_1.9.49.bb
index 05eab9b72ee3a1ea28548d7cd96d388401e805f8..9765f1947a49eb7a730e9d0f5008fce96d81cb60 100644
--- a/recipes-ros/ros-comm/topic-tools_1.9.49.bb
+++ b/recipes-ros/ros-comm/topic-tools_1.9.49.bb
@@ -4,7 +4,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "rostest-native rostest roscpp"
+DEPENDS = "rostest roscpp"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros/roslib_1.10.6.bb b/recipes-ros/ros/roslib_1.10.6.bb
index 38ce4aac3997e03780ef09e8deb12f926a48fc9c..af59dcd5542b5e05a5c30537e868f4e07788394e 100644
--- a/recipes-ros/ros/roslib_1.10.6.bb
+++ b/recipes-ros/ros/roslib_1.10.6.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "boost rospack-native rospack"
+DEPENDS = "boost rospack"
 
 require ros.inc
 
diff --git a/recipes-ros/std-msgs/std-msgs_0.5.8.bb b/recipes-ros/std-msgs/std-msgs_0.5.8.bb
index 5a90361310f49a56749947beff4feae3c410e297..3d0fe1f43b29b0af66bbe8d98bc0cef0c353cc31 100644
--- a/recipes-ros/std-msgs/std-msgs_0.5.8.bb
+++ b/recipes-ros/std-msgs/std-msgs_0.5.8.bb
@@ -4,7 +4,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "message-generation-native message-runtime-native"
+DEPENDS = "message-generation message-runtime"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
 SRC_URI[md5sum] = "5382be6760984ea6818858cd6f6ccf04"