diff --git a/CONTENT b/CONTENT
deleted file mode 100644
index 1ec44cdd467aedee2df8ada42b734ff1d90802f6..0000000000000000000000000000000000000000
--- a/CONTENT
+++ /dev/null
@@ -1,10 +0,0 @@
-CONTENT of the repository:
-
-* README                                                   the README file, which contains all important information
-* COPYING.MIT                                              MIT license
-* conf/layer.conf                                          configuration file for this layer
-* classes/catkin.bbclass                                   class for catkin-based packages
-* recipes-core/images                                      recipes of images for native compilation of ROS
-* recipes-devtools                                         recipes of system prerequisites of ROS
-* recipes-ros                                              recipes for cross-compiling ROS packages
-
diff --git a/CONTENTS b/CONTENTS
new file mode 100644
index 0000000000000000000000000000000000000000..4aee278547e0fa3be32a25964c4c5c469bf4057e
--- /dev/null
+++ b/CONTENTS
@@ -0,0 +1,9 @@
+CONTENTS of the repository:
+
+* README                    the README file with all important information
+* COPYING.MIT               MIT license
+* conf/layer.conf           configuration file for this layer
+* classes/catkin.bbclass    class for catkin-based packages
+* recipes-core/images       recipes of images for using ROS
+* recipes-devtools          recipes of system prerequisites of ROS
+* recipes-ros               recipes for cross-compiling ROS packages
diff --git a/README b/README
index 27017b801baa4576dd739af6b72e069bd2a28edf..77739aaf2942d133b8d16ec601f5cb634b4faefa 100644
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
-This is a layer to provide ROS Groovy Galapagos in an OpenEmbedded Linux system.
+This is a layer to provide ROS Hydromedusa in an OpenEmbedded Linux system.
 Currently, this layer is still under development and only provides 
 cross-compilation of the basic ros-comm packages.
 
@@ -58,17 +58,22 @@ USAGE
 
   Look at the meta-ros test reports for the description of the current state.
 
-
-  The recipe core-image-ros-groovy-qemux86-running-roscore provides a minimal
-  Linux system that runs roscore on the qemu x86 virtual machine.
+  The recipe core-image-ros-roscore provides a minimal Linux system that runs
+  roscore.
 
   You can compile the minimal Linux system with
-    bitbake core-image-ros-groovy-qemux86-running-roscore
+    bitbake core-image-ros-roscore
+
+  Then for example, you start this system in the qemu virtual machine with
+    runqemu <MACHINE> core-image-ros-roscore
+
+  
+  On the Linux system, ensure that the own host's name in resolved by adding
+  
+    127.0.0.1	<HOSTNAME>.localdomain		<HOSTNAME>
 
-  Then, you start this system with
-    runqemu qemux86 core-image-ros-groovy-qemux86-running-roscore
+  to the /etc/hosts file, and set up the environment with
 
-  In the qemu shell, set up the environment with
     export ROS_ROOT=/usr
     export ROS_MASTER_URI=http://localhost:11311
     export CMAKE_PREFIX_PATH=/usr
diff --git a/conf/layer.conf b/conf/layer.conf
index 2ee39292d2b6fed1d1658b9a699e5d8bce75a019..2fc56b58b2378a87b1ffb6c4d85d768c605cefbf 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -6,4 +6,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
 
 BBFILE_COLLECTIONS += "ros-layer"
 BBFILE_PATTERN_ros-layer := "^${LAYERDIR}/"
-BBFILE_PRIORITY_ros-layer = "7"
\ No newline at end of file
+BBFILE_PRIORITY_ros-layer = "7"
diff --git a/recipes-core/images/core-image-ros-groovy-qemux86-running-roscore.bb b/recipes-core/images/core-image-ros-groovy-qemux86-running-roscore.bb
deleted file mode 100644
index 52f9dbbead8411b56ff89d5592909e6a5e79dd42..0000000000000000000000000000000000000000
--- a/recipes-core/images/core-image-ros-groovy-qemux86-running-roscore.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-DESCRIPTION = "A small image just capable of starting roscore."
-
-IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
-
-IMAGE_LINGUAS = " "
-
-LICENSE = "MIT"
-
-inherit core-image
-
-IMAGE_ROOTFS_SIZE = "8192"
-
-# add own name to hosts
-# this is a simplistic setup for the qemu virtual machine with x86 architecture,
-# and not a general solution.
-augment_hosts_setting_file () {
-	echo '127.0.0.1\tqemux86.localdomain\t\tqemux86' >> ${IMAGE_ROOTFS}/etc/hosts
-}
-
-# remove not needed ipkg informations
-# create a custom hosts file
-ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; "
-
-IMAGE_INSTALL += "packagegroup-core-ssh-openssh \
-  roslaunch \
-"
diff --git a/recipes-core/images/core-image-ros-roscore.bb b/recipes-core/images/core-image-ros-roscore.bb
new file mode 100644
index 0000000000000000000000000000000000000000..a8bdb2e459b94fe2ce9e0034e3d9717f2796738d
--- /dev/null
+++ b/recipes-core/images/core-image-ros-roscore.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "A small image just capable of starting roscore."
+
+IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
+
+IMAGE_LINGUAS = " "
+
+LICENSE = "MIT"
+
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+
+# remove not needed ipkg informations
+ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files"
+
+IMAGE_INSTALL += "roslaunch"
diff --git a/recipes-devtools/python/python-catkin-pkg_0.1.16.bb b/recipes-devtools/python/python-catkin-pkg_0.1.16.bb
index b8cbc7251558b8372a0c34d879976fcb894410d2..bc82fc223149c3df3827fcf1431fec91d47b817d 100644
--- a/recipes-devtools/python/python-catkin-pkg_0.1.16.bb
+++ b/recipes-devtools/python/python-catkin-pkg_0.1.16.bb
@@ -12,6 +12,4 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 inherit distutils
 
-DEPENDS += "python"
-DEPENDS_class-native  += "python-native"
 BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-empy_3.3.bb b/recipes-devtools/python/python-empy_3.3.bb
index dd16e90ba77820b221fe17cd91c514cfce76339c..fb5e4178dd8500d967c7559655e8f27081095e93 100644
--- a/recipes-devtools/python/python-empy_3.3.bb
+++ b/recipes-devtools/python/python-empy_3.3.bb
@@ -10,11 +10,6 @@ SRC_URI[sha256sum] = "c625436d03cff8adbbade639d14a2df9bc4c4de99ec3a821ad4d6eeb66
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# RDEPENDS = "python-modules"
-
 inherit distutils
 
-DEPENDS += "python"
-DEPENDS_class-native  += "python-native"
 BBCLASSEXTEND = "native"
-
diff --git a/recipes-devtools/python/python-native_2.7.3.bbappend b/recipes-devtools/python/python-native_2.7.3.bbappend
index 90bc835521237f947fb277ac78825fd381f740df..e7420993097581c7f707ccdf522faaa5ad0d5b46 100644
--- a/recipes-devtools/python/python-native_2.7.3.bbappend
+++ b/recipes-devtools/python/python-native_2.7.3.bbappend
@@ -1 +1 @@
-RPROVIDES += "python-xml-native"
+RPROVIDES += "python-datetime-native python-netclient-native python-subprocess-native python-xml-native"
diff --git a/recipes-devtools/python/python-pyyaml_3.10.bb b/recipes-devtools/python/python-pyyaml_3.10.bb
index bb8e26f2e05b4b9c4ca3bc42bc8b5dd23d94dbb2..aacebafc81a1dbfea8a67ab502d66af85f3922bb 100644
--- a/recipes-devtools/python/python-pyyaml_3.10.bb
+++ b/recipes-devtools/python/python-pyyaml_3.10.bb
@@ -11,12 +11,8 @@ SRC_URI[sha256sum] = "e713da45c96ca53a3a8b48140d4120374db622df16ab71759c9ceb5b8d
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-inherit distutils
-
-DEPENDS += "python"
-DEPENDS_class-native  += "python-native"
-
 RDEPENDS_${PN} = "python-datetime"
 
-BBCLASSEXTEND = "native"
+inherit distutils
 
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-rosdep_0.10.11.bb b/recipes-devtools/python/python-rosdep_0.10.11.bb
index 64004a8f490abb56c1078a9eae2edc048dcfc117..993ce4d79b76879c2a78a97d4d2065b6aa02acb1 100644
--- a/recipes-devtools/python/python-rosdep_0.10.11.bb
+++ b/recipes-devtools/python/python-rosdep_0.10.11.bb
@@ -10,9 +10,8 @@ SRC_URI[sha256sum] = "c3e741db57b7230c8ac2cceca837b98181b4fa6d1488819e615366a858
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# install_requires=['catkin_pkg', 'rospkg', 'PyYAML >= 3.1'],
-# setup_requires=['nose >= 1.0'],
-
-RDEPENDS_${PN} += "python-catkin-pkg python-rospkg python-pyyaml"
+RDEPENDS_${PN} += "python-catkin-pkg python-rospkg python-pyyaml python-netclient"
 
 inherit setuptools
+
+BBCLASSEXTEND += "native"
diff --git a/recipes-devtools/python/python-rosinstall_0.6.21.bb b/recipes-devtools/python/python-rosinstall_0.6.21.bb
index d955a1cd717b8f0b22f652bcf2e59089ec0afc36..09e84c14ee14d5ba74946b2d17d2066430b45bdd 100644
--- a/recipes-devtools/python/python-rosinstall_0.6.21.bb
+++ b/recipes-devtools/python/python-rosinstall_0.6.21.bb
@@ -10,9 +10,7 @@ SRC_URI[sha256sum] = "7163106c93460c8d092c5e74749cefd3fc17295f3a06c4f041fe83a772
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# install_requires=['vcstools', 'pyyaml'],
 DEPENDS += "python-vcstools python-pyyaml"
 RDEPENDS_${PN} = "python-vcstools"
 
 inherit setuptools
-
diff --git a/recipes-devtools/python/python-rospkg_1.0.15.bb b/recipes-devtools/python/python-rospkg_1.0.15.bb
index a38a21060136c75233ff339ac6be0f3dea676880..893bf03a75dc85be9ef7163fd9a3e85920f27ca2 100644
--- a/recipes-devtools/python/python-rospkg_1.0.15.bb
+++ b/recipes-devtools/python/python-rospkg_1.0.15.bb
@@ -14,6 +14,4 @@ RDEPENDS_${PN} += "python-xml"
 
 inherit setuptools
 
-DEPENDS += "python"
 BBCLASSEXTEND = "native"
-
diff --git a/recipes-devtools/python/python-vcstools_0.1.26.bb b/recipes-devtools/python/python-vcstools_0.1.26.bb
index ac2a3bc0256b3ad0f50f694d8b0c210e651d9f76..3e57adc3299044733aa233f58f1219960a90802e 100644
--- a/recipes-devtools/python/python-vcstools_0.1.26.bb
+++ b/recipes-devtools/python/python-vcstools_0.1.26.bb
@@ -10,8 +10,6 @@ SRC_URI[sha256sum] = "11cae4907609d3524655c7cdba66260821f69fd2ff2330ae93db35111c
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# install_requires=['pyyaml','python-dateutil']
 RDEPENDS_${PN} += "python-pyyaml python-dateutil"
 
 inherit setuptools
-
diff --git a/recipes-devtools/python/python-wstool_0.0.2.bb b/recipes-devtools/python/python-wstool_0.0.2.bb
index 1dd82b7a947448c6d12f438d0c3716038e23cdf2..993ab1ae9ffe49211116edeb06039d8e5d299005 100644
--- a/recipes-devtools/python/python-wstool_0.0.2.bb
+++ b/recipes-devtools/python/python-wstool_0.0.2.bb
@@ -10,7 +10,6 @@ SRC_URI[sha256sum] = "487602f7d5bef1e0b759c60ab4b86db884dd2abfb756e1743ad4ae3754
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# install_requires=['vcstools', 'pyyaml', 'rosinstall'],
 RDEPENDS_${PN} += "python-vcstools python-pyyaml python-rosinstall"
 
 inherit setuptools
diff --git a/recipes-devtools/yaml-cpp/yaml-cpp_0.3.0.bb b/recipes-devtools/yaml-cpp/yaml-cpp_0.3.0.bb
index f87fb51499bf0974736890cb0325b3fe9fdac875..5a2c306f12bda308cb0a1b2197433b84541aa79f 100644
--- a/recipes-devtools/yaml-cpp/yaml-cpp_0.3.0.bb
+++ b/recipes-devtools/yaml-cpp/yaml-cpp_0.3.0.bb
@@ -9,7 +9,6 @@ PR = "r0"
 S = "${WORKDIR}/${PN}"
 
 SRC_URI = "http://yaml-cpp.googlecode.com/files/yaml-cpp-${PV}.tar.gz"
-
 SRC_URI[md5sum] = "9aa519205a543f9372bf4179071c8ac6"
 SRC_URI[sha256sum] = "2cd038b5a1583b6745e949e196fba525f6d0d5fd340566585fde24fc7e117b82"
 
diff --git a/recipes-extended/libpoco/libpoco_1.4.6p1.bb b/recipes-extended/libpoco/libpoco_1.4.6p1.bb
index 411af136d5d4cb1e8c1817b55343caaf002d89e5..6b5f6740a100f92baf046224ff57b0faaccfb05a 100644
--- a/recipes-extended/libpoco/libpoco_1.4.6p1.bb
+++ b/recipes-extended/libpoco/libpoco_1.4.6p1.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://pocoproject.org"
 LICENSE = "BSL-1.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e4224ccaecb14d942c71d31bef20d78c"
 
-DEPENDS = "expat zlib libpcre"
+DEPENDS = "expat zlib libpcre openssl"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/poco/poco-${PV}-all.tar.bz2 \
            file://OE \
diff --git a/recipes-ros/catkin/catkin_0.5.71.bb b/recipes-ros/catkin/catkin_0.5.71.bb
index c39be3d39fcf6608d30db93420eeeb0b139fdb4e..d39e7623fd31972afc3111b0d69701f99d78c3f4 100644
--- a/recipes-ros/catkin/catkin_0.5.71.bb
+++ b/recipes-ros/catkin/catkin_0.5.71.bb
@@ -4,8 +4,8 @@ LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
 DEPENDS = "cmake python-empy python-catkin-pkg python-empy-native python-catkin-pkg-native"
-RDEPENDS_${PN}_class-native = ""
 
+RDEPENDS_${PN}_class-native = ""
 RDEPENDS_${PN} = "cmake make binutils binutils-symlinks gcc gcc-symlinks g++ g++-symlinks \
     python-catkin-pkg python-argparse python-misc python-multiprocessing \
     python-shell python-subprocess python-xml"
@@ -27,5 +27,3 @@ FILES_${PN}-dev += "\
     ${prefix}/env.sh \
     ${prefix}/setup.* \
     "
-
-BBCLASSEXTEND += "native"
diff --git a/recipes-ros/common-msgs/actionlib-msgs_1.10.0.bb b/recipes-ros/common-msgs/actionlib-msgs_1.10.0.bb
index f42de8783e1c80cea941b78aa45f7d62372e68bb..914abd93f18684281f222f2391723d09b6f17253 100644
--- a/recipes-ros/common-msgs/actionlib-msgs_1.10.0.bb
+++ b/recipes-ros/common-msgs/actionlib-msgs_1.10.0.bb
@@ -5,4 +5,3 @@ LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
 
 require common-msgs.inc
-
diff --git a/recipes-ros/common-msgs/diagnostic-msgs_1.10.0.bb b/recipes-ros/common-msgs/diagnostic-msgs_1.10.0.bb
index 919ac0c0e01f32f8fdb8525ee291701b95caf381..256436c7a8594c94f7d0f96f2ec7252b94871000 100644
--- a/recipes-ros/common-msgs/diagnostic-msgs_1.10.0.bb
+++ b/recipes-ros/common-msgs/diagnostic-msgs_1.10.0.bb
@@ -1,4 +1,4 @@
-DESCRIPTION = "\This package holds the diagnostic messages which provide the \
+DESCRIPTION = "This package holds the diagnostic messages which provide the \
 standardized interface for the diagnostic and runtime monitoring systems in ROS."
 SECTION = "devel"
 LICENSE = "BSD"
diff --git a/recipes-ros/common-tutorials/common-tutorials.inc b/recipes-ros/common-tutorials/common-tutorials.inc
new file mode 100644
index 0000000000000000000000000000000000000000..ee7f39b78c34b2f0f05e2388fe2cd2fc7c39754d
--- /dev/null
+++ b/recipes-ros/common-tutorials/common-tutorials.inc
@@ -0,0 +1,7 @@
+SRC_URI = "https://github.com/ros/common_tutorials/archive/${PV}.tar.gz;downloadfilename=common_tutorials-${PV}.tar.gz"
+SRC_URI[md5sum] = "0055265f3854afcf4cc0abff06a9f023"
+SRC_URI[sha256sum] = "257f45f36463d5ffc04e1d60ac1fc6a2e7c1b11d012daa43b2eb43001383048c"
+
+S = "${WORKDIR}/common_tutorials-${PV}/${ROS_BPN}"
+
+inherit catkin
diff --git a/recipes-ros/common-tutorials/nodelet-tutorial-math_0.1.7.bb b/recipes-ros/common-tutorials/nodelet-tutorial-math_0.1.7.bb
new file mode 100644
index 0000000000000000000000000000000000000000..5f3de13f27cf940518d4ff0d21b664a46d2c9cce
--- /dev/null
+++ b/recipes-ros/common-tutorials/nodelet-tutorial-math_0.1.7.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "nodelet_tutorial_math ROS package"
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "roscpp nodelet std-msgs"
+
+require common-tutorials.inc
diff --git a/recipes-ros/common-tutorials/pluginlib-tutorials_0.1.7.bb b/recipes-ros/common-tutorials/pluginlib-tutorials_0.1.7.bb
new file mode 100644
index 0000000000000000000000000000000000000000..1a2b14adc6a688b5f8fbcb52dc13f63036d88463
--- /dev/null
+++ b/recipes-ros/common-tutorials/pluginlib-tutorials_0.1.7.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "pluginlib_tutorials ROS package"
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "roscpp pluginlib"
+
+require common-tutorials.inc
diff --git a/recipes-ros/console-bridge/console-bridge_0.2.4.bb b/recipes-ros/console-bridge/console-bridge_0.2.4.bb
index 0df8ba8f04f4e3237710bb52c352effb22cc42cf..cf9c48872be0d180215de60792dfcc44b3ee8c6e 100644
--- a/recipes-ros/console-bridge/console-bridge_0.2.4.bb
+++ b/recipes-ros/console-bridge/console-bridge_0.2.4.bb
@@ -24,4 +24,3 @@ inherit cmake
 
 FILES_SOLIBSDEV = ""
 FILES_${PN} += "${libdir}/lib*${SOLIBSDEV}"
-
diff --git a/recipes-ros/image-common/image-transport_1.11.0.bb b/recipes-ros/image-common/image-transport_1.11.0.bb
index 2665674beaf6714b7d274da61d6ab6e63b2a2602..fa6cff345704242df5105968eb93674128d85df9 100644
--- a/recipes-ros/image-common/image-transport_1.11.0.bb
+++ b/recipes-ros/image-common/image-transport_1.11.0.bb
@@ -6,4 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=d566ef916e9de
 DEPENDS = "message-filters pluginlib rosconsole roscpp roslib sensor-msgs"
 
 require image-common.inc
-
diff --git a/recipes-ros/ros-tutorials/ros-tutorials.inc b/recipes-ros/ros-tutorials/ros-tutorials.inc
new file mode 100644
index 0000000000000000000000000000000000000000..403171b7b117b8d1248ca564ec0b535564372dc1
--- /dev/null
+++ b/recipes-ros/ros-tutorials/ros-tutorials.inc
@@ -0,0 +1,7 @@
+SRC_URI = "https://github.com/ros/ros_tutorials/archive/${PV}.tar.gz;downloadfilename=ros_tutorials-${PV}.tar.gz;name=archive"
+SRC_URI[archive.md5sum] = "e1763e2ccc91976ac98b07d3f423478d"
+SRC_URI[archive.sha256sum] = "827622a42eb14119c3303665c91635fd4c1eb401e1585a9f1fde819f7651bdbf"
+
+S = "${WORKDIR}/ros_tutorials-${PV}/${ROS_BPN}"
+
+inherit catkin
diff --git a/recipes-ros/ros-tutorials/roscpp-tutorials_0.3.11.bb b/recipes-ros/ros-tutorials/roscpp-tutorials_0.3.11.bb
new file mode 100644
index 0000000000000000000000000000000000000000..9cb204c1b0bdd8501e1fbb2c51b75e39cb363803
--- /dev/null
+++ b/recipes-ros/ros-tutorials/roscpp-tutorials_0.3.11.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "This package contains step-by-step tutorials written in C++ for learning ROS."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "message-generation roscpp rosconsole roscpp-serialization rostime std-msgs"
+
+require ros-tutorials.inc
diff --git a/recipes-ros/ros-tutorials/rospy-tutorials_0.3.11.bb b/recipes-ros/ros-tutorials/rospy-tutorials_0.3.11.bb
new file mode 100644
index 0000000000000000000000000000000000000000..6a5e832dc8d003609c9c185f53a4e8136afaabc6
--- /dev/null
+++ b/recipes-ros/ros-tutorials/rospy-tutorials_0.3.11.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "This package contains step-by-step tutorials written python for learning ROS"
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "message-generation rostest std-msgs cpp-common roscpp-serialization"
+
+require ros-tutorials.inc
+
+SRC_URI += "https://github.com/ros/ros_tutorials/commit/1e559b3f811a6cf3daac59088d6d86ca1d31b261.patch;striplevel=2;name=patch"
+SRC_URI[patch.md5sum] = "c9e4af54266205ad233acc064a456840"
+SRC_URI[patch.sha256sum] = "838ad3cbe2da1c625a44af80c4351f1187478e6ec52adc1c535942337252a719"
diff --git a/recipes-ros/ros/mk_1.10.4.bb b/recipes-ros/ros/mk_1.10.4.bb
index 361d7017c8c740daf8f29804ca53af940295993d..608f11189e42c74622253e5dc73164502a28eaaf 100644
--- a/recipes-ros/ros/mk_1.10.4.bb
+++ b/recipes-ros/ros/mk_1.10.4.bb
@@ -3,8 +3,6 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = ""
-
 require ros.inc
 
 S = "${WORKDIR}/ros-${PV}/core/${BPN}"
diff --git a/recipes-ros/ros/rosbash_1.10.4.bb b/recipes-ros/ros/rosbash_1.10.4.bb
index 6aff5ba6a0b7f683abe5824e9730f95603e792fb..e4ab00a84fe2ab92bd507a96df1fa9eecf51b514 100644
--- a/recipes-ros/ros/rosbash_1.10.4.bb
+++ b/recipes-ros/ros/rosbash_1.10.4.bb
@@ -8,4 +8,3 @@ require ros.inc
 RDEPENDS_${PN} = "bash findutils"
 
 S = "${WORKDIR}/ros-${PV}/tools/${BPN}"
-
diff --git a/recipes-ros/ros/rosboost-cfg_1.10.4.bb b/recipes-ros/ros/rosboost-cfg_1.10.4.bb
index 783e1407402e4ef4495cbfbfd8f8b262de74046c..a229ef51a749973a26f4e9a2d7ded4c7a1af80ef 100644
--- a/recipes-ros/ros/rosboost-cfg_1.10.4.bb
+++ b/recipes-ros/ros/rosboost-cfg_1.10.4.bb
@@ -6,4 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc
 require ros.inc
 
 S = "${WORKDIR}/ros-${PV}/tools/${ROS_BPN}"
-
diff --git a/recipes-ros/ros/rosbuild_1.10.4.bb b/recipes-ros/ros/rosbuild_1.10.4.bb
index 2c307ec687573088ff77fa82b9143dd0dbdc37ee..b65e743040f0155e82627af55301f52adf4a3843 100644
--- a/recipes-ros/ros/rosbuild_1.10.4.bb
+++ b/recipes-ros/ros/rosbuild_1.10.4.bb
@@ -3,8 +3,6 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = ""
-
 require ros.inc
 
 S = "${WORKDIR}/ros-${PV}/core/${BPN}"
diff --git a/recipes-ros/ros/rosclean_1.10.4.bb b/recipes-ros/ros/rosclean_1.10.4.bb
index 68b4d3567ed0888c8d4fdb5cd79da548ab475a5a..dcb02ccb2e16acc11b810de447bced4e22a1b90d 100644
--- a/recipes-ros/ros/rosclean_1.10.4.bb
+++ b/recipes-ros/ros/rosclean_1.10.4.bb
@@ -6,4 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc
 require ros.inc
 
 S = "${WORKDIR}/ros-${PV}/tools/${BPN}"
-
diff --git a/recipes-ros/ros/roscreate_1.10.4.bb b/recipes-ros/ros/roscreate_1.10.4.bb
index 3dcf63d598def6f62180725b6340bbc520c54ea8..312d466e6c99fcac6c9f23a11337a2de8563dd1d 100644
--- a/recipes-ros/ros/roscreate_1.10.4.bb
+++ b/recipes-ros/ros/roscreate_1.10.4.bb
@@ -6,4 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9de
 require ros.inc
 
 S = "${WORKDIR}/ros-${PV}/tools/${BPN}"
-
diff --git a/recipes-ros/ros/rosmake_1.10.4.bb b/recipes-ros/ros/rosmake_1.10.4.bb
index 542b17f139fda9e5b357e17df8963b8f7f686794..02415198a9ffc99c9134e1d07411485b1920bd12 100644
--- a/recipes-ros/ros/rosmake_1.10.4.bb
+++ b/recipes-ros/ros/rosmake_1.10.4.bb
@@ -6,4 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
 require ros.inc
 
 S = "${WORKDIR}/ros-${PV}/tools/${BPN}"
-
diff --git a/recipes-ros/ros/rosunit_1.10.4.bb b/recipes-ros/ros/rosunit_1.10.4.bb
index 3bf82329b22a5b7a9ba0e237d42140608ed1b0d7..4679440999178b4b67a7664c10e35687433167c8 100644
--- a/recipes-ros/ros/rosunit_1.10.4.bb
+++ b/recipes-ros/ros/rosunit_1.10.4.bb
@@ -8,5 +8,3 @@ require ros.inc
 SRC_URI += "file://0001-rosunit-extras.cmake.em-remove-NO_CMAKE_FIND_ROOT_PA.patch;striplevel=3"
 
 S = "${WORKDIR}/ros-${PV}/tools/${BPN}"
-
-BBCLASSEXTEND += "native"
diff --git a/recipes-ros/roscpp-core/cpp-common_0.3.16.bb b/recipes-ros/roscpp-core/cpp-common_0.3.16.bb
index b8764bc6826a3ad9627f8e2a6dfc0376440583fc..dfa645cb2b1730626355bcc39121c5a88570cb66 100644
--- a/recipes-ros/roscpp-core/cpp-common_0.3.16.bb
+++ b/recipes-ros/roscpp-core/cpp-common_0.3.16.bb
@@ -4,5 +4,3 @@ LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9dedc494f5f793a6690ba5"
 
 require roscpp-core.inc
-
-S = "${WORKDIR}/roscpp_core-${PV}/${ROS_BPN}"
diff --git a/recipes-ros/roscpp-core/roscpp-core.inc b/recipes-ros/roscpp-core/roscpp-core.inc
index 71a19cfae05003867255c795a5161bf1b45c4691..0aa7f984885b318ba24431cc1f59913d281eb60a 100644
--- a/recipes-ros/roscpp-core/roscpp-core.inc
+++ b/recipes-ros/roscpp-core/roscpp-core.inc
@@ -2,6 +2,6 @@ SRC_URI = "https://github.com/ros/roscpp_core/archive/${PV}.tar.gz;downloadfilen
 SRC_URI[md5sum] = "d02c9d1270d1f68487944fb0e76adcb7"
 SRC_URI[sha256sum] = "805b08c5b7044dd93bfaf4a0dd5807b391d1d86db9f6d143f9946b5528500eda"
 
-S = "${WORKDIR}/roscpp_core-${PV}/${BPN}"
+S = "${WORKDIR}/roscpp_core-${PV}/${ROS_BPN}"
 
 inherit catkin
diff --git a/recipes-ros/roscpp-core/roscpp-serialization_0.3.16.bb b/recipes-ros/roscpp-core/roscpp-serialization_0.3.16.bb
index 03a283323d26b902712ed7e38ad2b095f2a0a5ba..07bd9ef1ea409b4db6d70608d9df916574eed6b0 100644
--- a/recipes-ros/roscpp-core/roscpp-serialization_0.3.16.bb
+++ b/recipes-ros/roscpp-core/roscpp-serialization_0.3.16.bb
@@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9de
 DEPENDS = "cpp-common roscpp-traits rostime"
 
 require roscpp-core.inc
-
-S = "${WORKDIR}/roscpp_core-${PV}/${ROS_BPN}"
diff --git a/recipes-ros/roscpp-core/roscpp-traits_0.3.16.bb b/recipes-ros/roscpp-core/roscpp-traits_0.3.16.bb
index f3c21f202580563026346057901e3033917cc418..9039bfd436ad932fc5008d97fc7ff5518d9747ef 100644
--- a/recipes-ros/roscpp-core/roscpp-traits_0.3.16.bb
+++ b/recipes-ros/roscpp-core/roscpp-traits_0.3.16.bb
@@ -4,5 +4,3 @@ LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
 
 require roscpp-core.inc
-
-S = "${WORKDIR}/roscpp_core-${PV}/${ROS_BPN}"
diff --git a/recipes-ros/rospack/rospack_2.1.21.bb b/recipes-ros/rospack/rospack_2.1.21.bb
index b172acb284de1140b49d8e6cf9688e46eedad969..3610377108928333232ee3f0483fc4732505ee80 100644
--- a/recipes-ros/rospack/rospack_2.1.21.bb
+++ b/recipes-ros/rospack/rospack_2.1.21.bb
@@ -4,6 +4,7 @@ LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=6;endline=6;md5=d566ef916e9dedc494f5f793a6690ba5"
 
 DEPENDS = "boost python-rospkg-native libtinyxml"
+RDEPENDS_${PN} = "python-rosdep python-subprocess"
 
 SRC_URI = "https://github.com/ros/${BPN}/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz"
 SRC_URI[md5sum] = "0bb1d12a115b7902d5b1f8546d63cdf8"