From a51044ef7bfa20c2a0ca958272f4f4283cfde966 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sun, 4 Aug 2013 11:04:29 +0200
Subject: [PATCH] cleaning up recipes-devtools/python recipes

---
 recipes-devtools/python/python-catkin-pkg_0.1.16.bb | 2 --
 recipes-devtools/python/python-empy_3.3.bb          | 5 -----
 recipes-devtools/python/python-pyyaml_3.10.bb       | 8 ++------
 recipes-devtools/python/python-rosinstall_0.6.21.bb | 2 --
 recipes-devtools/python/python-rospkg_1.0.15.bb     | 2 --
 recipes-devtools/python/python-vcstools_0.1.26.bb   | 2 --
 recipes-devtools/python/python-wstool_0.0.2.bb      | 1 -
 7 files changed, 2 insertions(+), 20 deletions(-)

diff --git a/recipes-devtools/python/python-catkin-pkg_0.1.16.bb b/recipes-devtools/python/python-catkin-pkg_0.1.16.bb
index b8cbc72..bc82fc2 100644
--- a/recipes-devtools/python/python-catkin-pkg_0.1.16.bb
+++ b/recipes-devtools/python/python-catkin-pkg_0.1.16.bb
@@ -12,6 +12,4 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 inherit distutils
 
-DEPENDS += "python"
-DEPENDS_class-native  += "python-native"
 BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-empy_3.3.bb b/recipes-devtools/python/python-empy_3.3.bb
index dd16e90..fb5e417 100644
--- a/recipes-devtools/python/python-empy_3.3.bb
+++ b/recipes-devtools/python/python-empy_3.3.bb
@@ -10,11 +10,6 @@ SRC_URI[sha256sum] = "c625436d03cff8adbbade639d14a2df9bc4c4de99ec3a821ad4d6eeb66
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# RDEPENDS = "python-modules"
-
 inherit distutils
 
-DEPENDS += "python"
-DEPENDS_class-native  += "python-native"
 BBCLASSEXTEND = "native"
-
diff --git a/recipes-devtools/python/python-pyyaml_3.10.bb b/recipes-devtools/python/python-pyyaml_3.10.bb
index bb8e26f..aacebaf 100644
--- a/recipes-devtools/python/python-pyyaml_3.10.bb
+++ b/recipes-devtools/python/python-pyyaml_3.10.bb
@@ -11,12 +11,8 @@ SRC_URI[sha256sum] = "e713da45c96ca53a3a8b48140d4120374db622df16ab71759c9ceb5b8d
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-inherit distutils
-
-DEPENDS += "python"
-DEPENDS_class-native  += "python-native"
-
 RDEPENDS_${PN} = "python-datetime"
 
-BBCLASSEXTEND = "native"
+inherit distutils
 
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-rosinstall_0.6.21.bb b/recipes-devtools/python/python-rosinstall_0.6.21.bb
index d955a1c..09e84c1 100644
--- a/recipes-devtools/python/python-rosinstall_0.6.21.bb
+++ b/recipes-devtools/python/python-rosinstall_0.6.21.bb
@@ -10,9 +10,7 @@ SRC_URI[sha256sum] = "7163106c93460c8d092c5e74749cefd3fc17295f3a06c4f041fe83a772
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# install_requires=['vcstools', 'pyyaml'],
 DEPENDS += "python-vcstools python-pyyaml"
 RDEPENDS_${PN} = "python-vcstools"
 
 inherit setuptools
-
diff --git a/recipes-devtools/python/python-rospkg_1.0.15.bb b/recipes-devtools/python/python-rospkg_1.0.15.bb
index a38a210..893bf03 100644
--- a/recipes-devtools/python/python-rospkg_1.0.15.bb
+++ b/recipes-devtools/python/python-rospkg_1.0.15.bb
@@ -14,6 +14,4 @@ RDEPENDS_${PN} += "python-xml"
 
 inherit setuptools
 
-DEPENDS += "python"
 BBCLASSEXTEND = "native"
-
diff --git a/recipes-devtools/python/python-vcstools_0.1.26.bb b/recipes-devtools/python/python-vcstools_0.1.26.bb
index ac2a3bc..3e57adc 100644
--- a/recipes-devtools/python/python-vcstools_0.1.26.bb
+++ b/recipes-devtools/python/python-vcstools_0.1.26.bb
@@ -10,8 +10,6 @@ SRC_URI[sha256sum] = "11cae4907609d3524655c7cdba66260821f69fd2ff2330ae93db35111c
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# install_requires=['pyyaml','python-dateutil']
 RDEPENDS_${PN} += "python-pyyaml python-dateutil"
 
 inherit setuptools
-
diff --git a/recipes-devtools/python/python-wstool_0.0.2.bb b/recipes-devtools/python/python-wstool_0.0.2.bb
index 1dd82b7..993ab1a 100644
--- a/recipes-devtools/python/python-wstool_0.0.2.bb
+++ b/recipes-devtools/python/python-wstool_0.0.2.bb
@@ -10,7 +10,6 @@ SRC_URI[sha256sum] = "487602f7d5bef1e0b759c60ab4b86db884dd2abfb756e1743ad4ae3754
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# install_requires=['vcstools', 'pyyaml', 'rosinstall'],
 RDEPENDS_${PN} += "python-vcstools python-pyyaml python-rosinstall"
 
 inherit setuptools
-- 
GitLab