diff --git a/recipes-devtools/python/python-catkin-pkg_0.1.16.bb b/recipes-devtools/python/python-catkin-pkg_0.1.16.bb
index b8cbc7251558b8372a0c34d879976fcb894410d2..bc82fc223149c3df3827fcf1431fec91d47b817d 100644
--- a/recipes-devtools/python/python-catkin-pkg_0.1.16.bb
+++ b/recipes-devtools/python/python-catkin-pkg_0.1.16.bb
@@ -12,6 +12,4 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 inherit distutils
 
-DEPENDS += "python"
-DEPENDS_class-native  += "python-native"
 BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-empy_3.3.bb b/recipes-devtools/python/python-empy_3.3.bb
index dd16e90ba77820b221fe17cd91c514cfce76339c..fb5e4178dd8500d967c7559655e8f27081095e93 100644
--- a/recipes-devtools/python/python-empy_3.3.bb
+++ b/recipes-devtools/python/python-empy_3.3.bb
@@ -10,11 +10,6 @@ SRC_URI[sha256sum] = "c625436d03cff8adbbade639d14a2df9bc4c4de99ec3a821ad4d6eeb66
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# RDEPENDS = "python-modules"
-
 inherit distutils
 
-DEPENDS += "python"
-DEPENDS_class-native  += "python-native"
 BBCLASSEXTEND = "native"
-
diff --git a/recipes-devtools/python/python-pyyaml_3.10.bb b/recipes-devtools/python/python-pyyaml_3.10.bb
index bb8e26f2e05b4b9c4ca3bc42bc8b5dd23d94dbb2..aacebafc81a1dbfea8a67ab502d66af85f3922bb 100644
--- a/recipes-devtools/python/python-pyyaml_3.10.bb
+++ b/recipes-devtools/python/python-pyyaml_3.10.bb
@@ -11,12 +11,8 @@ SRC_URI[sha256sum] = "e713da45c96ca53a3a8b48140d4120374db622df16ab71759c9ceb5b8d
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-inherit distutils
-
-DEPENDS += "python"
-DEPENDS_class-native  += "python-native"
-
 RDEPENDS_${PN} = "python-datetime"
 
-BBCLASSEXTEND = "native"
+inherit distutils
 
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-rosinstall_0.6.21.bb b/recipes-devtools/python/python-rosinstall_0.6.21.bb
index d955a1cd717b8f0b22f652bcf2e59089ec0afc36..09e84c14ee14d5ba74946b2d17d2066430b45bdd 100644
--- a/recipes-devtools/python/python-rosinstall_0.6.21.bb
+++ b/recipes-devtools/python/python-rosinstall_0.6.21.bb
@@ -10,9 +10,7 @@ SRC_URI[sha256sum] = "7163106c93460c8d092c5e74749cefd3fc17295f3a06c4f041fe83a772
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# install_requires=['vcstools', 'pyyaml'],
 DEPENDS += "python-vcstools python-pyyaml"
 RDEPENDS_${PN} = "python-vcstools"
 
 inherit setuptools
-
diff --git a/recipes-devtools/python/python-rospkg_1.0.15.bb b/recipes-devtools/python/python-rospkg_1.0.15.bb
index a38a21060136c75233ff339ac6be0f3dea676880..893bf03a75dc85be9ef7163fd9a3e85920f27ca2 100644
--- a/recipes-devtools/python/python-rospkg_1.0.15.bb
+++ b/recipes-devtools/python/python-rospkg_1.0.15.bb
@@ -14,6 +14,4 @@ RDEPENDS_${PN} += "python-xml"
 
 inherit setuptools
 
-DEPENDS += "python"
 BBCLASSEXTEND = "native"
-
diff --git a/recipes-devtools/python/python-vcstools_0.1.26.bb b/recipes-devtools/python/python-vcstools_0.1.26.bb
index ac2a3bc0256b3ad0f50f694d8b0c210e651d9f76..3e57adc3299044733aa233f58f1219960a90802e 100644
--- a/recipes-devtools/python/python-vcstools_0.1.26.bb
+++ b/recipes-devtools/python/python-vcstools_0.1.26.bb
@@ -10,8 +10,6 @@ SRC_URI[sha256sum] = "11cae4907609d3524655c7cdba66260821f69fd2ff2330ae93db35111c
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# install_requires=['pyyaml','python-dateutil']
 RDEPENDS_${PN} += "python-pyyaml python-dateutil"
 
 inherit setuptools
-
diff --git a/recipes-devtools/python/python-wstool_0.0.2.bb b/recipes-devtools/python/python-wstool_0.0.2.bb
index 1dd82b7a947448c6d12f438d0c3716038e23cdf2..993ab1ae9ffe49211116edeb06039d8e5d299005 100644
--- a/recipes-devtools/python/python-wstool_0.0.2.bb
+++ b/recipes-devtools/python/python-wstool_0.0.2.bb
@@ -10,7 +10,6 @@ SRC_URI[sha256sum] = "487602f7d5bef1e0b759c60ab4b86db884dd2abfb756e1743ad4ae3754
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# install_requires=['vcstools', 'pyyaml', 'rosinstall'],
 RDEPENDS_${PN} += "python-vcstools python-pyyaml python-rosinstall"
 
 inherit setuptools