diff --git a/install-groovy.sh b/install-groovy.sh
index c215af293ddd73e557d0bb74730e935863890382..5e142d59bfeb1e723edf67368baff70bc936c217 100644
--- a/install-groovy.sh
+++ b/install-groovy.sh
@@ -16,8 +16,31 @@ mkdir ros_catkin_ws
 cd ros_catkin_ws
 # extract
 tar -xzf ../src.tar.gz
+# patch catkin
+patch -p1 << EOF
+*** A/src/catkin/cmake/python.cmake	2013-01-04 14:22:33.223884756 +0100
+--- B/src/catkin/cmake/python.cmake	2013-01-04 14:28:01.971898385 +0100
+***************
+*** 6,12 ****
+  set(PYTHON_VERSION_XDOTY ${PYTHON_VERSION_XDOTY} CACHE STRING "Python version")
+  
+  #This should be resolved automatically one day...
+! option(SETUPTOOLS_DEB_LAYOUT "ON for debian style python packages layout" ON)
+  
+  if(APPLE OR MSVC)
+    set(SETUPTOOLS_DEB_LAYOUT OFF)
+--- 6,12 ----
+  set(PYTHON_VERSION_XDOTY ${PYTHON_VERSION_XDOTY} CACHE STRING "Python version")
+  
+  #This should be resolved automatically one day...
+! option(SETUPTOOLS_DEB_LAYOUT "ON for debian style python packages layout" OFF)
+  
+  if(APPLE OR MSVC)
+    set(SETUPTOOLS_DEB_LAYOUT OFF)
+EOF
 # compile, make and install
-catkin_make_isolated --install
+./src/catkin/bin/catkin_make_isolated --install
 # start roscore
 . install_isolated/setup.sh
 roscore
+
diff --git a/recipes-core/images/core-image-ros-groovy.bb b/recipes-core/images/core-image-ros-groovy.bb
index 319b042412123f2559e8b3e365cd0b27c6225eed..addbb36fff999258767452f9608744ed95157878 100644
--- a/recipes-core/images/core-image-ros-groovy.bb
+++ b/recipes-core/images/core-image-ros-groovy.bb
@@ -29,6 +29,5 @@ IMAGE_INSTALL += "packagegroup-core-ssh-openssh cmake \
   boost boost-dev python-dev libtinyxml libtinyxml-dev \
   log4cxx log4cxx-dev libbz2-dev \
   python-argparse python-rosdep python-wstool \
-  catkin \
-  roscpp-core \
-  "
+"
+