diff --git a/recipes-ros/ros-comm/roslaunch_1.10.12.bb b/recipes-ros/ros-comm/roslaunch_1.10.12.bb
index 8865cce8b3f5c1a9d4e7e852f23a323b28087d08..7e590354c2681aea32bf0316ac2adc2bbfa1fcdf 100644
--- a/recipes-ros/ros-comm/roslaunch_1.10.12.bb
+++ b/recipes-ros/ros-comm/roslaunch_1.10.12.bb
@@ -16,7 +16,6 @@ SRC_URI += "file://0001-increase-rosmaster-timeout.patch \
 ROS_PKG_SUBDIR = "tools"
 
 RDEPENDS_${PN} = "\
-    coreutils \
     python-textutils \
     python-logging \
     python-threading \
diff --git a/recipes-ros/ros/rosclean/0001-rosclean-Use-du-sk-1024-on-Linux-for-getting-disk-us.patch b/recipes-ros/ros/rosclean/0001-rosclean-Use-du-sk-1024-on-Linux-for-getting-disk-us.patch
new file mode 100644
index 0000000000000000000000000000000000000000..8948b0e31fa2416c1d60176297ccbbf85a46261b
--- /dev/null
+++ b/recipes-ros/ros/rosclean/0001-rosclean-Use-du-sk-1024-on-Linux-for-getting-disk-us.patch
@@ -0,0 +1,35 @@
+From 300ac79a86f580040a1676004e1e8758cc7c6781 Mon Sep 17 00:00:00 2001
+From: Alexis Ballier <aballier@gentoo.org>
+Date: Thu, 22 Jan 2015 09:56:41 +0100
+Subject: [PATCH] rosclean: Use "du -sk * 1024" on Linux for getting disk usage
+ since "du -b" is not supported by busybox du, while "du -k" is supported by
+ both coreutils and busybox.
+
+Upstream-Status: Submitted [https://github.com/ros/ros/pull/76]
+---
+ tools/rosclean/src/rosclean/__init__.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tools/rosclean/src/rosclean/__init__.py b/tools/rosclean/src/rosclean/__init__.py
+index 5dafb05..6f051f1 100644
+--- a/tools/rosclean/src/rosclean/__init__.py
++++ b/tools/rosclean/src/rosclean/__init__.py
+@@ -121,13 +121,13 @@ def get_disk_usage(d):
+     """
+     Get disk usage in bytes for directory
+     :param d: directory path, ``str``
+-    :returns: disk usage in bytes (du -b) or (du -A) * 1024, ``int``
++    :returns: disk usage in bytes (du -k) * 1024 or (du -A) * 1024, ``int``
+     :raises: :exc:`CleanupException` If get_disk_usage() cannot be used on this platform
+     """
+     # only implemented on Linux and FreeBSD for now. Should work on OS X but need to verify first (du is not identical)
+     if platform.system() == 'Linux':
+         try:
+-            return int(subprocess.Popen(['du', '-sb', d], stdout=subprocess.PIPE).communicate()[0].split()[0])
++            return int(subprocess.Popen(['du', '-sk', d], stdout=subprocess.PIPE).communicate()[0].split()[0]) * 1024
+         except:
+             raise CleanupException("rosclean is not supported on this platform")
+     elif platform.system() == 'FreeBSD':
+-- 
+1.9.3
+
diff --git a/recipes-ros/ros/rosclean_1.10.11.bb b/recipes-ros/ros/rosclean_1.10.11.bb
index e83895561e457864749df041822de8487582af92..3184c17a7e921f8ce15efe9a089efcee0c8dddc9 100644
--- a/recipes-ros/ros/rosclean_1.10.11.bb
+++ b/recipes-ros/ros/rosclean_1.10.11.bb
@@ -6,3 +6,5 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc
 require ros.inc
 
 ROS_PKG_SUBDIR = "tools"
+
+SRC_URI += "file://0001-rosclean-Use-du-sk-1024-on-Linux-for-getting-disk-us.patch;striplevel=3"