diff --git a/recipes-devtools/python/python-urlgrabber_3.9.1.bb b/recipes-devtools/python/python-urlgrabber_3.9.1.bb
new file mode 100644
index 0000000000000000000000000000000000000000..aeb792d5f8b4d19918690e7801171f0547837e94
--- /dev/null
+++ b/recipes-devtools/python/python-urlgrabber_3.9.1.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "A high-level cross-protocol url-grabber"
+SECTION = "devel/python"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=68ad62c64cc6c620126241fd429e68fe"
+SRCNAME = "urlgrabber"
+
+DEPENDS = "python-pycurl-native python-pycurl"
+
+SRC_URI = "https://pypi.python.org/packages/source/u/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "00c8359bf71062d0946bacea521f80b4"
+SRC_URI[sha256sum] = "4437076c8708e5754ea04540e46c7f4f233734ee3590bb8a96389264fb0650d0"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
diff --git a/recipes-ros/resource-retriever/resource-retriever_1.11.6.bb b/recipes-ros/resource-retriever/resource-retriever_1.11.6.bb
new file mode 100644
index 0000000000000000000000000000000000000000..fc15bffbed6f76ee2e3e3360171c057de4e3468d
--- /dev/null
+++ b/recipes-ros/resource-retriever/resource-retriever_1.11.6.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "This package retrieves data from url-format files such as \
+http://, ftp://, package:// file://, etc., and loads the data into memory."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=16;endline=16;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "curl rosconsole roslib"
+
+SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
+SRC_URI[md5sum] = "8cf8f6a42ea7853a8c7b6aba4f0d3211"
+SRC_URI[sha256sum] = "03e1d54d360273566539530328bdfa954a94e8f42effa7fff2ff7defbd0736ab"
+
+S = "${WORKDIR}/${ROS_SP}"
+
+inherit catkin
+
+RDEPENDS_${PN} = "python-urlgrabber"
diff --git a/recipes-ros/robot-model/collada-parser_1.10.21.bb b/recipes-ros/robot-model/collada-parser_1.11.7.bb
similarity index 100%
rename from recipes-ros/robot-model/collada-parser_1.10.21.bb
rename to recipes-ros/robot-model/collada-parser_1.11.7.bb
diff --git a/recipes-ros/robot-model/collada-urdf_1.10.21.bb b/recipes-ros/robot-model/collada-urdf_1.11.7.bb
similarity index 100%
rename from recipes-ros/robot-model/collada-urdf_1.10.21.bb
rename to recipes-ros/robot-model/collada-urdf_1.11.7.bb
diff --git a/recipes-ros/robot-model/joint-state-publisher_1.10.21.bb b/recipes-ros/robot-model/joint-state-publisher_1.11.7.bb
similarity index 100%
rename from recipes-ros/robot-model/joint-state-publisher_1.10.21.bb
rename to recipes-ros/robot-model/joint-state-publisher_1.11.7.bb
diff --git a/recipes-ros/robot-model/kdl-parser_1.10.21.bb b/recipes-ros/robot-model/kdl-parser_1.11.7.bb
similarity index 100%
rename from recipes-ros/robot-model/kdl-parser_1.10.21.bb
rename to recipes-ros/robot-model/kdl-parser_1.11.7.bb
diff --git a/recipes-ros/robot-model/resource-retriever_1.10.21.bb b/recipes-ros/robot-model/resource-retriever_1.10.21.bb
deleted file mode 100644
index 99bb5d72de3eaa2279deefcd72e5116abdea1910..0000000000000000000000000000000000000000
--- a/recipes-ros/robot-model/resource-retriever_1.10.21.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-DESCRIPTION = "This package retrieves data from url-format files such as http://, ftp://, package:// file://, etc., and loads the data into memory. The package:// url for ros packages is translated into a local file:// url.  The resourse retriever was initially designed to load mesh files into memory, but it can be used for any type of data. The resource retriever is based on the the libcurl library."
-SECTION = "devel"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://package.xml;beginline=16;endline=16;md5=d566ef916e9dedc494f5f793a6690ba5"
-
-DEPENDS = "curl rosconsole roslib"
-
-require robot-model.inc
diff --git a/recipes-ros/robot-model/robot-model.inc b/recipes-ros/robot-model/robot-model.inc
index 6f99d15e6754ff2146a4338503134edb28bdef35..d3d2f1f8f46e6732fa11a23a548c85becf583356 100644
--- a/recipes-ros/robot-model/robot-model.inc
+++ b/recipes-ros/robot-model/robot-model.inc
@@ -1,6 +1,6 @@
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "724cccac0a381e97df80ef42c2c6dd4f"
-SRC_URI[sha256sum] = "a1a42385799a713d1d57bee14bdad5890c8cf5983888ed310d54cdccec64ebba"
+SRC_URI[md5sum] = "60b0e4fe9027f4de1d10765e57f62620"
+SRC_URI[sha256sum] = "a076e1a148b136f856f1fdf48225458ec1f3d6cd405e153f81a5c388943dfb2e"
 
 S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
 
diff --git a/recipes-ros/robot-model/urdf-parser-plugin_1.10.21.bb b/recipes-ros/robot-model/urdf-parser-plugin_1.11.7.bb
similarity index 100%
rename from recipes-ros/robot-model/urdf-parser-plugin_1.10.21.bb
rename to recipes-ros/robot-model/urdf-parser-plugin_1.11.7.bb
diff --git a/recipes-ros/robot-model/urdf_1.10.21.bb b/recipes-ros/robot-model/urdf_1.11.7.bb
similarity index 100%
rename from recipes-ros/robot-model/urdf_1.10.21.bb
rename to recipes-ros/robot-model/urdf_1.11.7.bb