From 9dda5d0beb923342a5a8becb7986f0b34a3cbdef Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@bmw-carit.de>
Date: Fri, 8 Feb 2013 13:46:10 +0100
Subject: [PATCH] using BBCLASSEXTEND = "native" and removing the separate
 native package files (thanks to Stefan Herbrechtsmeier for this hint)

---
 recipes-devtools/python/python-catkin-pkg-native_0.1.8.bb | 4 ----
 recipes-devtools/python/python-catkin-pkg_0.1.8.bb        | 4 ++++
 recipes-devtools/python/python-empy-native_3.3.bb         | 4 ----
 recipes-devtools/python/python-empy_3.3.bb                | 5 +++++
 recipes-devtools/python/python-nose-native_1.2.1.bb       | 4 ----
 recipes-devtools/python/python-nose_1.2.1.bb              | 5 +++++
 recipes-devtools/python/python-pyyaml-native_3.10.bb      | 4 ----
 recipes-devtools/python/python-pyyaml_3.10.bb             | 5 +++++
 recipes-devtools/python/python-rospkg-native_1.0.15.bb    | 4 ----
 recipes-devtools/python/python-rospkg_1.0.15.bb           | 5 +++++
 10 files changed, 24 insertions(+), 20 deletions(-)
 delete mode 100644 recipes-devtools/python/python-catkin-pkg-native_0.1.8.bb
 delete mode 100644 recipes-devtools/python/python-empy-native_3.3.bb
 delete mode 100644 recipes-devtools/python/python-nose-native_1.2.1.bb
 delete mode 100644 recipes-devtools/python/python-pyyaml-native_3.10.bb
 delete mode 100644 recipes-devtools/python/python-rospkg-native_1.0.15.bb

diff --git a/recipes-devtools/python/python-catkin-pkg-native_0.1.8.bb b/recipes-devtools/python/python-catkin-pkg-native_0.1.8.bb
deleted file mode 100644
index fdb3b49..0000000
--- a/recipes-devtools/python/python-catkin-pkg-native_0.1.8.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require python-catkin-pkg_${PV}.bb
-inherit native pythonnative
-DEPENDS = "python-native"
-RDEPENDS_${PN} = ""
diff --git a/recipes-devtools/python/python-catkin-pkg_0.1.8.bb b/recipes-devtools/python/python-catkin-pkg_0.1.8.bb
index a89019a..b8370d3 100644
--- a/recipes-devtools/python/python-catkin-pkg_0.1.8.bb
+++ b/recipes-devtools/python/python-catkin-pkg_0.1.8.bb
@@ -11,3 +11,7 @@ SRC_URI[sha256sum] = "06fa265610333f8e37e1ed7c93075ddcbf7a3c26190dfd53ebb4d4cce3
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 inherit distutils
+
+DEPENDS += "python"
+DEPENDS_class-native  += "python-native"
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-empy-native_3.3.bb b/recipes-devtools/python/python-empy-native_3.3.bb
deleted file mode 100644
index 9157999..0000000
--- a/recipes-devtools/python/python-empy-native_3.3.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require python-empy_${PV}.bb
-inherit native pythonnative
-DEPENDS = "python-native"
-RDEPENDS_${PN} = ""
diff --git a/recipes-devtools/python/python-empy_3.3.bb b/recipes-devtools/python/python-empy_3.3.bb
index 73b710a..08ab115 100644
--- a/recipes-devtools/python/python-empy_3.3.bb
+++ b/recipes-devtools/python/python-empy_3.3.bb
@@ -13,3 +13,8 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
 RDEPENDS = "python-modules"
 
 inherit distutils
+
+DEPENDS += "python"
+DEPENDS_class-native  += "python-native"
+BBCLASSEXTEND = "native"
+
diff --git a/recipes-devtools/python/python-nose-native_1.2.1.bb b/recipes-devtools/python/python-nose-native_1.2.1.bb
deleted file mode 100644
index 05cfd42..0000000
--- a/recipes-devtools/python/python-nose-native_1.2.1.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require python-nose_${PV}.bb
-inherit native pythonnative
-DEPENDS = "python-native"
-RDEPENDS_${PN} = ""
diff --git a/recipes-devtools/python/python-nose_1.2.1.bb b/recipes-devtools/python/python-nose_1.2.1.bb
index 19af5bf..a365e9f 100644
--- a/recipes-devtools/python/python-nose_1.2.1.bb
+++ b/recipes-devtools/python/python-nose_1.2.1.bb
@@ -12,3 +12,8 @@ SRC_URI[sha256sum] = "2171e9202d118d302d5db1decb52dd862b79e2a626ca19653a6914574a
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 inherit distutils
+
+DEPENDS += "python"
+DEPENDS_class-native  += "python-native"
+BBCLASSEXTEND = "native"
+
diff --git a/recipes-devtools/python/python-pyyaml-native_3.10.bb b/recipes-devtools/python/python-pyyaml-native_3.10.bb
deleted file mode 100644
index 5ddefc4..0000000
--- a/recipes-devtools/python/python-pyyaml-native_3.10.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require python-pyyaml_${PV}.bb
-inherit native pythonnative
-DEPENDS = "python-native"
-RDEPENDS_${PN} = ""
diff --git a/recipes-devtools/python/python-pyyaml_3.10.bb b/recipes-devtools/python/python-pyyaml_3.10.bb
index 139b2c8..96e7f87 100644
--- a/recipes-devtools/python/python-pyyaml_3.10.bb
+++ b/recipes-devtools/python/python-pyyaml_3.10.bb
@@ -12,3 +12,8 @@ SRC_URI[sha256sum] = "e713da45c96ca53a3a8b48140d4120374db622df16ab71759c9ceb5b8d
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 inherit distutils
+
+DEPENDS += "python"
+DEPENDS_class-native  += "python-native"
+BBCLASSEXTEND = "native"
+
diff --git a/recipes-devtools/python/python-rospkg-native_1.0.15.bb b/recipes-devtools/python/python-rospkg-native_1.0.15.bb
deleted file mode 100644
index c320257..0000000
--- a/recipes-devtools/python/python-rospkg-native_1.0.15.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require python-rospkg_${PV}.bb
-inherit native pythonnative
-DEPENDS = "python-native"
-RDEPENDS_${PN} = ""
diff --git a/recipes-devtools/python/python-rospkg_1.0.15.bb b/recipes-devtools/python/python-rospkg_1.0.15.bb
index 718011d..f960cac 100644
--- a/recipes-devtools/python/python-rospkg_1.0.15.bb
+++ b/recipes-devtools/python/python-rospkg_1.0.15.bb
@@ -13,3 +13,8 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
 RDEPENDS_${PN} += "python-modules"
 
 inherit setuptools
+
+DEPENDS += "python"
+DEPENDS_class-native  += "python-native"
+BBCLASSEXTEND = "native"
+
-- 
GitLab