diff --git a/recipes-devtools/python/python-catkin-pkg-native_0.1.8.bb b/recipes-devtools/python/python-catkin-pkg-native_0.1.8.bb
deleted file mode 100644
index fdb3b49ce34a9ca3ec4ca84862e1639ea8081109..0000000000000000000000000000000000000000
--- a/recipes-devtools/python/python-catkin-pkg-native_0.1.8.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require python-catkin-pkg_${PV}.bb
-inherit native pythonnative
-DEPENDS = "python-native"
-RDEPENDS_${PN} = ""
diff --git a/recipes-devtools/python/python-catkin-pkg_0.1.8.bb b/recipes-devtools/python/python-catkin-pkg_0.1.8.bb
index a89019a9feb492093a3823da597fdd16b3b92902..b8370d337e6061f79e7fe41d33c6aa3ea6af6d7f 100644
--- a/recipes-devtools/python/python-catkin-pkg_0.1.8.bb
+++ b/recipes-devtools/python/python-catkin-pkg_0.1.8.bb
@@ -11,3 +11,7 @@ SRC_URI[sha256sum] = "06fa265610333f8e37e1ed7c93075ddcbf7a3c26190dfd53ebb4d4cce3
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 inherit distutils
+
+DEPENDS += "python"
+DEPENDS_class-native  += "python-native"
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-empy-native_3.3.bb b/recipes-devtools/python/python-empy-native_3.3.bb
deleted file mode 100644
index 915799980d8b66a46be94d580b13a46a8d35898a..0000000000000000000000000000000000000000
--- a/recipes-devtools/python/python-empy-native_3.3.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require python-empy_${PV}.bb
-inherit native pythonnative
-DEPENDS = "python-native"
-RDEPENDS_${PN} = ""
diff --git a/recipes-devtools/python/python-empy_3.3.bb b/recipes-devtools/python/python-empy_3.3.bb
index 73b710a3c08429785da5e0cacbaba26437ab828e..08ab1154288640328ceea10146112d36f81a941e 100644
--- a/recipes-devtools/python/python-empy_3.3.bb
+++ b/recipes-devtools/python/python-empy_3.3.bb
@@ -13,3 +13,8 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
 RDEPENDS = "python-modules"
 
 inherit distutils
+
+DEPENDS += "python"
+DEPENDS_class-native  += "python-native"
+BBCLASSEXTEND = "native"
+
diff --git a/recipes-devtools/python/python-nose-native_1.2.1.bb b/recipes-devtools/python/python-nose-native_1.2.1.bb
deleted file mode 100644
index 05cfd428995dd889517eb5fe4a3153f5676a0eba..0000000000000000000000000000000000000000
--- a/recipes-devtools/python/python-nose-native_1.2.1.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require python-nose_${PV}.bb
-inherit native pythonnative
-DEPENDS = "python-native"
-RDEPENDS_${PN} = ""
diff --git a/recipes-devtools/python/python-nose_1.2.1.bb b/recipes-devtools/python/python-nose_1.2.1.bb
index 19af5bf9dec21eeba71fd12ec9d216addf23675d..a365e9f9bc1b49a3237ac6602c702b54b85e477c 100644
--- a/recipes-devtools/python/python-nose_1.2.1.bb
+++ b/recipes-devtools/python/python-nose_1.2.1.bb
@@ -12,3 +12,8 @@ SRC_URI[sha256sum] = "2171e9202d118d302d5db1decb52dd862b79e2a626ca19653a6914574a
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 inherit distutils
+
+DEPENDS += "python"
+DEPENDS_class-native  += "python-native"
+BBCLASSEXTEND = "native"
+
diff --git a/recipes-devtools/python/python-pyyaml-native_3.10.bb b/recipes-devtools/python/python-pyyaml-native_3.10.bb
deleted file mode 100644
index 5ddefc41ec754fb2d0f55e2cddf25c22104e406b..0000000000000000000000000000000000000000
--- a/recipes-devtools/python/python-pyyaml-native_3.10.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require python-pyyaml_${PV}.bb
-inherit native pythonnative
-DEPENDS = "python-native"
-RDEPENDS_${PN} = ""
diff --git a/recipes-devtools/python/python-pyyaml_3.10.bb b/recipes-devtools/python/python-pyyaml_3.10.bb
index 139b2c8b261fb0111559f46a4c9903acc2a91cc8..96e7f873942793c606e503e1c6180640d395ea78 100644
--- a/recipes-devtools/python/python-pyyaml_3.10.bb
+++ b/recipes-devtools/python/python-pyyaml_3.10.bb
@@ -12,3 +12,8 @@ SRC_URI[sha256sum] = "e713da45c96ca53a3a8b48140d4120374db622df16ab71759c9ceb5b8d
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 inherit distutils
+
+DEPENDS += "python"
+DEPENDS_class-native  += "python-native"
+BBCLASSEXTEND = "native"
+
diff --git a/recipes-devtools/python/python-rospkg-native_1.0.15.bb b/recipes-devtools/python/python-rospkg-native_1.0.15.bb
deleted file mode 100644
index c32025720f138cc4aa28dfb99b0a6379e6647e03..0000000000000000000000000000000000000000
--- a/recipes-devtools/python/python-rospkg-native_1.0.15.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require python-rospkg_${PV}.bb
-inherit native pythonnative
-DEPENDS = "python-native"
-RDEPENDS_${PN} = ""
diff --git a/recipes-devtools/python/python-rospkg_1.0.15.bb b/recipes-devtools/python/python-rospkg_1.0.15.bb
index 718011d93486239b71ceb94f9e3415e581ce2340..f960cac9b070f9b6eb787d821ed480dbf28fadb4 100644
--- a/recipes-devtools/python/python-rospkg_1.0.15.bb
+++ b/recipes-devtools/python/python-rospkg_1.0.15.bb
@@ -13,3 +13,8 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
 RDEPENDS_${PN} += "python-modules"
 
 inherit setuptools
+
+DEPENDS += "python"
+DEPENDS_class-native  += "python-native"
+BBCLASSEXTEND = "native"
+