diff --git a/meta/recipes-core/images/core-image-bmw.bb b/meta/recipes-core/images/core-image-bmw.bb
index 1e235ddef28c6eb1ea9e3a6a6195a978c3bcc849..3922b2f9cbd7027c07a174ed0368f954a7bc553b 100644
--- a/meta/recipes-core/images/core-image-bmw.bb
+++ b/meta/recipes-core/images/core-image-bmw.bb
@@ -13,4 +13,4 @@ IMAGE_ROOTFS_EXTRA_SPACE = "524288"
 # remove not needed ipkg informations
 ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; "
 
-IMAGE_INSTALL += "boost packagegroup-core-ssh-openssh dhcp-client file ldd python-setuptools python-modules python-rospkg python-pyyaml"
+IMAGE_INSTALL += "boost packagegroup-core-ssh-openssh dhcp-client file ldd python-modules python-setuptools python-rospkg python-rosinstall git cmake python-empy"
diff --git a/meta/recipes-devtools/python/python-empy_3.3.bb b/meta/recipes-devtools/python/python-empy_3.3.bb
new file mode 100644
index 0000000000000000000000000000000000000000..cd2214ba01b01c89b83331139aa6ffaf47e1742c
--- /dev/null
+++ b/meta/recipes-devtools/python/python-empy_3.3.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "A powerful and robust templating system for Python"
+SECTION = "devel/python"
+LICENSE = "LGPL"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
+SRCNAME = "empy"
+
+SRC_URI = "http://www.alcyone.com/software/empy/empy-latest.tar.gz"
+SRC_URI[md5sum] = "e7b518a6fc4fd28fef87726cdb003118"
+SRC_URI[sha256sum] = "c625436d03cff8adbbade639d14a2df9bc4c4de99ec3a821ad4d6eeb66ade805"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+RDEPENDS = "python-modules"
+
+inherit distutils
\ No newline at end of file
diff --git a/meta/recipes-devtools/python/python-rosinstall_0.6.21.bb b/meta/recipes-devtools/python/python-rosinstall_0.6.21.bb
new file mode 100644
index 0000000000000000000000000000000000000000..03c90437eabe3ad424f07033f6c8815e90a6ec82
--- /dev/null
+++ b/meta/recipes-devtools/python/python-rosinstall_0.6.21.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "The installer for ROS"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=7184a9afd29fc7d6490a284f23c5365e"
+SRCNAME = "rosinstall"
+
+SRC_URI = "http://pr.willowgarage.com/downloads/rosinstall/rosinstall-0.6.21.tar.gz"
+SRC_URI[md5sum] = "079784ac80779f17dab699087103a2c3"
+SRC_URI[sha256sum] = "7163106c93460c8d092c5e74749cefd3fc17295f3a06c4f041fe83a772a86d14"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+