From 9262d74262097805396820740eb1e4700bbc7732 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@bmw-carit.de>
Date: Wed, 30 Jan 2013 13:31:25 +0100
Subject: [PATCH] improving catkin-native, but it remains unclear what the
 difference between BBCLASSEXTEND += native and inherit native is and which
 one we should use.

---
 recipes-ros/catkin/catkin-native_0.5.58.bb | 13 ++++++++++++-
 1 file changed, 12 insertions(+), 1 deletion(-)

diff --git a/recipes-ros/catkin/catkin-native_0.5.58.bb b/recipes-ros/catkin/catkin-native_0.5.58.bb
index 0896782..77a5c2b 100644
--- a/recipes-ros/catkin/catkin-native_0.5.58.bb
+++ b/recipes-ros/catkin/catkin-native_0.5.58.bb
@@ -9,6 +9,7 @@ SRC_URI[md5sum] = "e4df85e60dc792af9324334547cc76aa"
 SRC_URI[sha256sum] = "dd99cc04eeaf16a13185dd0a2f576939fa997dfb16a40ba45068c4d2ebbcb44b"
 
 # DEPENDS = "python-setuptools"
+DEPENDS = "python-empy-native python-catkin-pkg-native"
 
 EXTRA_OECMAKE = "-DSETUPTOOLS_DEB_LAYOUT=OFF"
 
@@ -16,9 +17,19 @@ inherit cmake pythonnative python-dir
 
 FILES_${PN} += "${libdir}/${PYTHON_DIR}/* ${PYTHON_SITEPACKAGES_DIR}/*"
 
+# catkin_EXTRAS_DIR = ${PROJECT_SPACE_DIR}/share/${PROJECT_NAME}/cmake
+# export catkin_EXTRAS_DIR
+
 export BUILD_SYS
 export HOST_SYS
 export STAGING_LIBDIR
 export STAGING_INCDIR
 
-BBCLASSEXTEND += "native"
+### OPEN QUESTION: use
+# inherit native
+# or use
+# BBCLASSEXTEND += "native"
+## TODO: what is the difference?
+
+inherit native
+#BBCLASSEXTEND += "native"
-- 
GitLab