From 8fed418521016317b2d49c3115becf66ee8a4a6d Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@bmw-carit.de>
Date: Thu, 3 Jan 2013 10:52:14 +0100
Subject: [PATCH] experimental image for ros-groovy

---
 recipes-core/images/core-image-ros-groovy.bb | 27 ++++++++++++++++++++
 1 file changed, 27 insertions(+)
 create mode 100644 recipes-core/images/core-image-ros-groovy.bb

diff --git a/recipes-core/images/core-image-ros-groovy.bb b/recipes-core/images/core-image-ros-groovy.bb
new file mode 100644
index 0000000..be4b57c
--- /dev/null
+++ b/recipes-core/images/core-image-ros-groovy.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A small image just capable of allowing a device to boot."
+
+IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
+
+IMAGE_LINGUAS = " "
+
+LICENSE = "CLOSED"
+
+inherit core-image
+
+IMAGE_ROOTFS_EXTRA_SPACE = "524288"
+
+IMAGE_FEATURES += "tools-sdk"
+
+# add own name to hosts
+augment_hosts_setting_file () {
+	echo '127.0.0.1\tqemux86.localdomain\t\tqemux86' >> ${IMAGE_ROOTFS}/etc/hosts
+}
+
+# remove not needed ipkg informations
+# create a custom hosts file
+ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; "
+
+IMAGE_INSTALL += "packagegroup-core-ssh-openssh git cmake \
+  boost boost-dev log4cxx log4cxx-dev libbz2-dev \
+  python-modules python-empy python-pyyaml python-nose \
+  python-setuptools python-rospkg python-dateutil python-vcstools python-rosinstall"
-- 
GitLab