diff --git a/recipes-ros/octomap/octomap.inc b/recipes-ros/octomap/octomap.inc
new file mode 100644
index 0000000000000000000000000000000000000000..774e89d987136f7344427120a480572626b54ff6
--- /dev/null
+++ b/recipes-ros/octomap/octomap.inc
@@ -0,0 +1,9 @@
+SRC_URI = "https://github.com/OctoMap/${ROS_SPN}/archive/v${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
+SRC_URI[md5sum] = "b4ea2f354e286c48263543dac42cf555"
+SRC_URI[sha256sum] = "c68b75913ea5ebeb5459eaf2114801477aeaa2a584b018b8816f8a510150e76e"
+
+S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
+
+inherit cmake ros
+
+ROS_SPN = "octomap"
diff --git a/recipes-ros/octomap/octomap_1.6.1.bb b/recipes-ros/octomap/octomap_1.6.1.bb
new file mode 100644
index 0000000000000000000000000000000000000000..bc05817fbe90615c25c956b39d3b32e683dc89a8
--- /dev/null
+++ b/recipes-ros/octomap/octomap_1.6.1.bb
@@ -0,0 +1,6 @@
+DESCRIPTION = "The OctoMap library implements a 3D occupancy grid mapping approach, providing data structures and mapping algorithms in C++."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9b0e1f01a68f441eeaf7b5e18812d3c8"
+
+require octomap.inc