From 8c0cef057c6afd5ba2a89098cc285fb00a2cab60 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@bmw-carit.de>
Date: Fri, 21 Dec 2012 11:29:06 +0100
Subject: [PATCH] tried to add python-vcstools via dependency in
 python-rosinstall but it does not do and then added it the core-image
 instead; tuned layout and order in core-image

---
 recipes-core/images/core-image-ros.bb               | 5 ++++-
 recipes-devtools/python/python-rosinstall_0.6.21.bb | 2 ++
 2 files changed, 6 insertions(+), 1 deletion(-)

diff --git a/recipes-core/images/core-image-ros.bb b/recipes-core/images/core-image-ros.bb
index 36c2149..59fa58b 100644
--- a/recipes-core/images/core-image-ros.bb
+++ b/recipes-core/images/core-image-ros.bb
@@ -24,4 +24,7 @@ create_python_easy_install_pth_file () {
 # create a custom hosts file
 ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; create_python_easy_install_pth_file ; "
 
-IMAGE_INSTALL += "boost boost-dev packagegroup-core-ssh-openssh python-modules python-setuptools python-rospkg python-rosinstall git cmake python-empy python-pyyaml python-nose log4cxx log4cxx-dev libbz2-dev"
+IMAGE_INSTALL += "packagegroup-core-ssh-openssh git cmake \
+  boost boost-dev log4cxx log4cxx-dev libbz2-dev \
+  python-modules python-empy python-pyyaml python-nose \
+  python-setuptools python-rospkg python-vcstools python-rosinstall"
diff --git a/recipes-devtools/python/python-rosinstall_0.6.21.bb b/recipes-devtools/python/python-rosinstall_0.6.21.bb
index c4a2fe0..13fcb83 100644
--- a/recipes-devtools/python/python-rosinstall_0.6.21.bb
+++ b/recipes-devtools/python/python-rosinstall_0.6.21.bb
@@ -10,5 +10,7 @@ SRC_URI[sha256sum] = "7163106c93460c8d092c5e74749cefd3fc17295f3a06c4f041fe83a772
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
+DEPENDS += "python-vcstools"
+
 inherit setuptools
 
-- 
GitLab