From 7e00b874d9962ea591ba40793ad6bd1c9d8681c8 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@bmw-carit.de>
Date: Thu, 31 Jan 2013 14:34:20 +0100
Subject: [PATCH] adding the rostime recipe that relies on ros-cpp-common,
 trying to model the dependency of two ROS packages as dependency of two
 bitbake recipes

---
 recipes-ros/rostime/rostime_0.3.12.bb | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 recipes-ros/rostime/rostime_0.3.12.bb

diff --git a/recipes-ros/rostime/rostime_0.3.12.bb b/recipes-ros/rostime/rostime_0.3.12.bb
new file mode 100644
index 0000000..3c009f3
--- /dev/null
+++ b/recipes-ros/rostime/rostime_0.3.12.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Time and Duration implementations for C++ libraries, including roscpp."
+SECTION = "devel"
+# TODO: License of cpp_common not mentioned in the file
+LICENSE = "CLOSED"
+
+SRC_URI = "https://github.com/ros-gbp/roscpp_core-release/archive/release/rostime/0.3.12.tar.gz"
+SRC_URI[md5sum] = "ad80d12cf7dac87e7a5ef4573ced9db7"
+SRC_URI[sha256sum] = "887a89406d9682dc49c4049b4fe0766b6613208fd9df95a0efa55579b93cc965"
+
+S = "${WORKDIR}/roscpp_core-release-release-rostime-0.3.12"
+
+DEPENDS = "catkin-native boost ros-cpp-common"
+RDEPENDS = "boost ros-cpp-common"
+
+FILES_${PN} += "${libdir}/*"
+
+inherit cmake pythonnative
+
+EXTRA_OECMAKE = "-DCMAKE_PREFIX_PATH=/home/lukas/poky-danny-8.0/build/tmp/sysroots/qemux86/usr/share/cpp_common/cmake/ \
+  -Dcpp_common_DIR=/home/lukas/poky-danny-8.0/build/tmp/sysroots/qemux86/usr/share/cpp_common/cmake/"
-- 
GitLab