From 7b6451687bcb09351ed016b6d87669b8d547bbb4 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@bmw-carit.de>
Date: Tue, 2 Apr 2013 15:02:22 +0200
Subject: [PATCH] roslaunch: adding all runtime dependencies to get roscore
 starting up

For starting roscore, it requires a number of runtime dependencies.
At the moment, all runtime dependencies, even recursive runtime dependencies,
are added only in the roslaunch recipe. Hence, the recipe contains all
runtime dependencies.
At a later stage, one should move the recursive runtime dependencies into
the appropriate recipes.
---
 recipes-ros/ros-comm/roslaunch_1.9.41.bb | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

diff --git a/recipes-ros/ros-comm/roslaunch_1.9.41.bb b/recipes-ros/ros-comm/roslaunch_1.9.41.bb
index 2e34572..03c0c0d 100644
--- a/recipes-ros/ros-comm/roslaunch_1.9.41.bb
+++ b/recipes-ros/ros-comm/roslaunch_1.9.41.bb
@@ -3,6 +3,23 @@ via SSH, as well as setting parameters on the Parameter Server."
 SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=16;endline=16;md5=d566ef916e9dedc494f5f793a6690ba5"
+RDEPENDS_${PN} = "\
+  python-textutils \
+  python-logging \
+  python-threading \
+  python-rospkg \
+  rosgraph \
+  python-pyyaml \
+  roslib \
+  catkin \
+  python-catkin-pkg \
+  rosclean \
+  rosmaster \
+  rosgraph-msgs \
+    genpy \
+      genmsg \
+    std-msgs \
+"
 
 require ros-comm.inc
 
-- 
GitLab