diff --git a/recipes-ros/ros-comm/rosconsole/0001-Add-Include-vector-to-fix-building-on-GCC-6.patch b/recipes-ros/ros-comm/rosconsole/0001-Add-Include-vector-to-fix-building-on-GCC-6.patch
new file mode 100644
index 0000000000000000000000000000000000000000..764a3373eee3b4b28e5bd4f1264ac93101afacc7
--- /dev/null
+++ b/recipes-ros/ros-comm/rosconsole/0001-Add-Include-vector-to-fix-building-on-GCC-6.patch
@@ -0,0 +1,34 @@
+From 74674c49a64abbdcdd5aeea016997af2959c6f05 Mon Sep 17 00:00:00 2001
+From: Hodorgasm <nsane457@gmail.com>
+Date: Mon, 3 Oct 2016 20:32:20 -0400
+Subject: [PATCH] Add '#Include <vector>' to fix building on GCC-6
+
+Don't rely on transitive header inclusion to declare std::vector as building with GCC-6 fails due to no '#Include <vector>' statement.
+
+Upstream-Status: Backport [https://github.com/ros/ros_comm/commit/74674c49a64abbdcdd5aeea016997af2959c6f05]
+
+This patch has been generated with:
+  `git format-patch -1 74674c49a64abbdcdd5aeea016997af2959c6f05`
+in the kinetic branch of the ros_comm repository.
+This patch applies without modifications to the indigo release 1.11.20.
+
+Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+---
+ tools/rosconsole/include/ros/console.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tools/rosconsole/include/ros/console.h b/tools/rosconsole/include/ros/console.h
+index 4d2a86b..28901d7 100644
+--- a/tools/rosconsole/include/ros/console.h
++++ b/tools/rosconsole/include/ros/console.h
+@@ -40,6 +40,7 @@
+ #include <cstdarg>
+ #include <ros/macros.h>
+ #include <map>
++#include <vector>
+ 
+ #ifdef ROSCONSOLE_BACKEND_LOG4CXX
+ #include "log4cxx/level.h"
+-- 
+2.5.5
+
diff --git a/recipes-ros/ros-comm/rosconsole_1.11.20.bb b/recipes-ros/ros-comm/rosconsole_1.11.20.bb
index 2aa1631edc41c5c933c920fafb43028a1e7b4acb..3a7bce327769b9d96b9bc2fcd2265093ce97a046 100644
--- a/recipes-ros/ros-comm/rosconsole_1.11.20.bb
+++ b/recipes-ros/ros-comm/rosconsole_1.11.20.bb
@@ -8,3 +8,5 @@ DEPENDS = "apr boost cpp-common log4cxx rostime rosunit"
 require ros-comm.inc
 
 ROS_PKG_SUBDIR = "tools"
+
+SRC_URI += "file://0001-Add-Include-vector-to-fix-building-on-GCC-6.patch;striplevel=3"