diff --git a/meta/classes/distutils.bbclass b/meta/classes/distutils.bbclass
index 0b417236fe913a7318483c745a977136302b0a24..f67297e3ba3441a727966829766ca56e9c6d4c92 100644
--- a/meta/classes/distutils.bbclass
+++ b/meta/classes/distutils.bbclass
@@ -58,12 +58,8 @@ distutils_do_install() {
                 sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i
             done
         fi
-        
-        if test -e ${D}${PYTHON_SITEPACKAGES_DIR}/easy-install.pth; then
-            echo "easy-install.pth exists"
-            cat ${D}${PYTHON_SITEPACKAGES_DIR}/easy-install.pth
-        fi
-        # rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/easy-install.pth
+
+        rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/easy-install.pth
         
         #
         # FIXME: Bandaid against wrong datadir computation
diff --git a/meta/recipes-core/images/core-image-bmw.bb b/meta/recipes-core/images/core-image-bmw.bb
index d3d19edf41fe1d0113316b62e1a1d2e4282a3b21..0e9e58d5496b8474e5104824bb6a8783220aab60 100644
--- a/meta/recipes-core/images/core-image-bmw.bb
+++ b/meta/recipes-core/images/core-image-bmw.bb
@@ -19,4 +19,4 @@ augment_hosts_setting_file () {
 # create a custom hosts file
 ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; "
 
-IMAGE_INSTALL += "boost boost-dev packagegroup-core-ssh-openssh dhcp-client file ldd python-modules python-rospkg python-rosinstall git cmake python-empy python-pyyaml python-nose log4cxx log4cxx-dev libbz2-dev python-setuptools"
+IMAGE_INSTALL += "boost boost-dev packagegroup-core-ssh-openssh dhcp-client file ldd python-modules python-setuptools python-rospkg python-rosinstall git cmake python-empy python-pyyaml python-nose log4cxx log4cxx-dev libbz2-dev"
diff --git a/meta/recipes-devtools/python/python-rospkg_1.0.15.bb b/meta/recipes-devtools/python/python-rospkg_1.0.15.bb
index 45f7ba9cf40b6f0f7c8e3f4c52e674ea3b35c57e..476e1176b71625b7cbe92d19213ce00dea00ae32 100644
--- a/meta/recipes-devtools/python/python-rospkg_1.0.15.bb
+++ b/meta/recipes-devtools/python/python-rospkg_1.0.15.bb
@@ -3,7 +3,6 @@ SECTION = "devel/python"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://PKG-INFO;md5=083869c8da6fdf8c3a5bbd7d1bf93cac"
 SRCNAME = "rospkg"
-DEPENDS = "python-setuptools"
 
 SRC_URI = "http://pypi.python.org/packages/source/r/rospkg/rospkg-1.0.15.tar.gz"
 SRC_URI[md5sum] = "3c9b1b8d1e90950944b3f10bad16ecff"