diff --git a/README b/README
index 89ba172523309ec0c9cf391ea6e4701c11a9916d..39aadd0f636f601f8c5a361871074e29a89b0b30 100644
--- a/README
+++ b/README
@@ -29,7 +29,6 @@ STATE OF THIS WORK:
   This repository provides
   - Native compilation of ROS-fuerte
   - Native compilation of ROS-groovy
-  - Attempt of cross-compilation of ROS-fuerte (discontinued)
   - Cross-compilation of catkin 0.5.58 (shipped with ROS-groovy)
   - catkin 0.5.58 setup for cross-compiling catkin packages
   - Attempt of cross-compilation of ROS-groovy (in development)
@@ -89,30 +88,6 @@ USE for native compilation of ROS-groovy on the qemu VM:
   The installation script installs ros and starts roscore.
 
 
-USE for cross-compilation of ROS-fuerte (discontinued):
-   
-  source oe-init-build-env
-  bitbake ros
-
-  momentarily fails at some point with:
-
-> CMake Error at catkin/cmake/find_program_required.cmake:5 (message):
->  check_test_ran.py not found
-> Call Stack (most recent call first):
->  ../catkin/CMakeFiles/tests.cmake:31 (find_program_required)
->  ../catkin/CMakeFiles/tests.cmake:41 (catkin_initialize_tests)
->  catkin/cmake/all.cmake:54 (include)
->  catkin/CMakeLists.txt:12 (include)
->
->
->
-> -- Configuring incomplete, errors occurred!
->
->
-> ERROR: Function failed: do_configure (see /home/lukas/NEW/poky-danny-8.0/build/tmp/work/i586-poky-linux/ros-1.0-r0/temp/log.do_configure.9702 for further information)
-> ERROR: Logfile of failure stored in: /home/lukas/NEW/poky-danny-8.0/build/tmp/work/i586-poky-linux/ros-1.0-r0/temp/log.do_configure.9702
-
-
 USE for cross-compilation of ROS-groovy (in development):
 
   Currently, we can cross-compile 4 packages:
diff --git a/recipes-ros/ros/ros.bb b/recipes-ros/ros/ros.bb
deleted file mode 100644
index 6f933a686bebff5db01cf5e884fad7906a1211b7..0000000000000000000000000000000000000000
--- a/recipes-ros/ros/ros.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-DESCRIPTION  = "ROS"
-HOMEPAGE = "http://ros.org"
-
-LICENSE = "CLOSED"
-# LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
-
-DEPENDS = "python-empy-native python-rospkg-native python-native python-pyyaml-native python-nose-native eglibc"
-
-PR = "r0"
-
-SRC_URI = "file://fuerte-ros-base.rosinstall"
-
-S = "${WORKDIR}"
-
-OECMAKE_SOURCEPATH = "${WORKDIR}/ros-underlay"
-EXTRA_OECMAKE = "-DSETUPTOOLS_DEB_LAYOUT=OFF"
-
-inherit pythonnative cmake
-
-do_rosinstall () {
-	echo "Installing ros"
-        mkdir -p ./ros-underlay
-	rosinstall --catkin ./ros-underlay fuerte-ros-base.rosinstall
-}
-addtask rosinstall after do_patch before do_configure
-
-
diff --git a/recipes-ros/ros/ros/fuerte-ros-base.rosinstall b/recipes-ros/ros/ros/fuerte-ros-base.rosinstall
deleted file mode 100644
index e3c40c6c078964682f9e63d0d20287afae0e607b..0000000000000000000000000000000000000000
--- a/recipes-ros/ros/ros/fuerte-ros-base.rosinstall
+++ /dev/null
@@ -1,44 +0,0 @@
-- git:
-    local-name: catkin
-    uri: git://github.com/wg-debs/catkin-release.git
-    version: debian/ros-fuerte-catkin_0.4.4_lucid
-- git:
-    local-name: common_msgs
-    uri: git://github.com/wg-debs/common_msgs-release.git
-    version: debian/ros-fuerte-common-msgs_1.8.7_lucid
-- git:
-    local-name: gencpp
-    uri: git://github.com/wg-debs/gencpp-release.git
-    version: debian/ros-fuerte-gencpp_0.3.4_lucid
-- git:
-    local-name: genlisp
-    uri: git://github.com/wg-debs/genlisp-release.git
-    version: debian/ros-fuerte-genlisp_0.3.3_lucid
-- git:
-    local-name: genmsg
-    uri: git://github.com/wg-debs/genmsg-release.git
-    version: debian/ros-fuerte-genmsg_0.3.10_lucid
-- git:
-    local-name: genpy
-    uri: git://github.com/wg-debs/genpy-release.git
-    version: debian/ros-fuerte-genpy_0.3.7_lucid
-- git:
-    local-name: ros
-    uri: git://github.com/wg-debs/ros-release.git
-    version: debian/ros-fuerte-ros_1.8.9_lucid
-- git:
-    local-name: ros_comm
-    uri: git://github.com/wg-debs/ros_comm-release.git
-    version: debian/ros-fuerte-ros-comm_1.8.12_lucid
-- git:
-    local-name: roscpp_core
-    uri: git://github.com/wg-debs/roscpp_core-release.git
-    version: debian/ros-fuerte-roscpp-core_0.2.5_lucid
-- git:
-    local-name: rospack
-    uri: git://github.com/wg-debs/rospack-release.git
-    version: debian/ros-fuerte-rospack_2.0.13_lucid
-- git:
-    local-name: std_msgs
-    uri: git://github.com/wg-debs/std_msgs-release.git
-    version: debian/ros-fuerte-std-msgs_0.4.8_lucid