From 74ba602a6115f433092714caade128cbaadca078 Mon Sep 17 00:00:00 2001
From: vmayoral <v.mayoralv@gmail.com>
Date: Wed, 18 Sep 2013 16:51:59 +0200
Subject: [PATCH] cmake-modules: recipe added.

A common repository for CMake Modules which are not distributed with
CMake but are commonly used by ROS packages.
---
 ...-the-path-added-to-CMAKE_MODULE_PATH.patch | 22 +++++++++++++++++++
 .../cmake-modules/cmake-modules_0.1.0.bb      | 17 ++++++++++++++
 2 files changed, 39 insertions(+)
 create mode 100644 recipes-ros/cmake-modules/cmake-modules/0001-Fix-the-path-added-to-CMAKE_MODULE_PATH.patch
 create mode 100644 recipes-ros/cmake-modules/cmake-modules_0.1.0.bb

diff --git a/recipes-ros/cmake-modules/cmake-modules/0001-Fix-the-path-added-to-CMAKE_MODULE_PATH.patch b/recipes-ros/cmake-modules/cmake-modules/0001-Fix-the-path-added-to-CMAKE_MODULE_PATH.patch
new file mode 100644
index 0000000..99b5cbf
--- /dev/null
+++ b/recipes-ros/cmake-modules/cmake-modules/0001-Fix-the-path-added-to-CMAKE_MODULE_PATH.patch
@@ -0,0 +1,22 @@
+From 47c18f75d6a3950836d64b77d7e415ecca3755e9 Mon Sep 17 00:00:00 2001
+From: vmayoral <v.mayoralv@gmail.com>
+Date: Fri, 20 Sep 2013 13:22:53 +0200
+Subject: [PATCH] Fix the path added to CMAKE_MODULE_PATH.
+
+@CMAKE_INSTALL_PREFIX@/@CATKIN_PACKAGE_SHARE_DESTINATION@ have been
+replaced with "${cmake_modules_DIR}/.." to make the module work.
+---
+ cmake/cmake_modules-extras.cmake.installspace.in |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/cmake_modules-extras.cmake.installspace.in b/cmake/cmake_modules-extras.cmake.installspace.in
+index a4cd265..0701f02 100644
+--- a/cmake/cmake_modules-extras.cmake.installspace.in
++++ b/cmake/cmake_modules-extras.cmake.installspace.in
+@@ -1,2 +1,2 @@
+ # Prepend the installed cmake modules to the cmake module path
+-list(INSERT CMAKE_MODULE_PATH 0 @CMAKE_INSTALL_PREFIX@/@CATKIN_PACKAGE_SHARE_DESTINATION@/cmake/Modules)
++list(INSERT CMAKE_MODULE_PATH 0 ${cmake_modules_DIR}/../cmake/Modules)
+-- 
+1.7.9.5
+
diff --git a/recipes-ros/cmake-modules/cmake-modules_0.1.0.bb b/recipes-ros/cmake-modules/cmake-modules_0.1.0.bb
new file mode 100644
index 0000000..6fafc7c
--- /dev/null
+++ b/recipes-ros/cmake-modules/cmake-modules_0.1.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "A common repository for CMake Modules which are not \
+distributed with CMake but are commonly used by ROS packages."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
+SRC_URI[md5sum] = "988ce2ea80d375eebe36984c39b948d4"
+SRC_URI[sha256sum] = "5ba9d987fad3ee781ca1b85af7cc07567b8f955346b4beb2c0b5140cf10b2a16"
+
+SRC_URI += "file://0001-Fix-the-path-added-to-CMAKE_MODULE_PATH.patch;striplevel=1;name=patch"
+SRC_URI[patch.md5sum] = "eba3a7eda081516f2113d6db70e881df"
+SRC_URI[patch.sha256sum] = "164a8e9d8595856be6a1523fa9ecc0c329961bb89bde2045fefc21306aae6de4"
+
+S = "${WORKDIR}/${ROS_SP}"
+
+inherit catkin
-- 
GitLab