From 74840ea4834d585d2ba725337f2691ce479779b8 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Fri, 24 May 2013 14:10:51 +0200
Subject: [PATCH] bond-core: adding all recipes of the bond_core repository

This commit adds the recipes for packages bond, bondcpp, smclib
and bondpy. The first three packages are required for the nodelet
package.
---
 recipes-ros/bond-core/bond-core.inc     |  7 +++++++
 recipes-ros/bond-core/bond_1.7.11.bb    | 13 +++++++++++++
 recipes-ros/bond-core/bondcpp_1.7.11.bb |  8 ++++++++
 recipes-ros/bond-core/bondpy_1.7.11.bb  |  8 ++++++++
 recipes-ros/bond-core/smclib_1.7.11.bb  | 12 ++++++++++++
 5 files changed, 48 insertions(+)
 create mode 100644 recipes-ros/bond-core/bond-core.inc
 create mode 100644 recipes-ros/bond-core/bond_1.7.11.bb
 create mode 100644 recipes-ros/bond-core/bondcpp_1.7.11.bb
 create mode 100644 recipes-ros/bond-core/bondpy_1.7.11.bb
 create mode 100644 recipes-ros/bond-core/smclib_1.7.11.bb

diff --git a/recipes-ros/bond-core/bond-core.inc b/recipes-ros/bond-core/bond-core.inc
new file mode 100644
index 0000000..f2ecc26
--- /dev/null
+++ b/recipes-ros/bond-core/bond-core.inc
@@ -0,0 +1,7 @@
+SRC_URI = "https://github.com/ros/bond_core/archive/${PV}.tar.gz;downloadfilename=bond_core-${PV}.tar.gz"
+SRC_URI[md5sum] = "ce18d722353318f1a6e360a271529abb"
+SRC_URI[sha256sum] = "4fc2019acc136768dafc3e7422dac622cc58038aaf8a41302e45cc9510c1c723"
+
+S = "${WORKDIR}/bond_core-${PV}/${PN}"
+
+inherit catkin
diff --git a/recipes-ros/bond-core/bond_1.7.11.bb b/recipes-ros/bond-core/bond_1.7.11.bb
new file mode 100644
index 0000000..629fc7d
--- /dev/null
+++ b/recipes-ros/bond-core/bond_1.7.11.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "\
+A bond allows two processes, A and B, to know when the other has \
+terminated, either cleanly or by crashing. The bond remains \
+connected until it is either broken explicitly or until a \
+heartbeat times out.\
+"
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "message-generation std-msgs roscpp-serialization"
+
+require bond-core.inc
diff --git a/recipes-ros/bond-core/bondcpp_1.7.11.bb b/recipes-ros/bond-core/bondcpp_1.7.11.bb
new file mode 100644
index 0000000..33425a8
--- /dev/null
+++ b/recipes-ros/bond-core/bondcpp_1.7.11.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "C++ implementation of bond, a mechanism for checking when another process has terminated."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "bond boost roscpp smclib"
+
+require bond-core.inc
diff --git a/recipes-ros/bond-core/bondpy_1.7.11.bb b/recipes-ros/bond-core/bondpy_1.7.11.bb
new file mode 100644
index 0000000..96c83b6
--- /dev/null
+++ b/recipes-ros/bond-core/bondpy_1.7.11.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Python implementation of bond, a mechanism for checking when another process has terminated."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "bond rospy smclib"
+
+require bond-core.inc
diff --git a/recipes-ros/bond-core/smclib_1.7.11.bb b/recipes-ros/bond-core/smclib_1.7.11.bb
new file mode 100644
index 0000000..c083886
--- /dev/null
+++ b/recipes-ros/bond-core/smclib_1.7.11.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "\
+The State Machine Compiler (SMC) from http://smc.sourceforge.net/ \
+converts a language-independent description of a state machine \
+into the source code to support that state machine. \
+This package contains the libraries that a compiled state machine \
+depends on, but it does not contain the compiler itself. \
+"
+SECTION = "devel"
+LICENSE = "MPL-1.1"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=e1b5a50d4dd59d8102e41a7a2254462d"
+
+require bond-core.inc
-- 
GitLab