From 7270734e41d25628ceef98304b2e2a9631930a74 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 11 Jun 2013 08:07:46 +0200
Subject: [PATCH] image-transport: initial commit

---
 recipes-ros/image-common/image-common.inc          | 7 +++++++
 recipes-ros/image-common/image-transport_1.10.3.bb | 9 +++++++++
 2 files changed, 16 insertions(+)
 create mode 100644 recipes-ros/image-common/image-common.inc
 create mode 100644 recipes-ros/image-common/image-transport_1.10.3.bb

diff --git a/recipes-ros/image-common/image-common.inc b/recipes-ros/image-common/image-common.inc
new file mode 100644
index 0000000..4c9452d
--- /dev/null
+++ b/recipes-ros/image-common/image-common.inc
@@ -0,0 +1,7 @@
+SRC_URI = "https://github.com/ros-perception/image_common/archive/${PV}.tar.gz;downloadfilename=image_common-${PV}.tar.gz"
+SRC_URI[md5sum] = "1831f995e72eeeb143b0d3f072a2c153"
+SRC_URI[sha256sum] = "e111bb72da8df67efb742c05742d774a337266e0b2a70073e283c157b4ab7029"
+
+inherit catkin
+
+S = "${WORKDIR}/image_common-${PV}/${ROS_BPN}"
diff --git a/recipes-ros/image-common/image-transport_1.10.3.bb b/recipes-ros/image-common/image-transport_1.10.3.bb
new file mode 100644
index 0000000..d28ccca
--- /dev/null
+++ b/recipes-ros/image-common/image-transport_1.10.3.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "image_transport should always be used to subscribe to and publish images."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=68b329da9893e34099c7d8ad5cb9c940"
+
+DEPENDS = "message-filters pluginlib rosconsole roscpp roslib sensor-msgs"
+
+require image-common.inc
+
-- 
GitLab