diff --git a/recipes-ros/image-common/image-common.inc b/recipes-ros/image-common/image-common.inc
new file mode 100644
index 0000000000000000000000000000000000000000..4c9452db482aa8a8f4acee9e46a90b459ccca19b
--- /dev/null
+++ b/recipes-ros/image-common/image-common.inc
@@ -0,0 +1,7 @@
+SRC_URI = "https://github.com/ros-perception/image_common/archive/${PV}.tar.gz;downloadfilename=image_common-${PV}.tar.gz"
+SRC_URI[md5sum] = "1831f995e72eeeb143b0d3f072a2c153"
+SRC_URI[sha256sum] = "e111bb72da8df67efb742c05742d774a337266e0b2a70073e283c157b4ab7029"
+
+inherit catkin
+
+S = "${WORKDIR}/image_common-${PV}/${ROS_BPN}"
diff --git a/recipes-ros/image-common/image-transport_1.10.3.bb b/recipes-ros/image-common/image-transport_1.10.3.bb
new file mode 100644
index 0000000000000000000000000000000000000000..d28ccca63531801dd64faf446f9244d2933bdde4
--- /dev/null
+++ b/recipes-ros/image-common/image-transport_1.10.3.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "image_transport should always be used to subscribe to and publish images."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=68b329da9893e34099c7d8ad5cb9c940"
+
+DEPENDS = "message-filters pluginlib rosconsole roscpp roslib sensor-msgs"
+
+require image-common.inc
+