diff --git a/README.af_yocto b/README.af_yocto
index f042f9f9462dc7196c1a8323c733ff90234ede17..3c911ad732b42c55408bdbe5cb1a6202017ae7c5 100644
--- a/README.af_yocto
+++ b/README.af_yocto
@@ -62,4 +62,12 @@ OPEN ISSUES for M1:
     SHOULD BE RESOLVED by creating an appropriate patch for python-setuptools and contributing to openembedded-core
   - rospkg modules are not found when runnning python.
     TEMPORARILY RESOLVED by installing natively in the virtual machine
-    SOLUTION UNCLEAR. Cannot be solved by adding rospkg-dev.
+    CAUSE of PROBLEM: must add /usr/lib/python2.7/site-packages/rospkg-1.0.15-py2.7.egg to PYTHON_PATH (sys.path)
+    In the usual setting, this is done by adding rospkg-1.0.15-py2.7.egg to the easy-install.pth
+    However, the distutils class removes the created easy-install.pth before packaging.
+    Modifying the class, to not remove the easy-install.pth does not solve the issue, because
+    also the python-setuptools must add an entry to easy-install.pth
+    This can be only solved by providing a general merge mechanism for the easy-install.pth file.
+    Implementing this should not be difficult because the format of this file is very easy, and
+    the pathes can be simply accumulated.
+    TEMPORARY SOLUTION NOW: we simply write the easy-install.pth file in the rootfs task of the image generation.
diff --git a/install.sh b/install.sh
index 74468c3096ed485a5ebd1c2bad0da19eb8b5ebb3..79958a4c95962027147b7dde08c9f49fe746794a 100644
--- a/install.sh
+++ b/install.sh
@@ -42,8 +42,6 @@ cmake .. -DCMAKE_INSTALL_PREFIX=/opt/ros/fuerte -DSETUPTOOLS_DEB_LAYOUT=OFF
 # compile and install
 make
 make install
-# add own name to hosts
-echo -e '127.0.0.1\tqemux86-64.localdomain\t\tqemux86-64' >> /etc/hosts
 # start roscore
 . /opt/ros/fuerte/setup.sh
 roscore
diff --git a/meta/recipes-core/images/core-image-bmw.bb b/meta/recipes-core/images/core-image-bmw.bb
index 949e0763dae8326fbd825238526e9f2728646cfd..d3d19edf41fe1d0113316b62e1a1d2e4282a3b21 100644
--- a/meta/recipes-core/images/core-image-bmw.bb
+++ b/meta/recipes-core/images/core-image-bmw.bb
@@ -10,7 +10,13 @@ inherit core-image
 
 IMAGE_ROOTFS_EXTRA_SPACE = "524288"
 
+# add own name to hosts
+augment_hosts_setting_file () {
+	echo '127.0.0.1\tqemux86-64.localdomain\t\tqemux86-64' >> ${IMAGE_ROOTFS}/etc/hosts
+}
+
 # remove not needed ipkg informations
-ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; "
+# create a custom hosts file
+ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; "
 
 IMAGE_INSTALL += "boost boost-dev packagegroup-core-ssh-openssh dhcp-client file ldd python-modules python-rospkg python-rosinstall git cmake python-empy python-pyyaml python-nose log4cxx log4cxx-dev libbz2-dev python-setuptools"