From 5b0d7e5b1cfe91edaf5f9752dba6da5ce6659add Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@bmw-carit.de>
Date: Fri, 4 Jan 2013 10:53:31 +0100
Subject: [PATCH] adding some modules to the image that are needed by catkin

---
 recipes-core/images/core-image-ros-groovy.bb | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/recipes-core/images/core-image-ros-groovy.bb b/recipes-core/images/core-image-ros-groovy.bb
index afe2dda..4303832 100644
--- a/recipes-core/images/core-image-ros-groovy.bb
+++ b/recipes-core/images/core-image-ros-groovy.bb
@@ -21,4 +21,9 @@ augment_hosts_setting_file () {
 # create a custom hosts file
 ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; "
 
-IMAGE_INSTALL += "python-rosdep python-wstool"
+# currently install all python-modules, but we only need a subset.
+# also adding python-misc to obtain the ast module. We should check if this ast file should better
+# be a python module in the openembedded core repository.
+IMAGE_INSTALL += "packagegroup-core-ssh-openssh cmake \
+  python-modules python-misc python-empy \
+  python-argparse python-rosdep python-wstool"
-- 
GitLab