diff --git a/recipes-core/images/core-image-ros-groovy.bb b/recipes-core/images/core-image-ros-groovy.bb
index afe2ddac329e8134182c0f880ed2a534d46de301..43038325fe8afbd8c1926a8b34647eb69d011ece 100644
--- a/recipes-core/images/core-image-ros-groovy.bb
+++ b/recipes-core/images/core-image-ros-groovy.bb
@@ -21,4 +21,9 @@ augment_hosts_setting_file () {
 # create a custom hosts file
 ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; "
 
-IMAGE_INSTALL += "python-rosdep python-wstool"
+# currently install all python-modules, but we only need a subset.
+# also adding python-misc to obtain the ast module. We should check if this ast file should better
+# be a python module in the openembedded core repository.
+IMAGE_INSTALL += "packagegroup-core-ssh-openssh cmake \
+  python-modules python-misc python-empy \
+  python-argparse python-rosdep python-wstool"