diff --git a/recipes-ros/genpy/genpy/0001-genpy-extras.cmake.em-use-find_program-for-GENxxx_PY_BIN.patch b/recipes-ros/genpy/genpy/0001-genpy-extras.cmake.em-use-find_program-for-GENxxx_PY_BIN.patch
deleted file mode 100644
index 99216a796c5b21426f5eb444512bbd8a041dd40e..0000000000000000000000000000000000000000
--- a/recipes-ros/genpy/genpy/0001-genpy-extras.cmake.em-use-find_program-for-GENxxx_PY_BIN.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur a/cmake/genpy-extras.cmake.em b/cmake/genpy-extras.cmake.em
---- a/cmake/genpy-extras.cmake.em	2013-05-30 12:31:39.000000000 +0200
-+++ b/cmake/genpy-extras.cmake.em	2013-05-30 12:43:02.000000000 +0200
-@@ -1,13 +1,15 @@
- @[if DEVELSPACE]@
- # bin dir variables in develspace
- set(GENPY_BIN_DIR "@(CMAKE_CURRENT_SOURCE_DIR)/scripts")
-+set(CATKIN_FIND_ROOT_PATH_MODE NO_CMAKE_FIND_ROOT_PATH)
- @[else]@
- # bin dir variables in installspace
- set(GENPY_BIN_DIR "@(CMAKE_INSTALL_PREFIX)/@(CATKIN_PACKAGE_BIN_DESTINATION)")
-+set(CATKIN_FIND_ROOT_PATH_MODE "")
- @[end if]@
- 
-+find_program(GENMSG_PY_BIN genmsg_py.py PATHS ${GENPY_BIN_DIR} NO_DEFAULT_PATH CATKIN_FIND_ROOT_PATH_MODE)
-+find_program(GENSRV_PY_BIN gensrv_py.py PATHS ${GENPY_BIN_DIR} NO_DEFAULT_PATH CATKIN_FIND_ROOT_PATH_MODE)
--set(GENMSG_PY_BIN ${GENPY_BIN_DIR}/genmsg_py.py)
--set(GENSRV_PY_BIN ${GENPY_BIN_DIR}/gensrv_py.py)
- 
- # Generate .msg->.h for py
- # The generated .h files should be added ALL_GEN_OUTPUT_FILES_py
diff --git a/recipes-ros/genpy/genpy/0001-resolve-genpy-path-in-installspace-at-runtime.patch b/recipes-ros/genpy/genpy/0001-resolve-genpy-path-in-installspace-at-runtime.patch
new file mode 100644
index 0000000000000000000000000000000000000000..89037733687e5dcb7a9ad1469969a21469496abc
--- /dev/null
+++ b/recipes-ros/genpy/genpy/0001-resolve-genpy-path-in-installspace-at-runtime.patch
@@ -0,0 +1,30 @@
+From 1bc78ac23e465c1b3ef040d11c53d89cdc00b8ae Mon Sep 17 00:00:00 2001
+From: Dirk Thomas <dthomas@osrfoundation.org>
+Date: Fri, 26 Jul 2013 13:34:18 -0700
+Subject: [PATCH] resolve genpy path in installspace at runtime
+ (ros/catkin#490)
+
+---
+ cmake/genpy-extras.cmake.em | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/cmake/genpy-extras.cmake.em b/cmake/genpy-extras.cmake.em
+index fd78a97..5a57285 100644
+--- a/cmake/genpy-extras.cmake.em
++++ b/cmake/genpy-extras.cmake.em
+@@ -1,9 +1,9 @@
+ @[if DEVELSPACE]@
+-# bin dir variables in develspace
++# location of scripts in develspace
+ set(GENPY_BIN_DIR "@(CMAKE_CURRENT_SOURCE_DIR)/scripts")
+ @[else]@
+-# bin dir variables in installspace
+-set(GENPY_BIN_DIR "@(CMAKE_INSTALL_PREFIX)/@(CATKIN_PACKAGE_BIN_DESTINATION)")
++# location of scripts in installspace
++set(GENPY_BIN_DIR "${genpy_DIR}/../../../@(CATKIN_PACKAGE_BIN_DESTINATION)")
+ @[end if]@
+ 
+ set(GENMSG_PY_BIN ${GENPY_BIN_DIR}/genmsg_py.py)
+-- 
+1.8.1.6
+
diff --git a/recipes-ros/genpy/genpy_0.4.13.bb b/recipes-ros/genpy/genpy_0.4.13.bb
index 11c74efa1376bdcfc7fe0c13f4ba7c8b6cd7fd37..9a9e28ca3902597902d747cf8ffe2cd925cfdd72 100644
--- a/recipes-ros/genpy/genpy_0.4.13.bb
+++ b/recipes-ros/genpy/genpy_0.4.13.bb
@@ -5,13 +5,13 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc
 
 DEPENDS = "genmsg-native"
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
 SRC_URI[md5sum] = "201e3f1aa5e12ccc09159b1a3d9272f7"
 SRC_URI[sha256sum] = "9dae768e9350c835ae8a40f19d230e3fe023bfc1e259a14be8b3ae7c4c632d3c"
 
-SRC_URI += "file://0001-genpy-extras.cmake.em-use-find_program-for-GENxxx_PY_BIN.patch"
+SRC_URI += "file://0001-resolve-genpy-path-in-installspace-at-runtime.patch"
 
 inherit catkin