diff --git a/recipes-extended/libpoco/libpoco_1.4.6.bb b/recipes-extended/libpoco/libpoco_1.4.6.bb
new file mode 100644
index 0000000000000000000000000000000000000000..6f3b7ee701b8f91a7c8d394cca2c3f80b676135a
--- /dev/null
+++ b/recipes-extended/libpoco/libpoco_1.4.6.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "C++ class libraries and frameworks for building network- and internet-based applications"
+HOMEPAGE = "http://pocoproject.org/"
+SECTION = "libs"
+
+LICENSE = "BSL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e4224ccaecb14d942c71d31bef20d78c"
+
+SRC_URI = "http://pocoproject.org/releases/poco-${PV}/poco-${PV}p1.tar.gz"
+SRC_URI[md5sum] = "8d9cf241dfa7c99842a7ef73c207994b"
+SRC_URI[sha256sum] = "f9eddd5e7f963693e9da008a2992f211630560856edfc0f954532b0f42fc66e7"
+
+S = "${WORKDIR}/poco-${PV}p1"
+
+inherit autotools
diff --git a/recipes-ros/bond-core/bond-core.inc b/recipes-ros/bond-core/bond-core.inc
new file mode 100644
index 0000000000000000000000000000000000000000..f2ecc260e556edb6ef3019f3585d0abde4138f50
--- /dev/null
+++ b/recipes-ros/bond-core/bond-core.inc
@@ -0,0 +1,7 @@
+SRC_URI = "https://github.com/ros/bond_core/archive/${PV}.tar.gz;downloadfilename=bond_core-${PV}.tar.gz"
+SRC_URI[md5sum] = "ce18d722353318f1a6e360a271529abb"
+SRC_URI[sha256sum] = "4fc2019acc136768dafc3e7422dac622cc58038aaf8a41302e45cc9510c1c723"
+
+S = "${WORKDIR}/bond_core-${PV}/${PN}"
+
+inherit catkin
diff --git a/recipes-ros/bond-core/bond_1.7.11.bb b/recipes-ros/bond-core/bond_1.7.11.bb
new file mode 100644
index 0000000000000000000000000000000000000000..629fc7d9ca56753d6521212361454f828584aa91
--- /dev/null
+++ b/recipes-ros/bond-core/bond_1.7.11.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "\
+A bond allows two processes, A and B, to know when the other has \
+terminated, either cleanly or by crashing. The bond remains \
+connected until it is either broken explicitly or until a \
+heartbeat times out.\
+"
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "message-generation std-msgs roscpp-serialization"
+
+require bond-core.inc
diff --git a/recipes-ros/bond-core/bondcpp_1.7.11.bb b/recipes-ros/bond-core/bondcpp_1.7.11.bb
new file mode 100644
index 0000000000000000000000000000000000000000..33425a8ae0e9c0a34879d2d52f29be20726710a4
--- /dev/null
+++ b/recipes-ros/bond-core/bondcpp_1.7.11.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "C++ implementation of bond, a mechanism for checking when another process has terminated."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "bond boost roscpp smclib"
+
+require bond-core.inc
diff --git a/recipes-ros/bond-core/bondpy_1.7.11.bb b/recipes-ros/bond-core/bondpy_1.7.11.bb
new file mode 100644
index 0000000000000000000000000000000000000000..96c83b6c82d388684fcc4d81e34be9ed61345db9
--- /dev/null
+++ b/recipes-ros/bond-core/bondpy_1.7.11.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Python implementation of bond, a mechanism for checking when another process has terminated."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "bond rospy smclib"
+
+require bond-core.inc
diff --git a/recipes-ros/bond-core/smclib_1.7.11.bb b/recipes-ros/bond-core/smclib_1.7.11.bb
new file mode 100644
index 0000000000000000000000000000000000000000..c0838861459ee79fad2e3da98e0934da9c4015fb
--- /dev/null
+++ b/recipes-ros/bond-core/smclib_1.7.11.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "\
+The State Machine Compiler (SMC) from http://smc.sourceforge.net/ \
+converts a language-independent description of a state machine \
+into the source code to support that state machine. \
+This package contains the libraries that a compiled state machine \
+depends on, but it does not contain the compiler itself. \
+"
+SECTION = "devel"
+LICENSE = "MPL-1.1"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=e1b5a50d4dd59d8102e41a7a2254462d"
+
+require bond-core.inc
diff --git a/recipes-ros/class-loader/class-loader_0.1.28.bb b/recipes-ros/class-loader/class-loader_0.1.28.bb
new file mode 100644
index 0000000000000000000000000000000000000000..338eeb80f3ce5874b396c83fe2a0a8f978f7419d
--- /dev/null
+++ b/recipes-ros/class-loader/class-loader_0.1.28.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "\
+The class_loader package is a ROS-independent package for loading plugins \
+during runtime and the foundation of the higher level ROS "pluginlib" library. \
+class_loader utilizes the host operating system's runtime loader to open \
+runtime libraries (e.g. .so/.dll files), introspect the library for exported \
+plugin classes, and allows users to instantiate objects of said exported \
+classes without the explicit declaration (i.e. header file) for those classes.\
+"
+
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+SRC_URI = "https://github.com/ros/${ROS_BPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_BP}.tar.gz"
+
+SRC_URI[md5sum] = "484049d013eb988d654d610babb63ffa"
+SRC_URI[sha256sum] = "7e0bd2ba6e55de92260fe580792b2ba1793c0b71cc1479d0b63cf56368852eb2"
+
+DEPENDS = "console-bridge libpoco"
+
+S = "${WORKDIR}/${ROS_BP}"
+
+inherit catkin
diff --git a/recipes-ros/console-bridge/console-bridge_0.2.2.bb b/recipes-ros/console-bridge/console-bridge_0.2.2.bb
new file mode 100644
index 0000000000000000000000000000000000000000..7ef98392b8c3a66e534e130c68489d3c15b19635
--- /dev/null
+++ b/recipes-ros/console-bridge/console-bridge_0.2.2.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "\
+console_bridge is a ROS-independent, pure CMake package that provides logging \
+calls that mirror those found in rosconsole, but for applications that are \
+not necessarily using ROS.\
+"
+
+SECTION = "devel"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "\
+  file://include/console_bridge/console.h;beginline=1;endline=33;md5=279eed49072cc9f6ebe38974afcc4803 \
+  file://src/console.cpp;beginline=1;endline=33;md5=279eed49072cc9f6ebe38974afcc4803 \
+"
+
+DEPENDS = "boost"
+
+SRC_URI = "https://github.com/ros/console_bridge/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz"
+SRC_URI[md5sum] = "82c24b68ffaacee540055571669dcdd7"
+SRC_URI[sha256sum] = "69c3efa4ef86b2c3ffb37d29a9c6169853975a3bc362815c9cffc40f74b25f18"
+
+S = "${WORKDIR}/console_bridge-${PV}"
+
+inherit cmake
+
+FILES_${PN}-dev += "\
+    ${datadir}/console_bridge \
+    ${datadir}/console_bridge/cmake \
+    "
+
diff --git a/recipes-ros/message-generation/message-generation_0.2.9.bb b/recipes-ros/message-generation/message-generation_0.2.9.bb
index 853b131391894836a109b517e054281f8c7d52c1..17aefcbd3fc6cc0b4be6aeb0f9da4c50d0887880 100644
--- a/recipes-ros/message-generation/message-generation_0.2.9.bb
+++ b/recipes-ros/message-generation/message-generation_0.2.9.bb
@@ -9,6 +9,6 @@ SRC_URI = "https://github.com/ros/${ROS_BPN}/archive/${PV}.tar.gz;downloadfilena
 SRC_URI[md5sum] = "b3086fbe24cc103f412cb30d83362e36"
 SRC_URI[sha256sum] = "9ce9c5b4e995933c575f2a5cb5c4b042b39913637bca06554092a52c3bb24c12"
 
-S = "${WORKDIR}/${ROS_BPN}-${PV}"
+S = "${WORKDIR}/${ROS_BP}"
 
 inherit catkin
diff --git a/recipes-ros/message-runtime/message-runtime_0.4.11.bb b/recipes-ros/message-runtime/message-runtime_0.4.11.bb
index 1cadd8c652d94bf12a97b953bf934f0182fbef5d..9b030d87b03d34f2a282066902a6f8c32aa14509 100644
--- a/recipes-ros/message-runtime/message-runtime_0.4.11.bb
+++ b/recipes-ros/message-runtime/message-runtime_0.4.11.bb
@@ -9,6 +9,6 @@ SRC_URI = "https://github.com/ros/${ROS_BPN}/archive/${PV}.tar.gz;downloadfilena
 SRC_URI[md5sum] = "10a516326a3bf18f5b5b4523c6e53940"
 SRC_URI[sha256sum] = "87f6b56679ea6b90512e2f2d299dd129d361b4a5d167237a9d28ac56ce6f2a36"
 
-S = "${WORKDIR}/${ROS_BPN}-${PV}"
+S = "${WORKDIR}/${ROS_BP}"
 
 inherit catkin
diff --git a/recipes-ros/nodelet-core/nodelet_1.7.15.bb b/recipes-ros/nodelet-core/nodelet_1.7.15.bb
new file mode 100644
index 0000000000000000000000000000000000000000..5dcd0a85ded91c8c47a3424f668f9b5a262bd641
--- /dev/null
+++ b/recipes-ros/nodelet-core/nodelet_1.7.15.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "\
+The nodelet package is designed to provide a way to run multiple \
+algorithms in the same process with zero copy transport between \
+algorithms. \
+This package provides both the nodelet base class needed for \
+implementing a nodelet, as well as the NodeletLoader class used \
+for instantiating nodelets\
+"
+
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+SRC_URI = "https://github.com/ros/nodelet_core/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz"
+
+SRC_URI[md5sum] = "be206acca97aa658b31266ddf9d768b9"
+SRC_URI[sha256sum] = "76419dd7afdac31d4813e5e0665af61eb9bccc2c450a8b64886c06030f6d5a1c"
+
+DEPENDS = "bondcpp boost message-generation pluginlib rosconsole roscpp rospy std-msgs libtinyxml"
+
+S = "${WORKDIR}/nodelet_core-${PV}/${PN}"
+
+inherit catkin
diff --git a/recipes-ros/pluginlib/pluginlib_1.9.20.bb b/recipes-ros/pluginlib/pluginlib_1.9.20.bb
new file mode 100644
index 0000000000000000000000000000000000000000..34cbb815daf4e7eef74ccd167a1fa9fffb002cfd
--- /dev/null
+++ b/recipes-ros/pluginlib/pluginlib_1.9.20.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "\
+The pluginlib package provides tools for writing and dynamically loading plugins using the ROS build infrastructure.\
+To work, these tools require plugin providers to register their plugins in the package.xml of their package.\
+"
+
+SECTION = "devel"
+LICENSE = "BSD & BSL-1.0"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=10;md5=bbbb6ab628b1f3daee74dd9c62bee312"
+
+SRC_URI = "https://github.com/ros/${PN}/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz"
+
+SRC_URI[md5sum] = "0346edf3d399b3cdcbd96ee535585b31"
+SRC_URI[sha256sum] = "6d1280b03f67666d128b98c478312d59b1eea0dd1e4233d268a565ce39ce5739"
+
+DEPENDS = "boost class-loader rosconsole roslib libtinyxml"
+
+inherit catkin
diff --git a/recipes-ros/std-msgs/std-msgs_0.5.7.bb b/recipes-ros/std-msgs/std-msgs_0.5.7.bb
index e636d242b467318559fb6614e12acbe2f6d95fd0..5e3fc1689d609ef57ed57e8c50448e5b2b346d8e 100644
--- a/recipes-ros/std-msgs/std-msgs_0.5.7.bb
+++ b/recipes-ros/std-msgs/std-msgs_0.5.7.bb
@@ -10,6 +10,6 @@ SRC_URI = "https://github.com/ros/${ROS_BPN}/archive/${PV}.tar.gz;downloadfilena
 SRC_URI[md5sum] = "ea40e6dd8ea19fe54a2b476358c0ceea"
 SRC_URI[sha256sum] = "acc3d6aed8ede795e4bc6676c1849924699a418769b3d29016a9a2ac08319a56"
 
-S = "${WORKDIR}/${ROS_BPN}-${PV}"
+S = "${WORKDIR}/${ROS_BP}"
 
 inherit catkin