diff --git a/recipes-core/images/core-image-ros-groovy-qemux86-running-roscore.bb b/recipes-core/images/core-image-ros-groovy-qemux86-running-roscore.bb
deleted file mode 100644
index 52f9dbbead8411b56ff89d5592909e6a5e79dd42..0000000000000000000000000000000000000000
--- a/recipes-core/images/core-image-ros-groovy-qemux86-running-roscore.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-DESCRIPTION = "A small image just capable of starting roscore."
-
-IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
-
-IMAGE_LINGUAS = " "
-
-LICENSE = "MIT"
-
-inherit core-image
-
-IMAGE_ROOTFS_SIZE = "8192"
-
-# add own name to hosts
-# this is a simplistic setup for the qemu virtual machine with x86 architecture,
-# and not a general solution.
-augment_hosts_setting_file () {
-	echo '127.0.0.1\tqemux86.localdomain\t\tqemux86' >> ${IMAGE_ROOTFS}/etc/hosts
-}
-
-# remove not needed ipkg informations
-# create a custom hosts file
-ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; "
-
-IMAGE_INSTALL += "packagegroup-core-ssh-openssh \
-  roslaunch \
-"
diff --git a/recipes-core/images/core-image-ros-roscore.bb b/recipes-core/images/core-image-ros-roscore.bb
new file mode 100644
index 0000000000000000000000000000000000000000..a8bdb2e459b94fe2ce9e0034e3d9717f2796738d
--- /dev/null
+++ b/recipes-core/images/core-image-ros-roscore.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "A small image just capable of starting roscore."
+
+IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
+
+IMAGE_LINGUAS = " "
+
+LICENSE = "MIT"
+
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+
+# remove not needed ipkg informations
+ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files"
+
+IMAGE_INSTALL += "roslaunch"