diff --git a/recipes-ros/ros-comm/files/0001-fix-roslaunch-check-script-in-install-space.patch b/recipes-ros/ros-comm/files/0001-fix-roslaunch-check-script-in-install-space.patch
deleted file mode 100644
index bda8dcc6f52a511927a7d905d1d0bb795a8d2c69..0000000000000000000000000000000000000000
--- a/recipes-ros/ros-comm/files/0001-fix-roslaunch-check-script-in-install-space.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 60f0f657bd9aabfedba0b00374ae8398e5e92359 Mon Sep 17 00:00:00 2001
-From: Dirk Thomas <dthomas@osrfoundation.org>
-Date: Wed, 24 Jul 2013 00:19:21 -0700
-Subject: [PATCH] fix roslaunch check script in install space (fix #257)
-
----
- tools/roslaunch/cmake/roslaunch-extras.cmake.em | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tools/roslaunch/cmake/roslaunch-extras.cmake.em b/tools/roslaunch/cmake/roslaunch-extras.cmake.em
-index 10c0ce2..bb1ae40 100644
---- a/tools/roslaunch/cmake/roslaunch-extras.cmake.em
-+++ b/tools/roslaunch/cmake/roslaunch-extras.cmake.em
-@@ -5,7 +5,7 @@
- set(roslaunch_check_script @(CMAKE_CURRENT_SOURCE_DIR)/scripts/roslaunch-check)
- @[else]@
- # set path to roslaunch-check.py installspace
--set(roslaunch_check_script @(CMAKE_INSTALL_PREFIX)/${CATKIN_PACKAGE_SHARE_DESTINATION}/scripts/roslaunch-check)
-+set(roslaunch_check_script @(CMAKE_INSTALL_PREFIX)/@(CATKIN_PACKAGE_SHARE_DESTINATION)/scripts/roslaunch-check)
- @[end if]@
- 
- #
--- 
-1.8.1.6
-
diff --git a/recipes-ros/ros-comm/files/0002-resolve-roslaunch-rostest-paths-in-installspace-at-r.patch b/recipes-ros/ros-comm/files/0002-resolve-roslaunch-rostest-paths-in-installspace-at-r.patch
deleted file mode 100644
index 794f3b2b662bfc97e7e42f1d20255d586135c38d..0000000000000000000000000000000000000000
--- a/recipes-ros/ros-comm/files/0002-resolve-roslaunch-rostest-paths-in-installspace-at-r.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From e0366e14128ed0083e9450bbe9f98fd9b2806454 Mon Sep 17 00:00:00 2001
-From: Dirk Thomas <dthomas@osrfoundation.org>
-Date: Fri, 26 Jul 2013 13:37:23 -0700
-Subject: [PATCH] resolve roslaunch/rostest paths in installspace at runtime
- without find_program()  (ros/catkin#490)
-
----
- tools/roslaunch/cmake/roslaunch-extras.cmake.em |  6 +++---
- tools/rostest/cmake/rostest-extras.cmake.em     | 12 ++++--------
- 2 files changed, 7 insertions(+), 11 deletions(-)
-
-diff --git a/tools/roslaunch/cmake/roslaunch-extras.cmake.em b/tools/roslaunch/cmake/roslaunch-extras.cmake.em
-index bb1ae40..6df3a14 100644
---- a/tools/roslaunch/cmake/roslaunch-extras.cmake.em
-+++ b/tools/roslaunch/cmake/roslaunch-extras.cmake.em
-@@ -1,11 +1,11 @@
- # generated from ros_comm/tools/roslaunch/cmake/roslaunch-extras.cmake.em
- 
- @[if DEVELSPACE]@
--# set path to roslaunch-check.py in develspace
-+# set path to roslaunch-check script in develspace
- set(roslaunch_check_script @(CMAKE_CURRENT_SOURCE_DIR)/scripts/roslaunch-check)
- @[else]@
--# set path to roslaunch-check.py installspace
--set(roslaunch_check_script @(CMAKE_INSTALL_PREFIX)/@(CATKIN_PACKAGE_SHARE_DESTINATION)/scripts/roslaunch-check)
-+# set path to roslaunch-check script installspace
-+set(roslaunch_check_script ${roslaunch_DIR}/../scripts/roslaunch-check)
- @[end if]@
- 
- #
-diff --git a/tools/rostest/cmake/rostest-extras.cmake.em b/tools/rostest/cmake/rostest-extras.cmake.em
-index 1fca6bc..93ca8ff 100644
---- a/tools/rostest/cmake/rostest-extras.cmake.em
-+++ b/tools/rostest/cmake/rostest-extras.cmake.em
-@@ -8,15 +8,11 @@ function(add_rostest file)
-   _warn_if_skip_testing("add_rostest")
- 
- @[if DEVELSPACE]@
--  # find program in develspace
--  find_program_required(ROSTEST_EXE rostest 
--    PATHS @(PROJECT_SOURCE_DIR)/scripts
--    NO_DEFAULT_PATH NO_CMAKE_FIND_ROOT_PATH)
-+  # bin in develspace
-+  set(ROSTEST_EXE "@(PROJECT_SOURCE_DIR)/scripts/rostest")
- @[else]@
--  # find program in installspace
--  find_program_required(ROSTEST_EXE rostest 
--    PATHS @(CMAKE_INSTALL_PREFIX)/bin
--    NO_DEFAULT_PATH NO_CMAKE_FIND_ROOT_PATH)
-+  # bin in installspace
-+  set(ROSTEST_EXE "${rostest_DIR}/../../../@(CATKIN_GLOBAL_BIN_DESTINATION)/rostest")
- @[end if]@
- 
-   cmake_parse_arguments(_rostest "" "WORKING_DIRECTORY" "ARGS" ${ARGN})
--- 
-1.8.1.6
-
diff --git a/recipes-ros/ros-comm/message-filters_1.9.47.bb b/recipes-ros/ros-comm/message-filters_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/message-filters_1.9.47.bb
rename to recipes-ros/ros-comm/message-filters_1.9.48.bb
diff --git a/recipes-ros/ros-comm/ros-comm.inc b/recipes-ros/ros-comm/ros-comm.inc
index 850bafd6a9783bcedb11ef2ca3c01db0308ad7d6..3373ae5b7dc3cf21aec398c19245e92fe26da9a8 100644
--- a/recipes-ros/ros-comm/ros-comm.inc
+++ b/recipes-ros/ros-comm/ros-comm.inc
@@ -1,9 +1,6 @@
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "2d4b8083abc6598857e01b698f4b0d20"
-SRC_URI[sha256sum] = "44c5a076a604134e44d044e08b2c15b185aefac277b8632b5ca2d011ec8d3da6"
-
-SRC_URI += "file://0001-fix-roslaunch-check-script-in-install-space.patch;patchdir=../.."
-SRC_URI += "file://0002-resolve-roslaunch-rostest-paths-in-installspace-at-r.patch;patchdir=../.."
+SRC_URI[md5sum] = "084abed026cfe1821b03cfcfc4cc4c17"
+SRC_URI[sha256sum] = "881f30e896c818502212762dda23bfd82ba384a4ec47d682f4f5fbe97b298cbc"
 
 ROS_PKG_SUBDIR ?= ""
 S = "${WORKDIR}/${ROS_SP}/${ROS_PKG_SUBDIR}/${ROS_BPN}"
diff --git a/recipes-ros/ros-comm/rosbag_1.9.47.bb b/recipes-ros/ros-comm/rosbag_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosbag_1.9.47.bb
rename to recipes-ros/ros-comm/rosbag_1.9.48.bb
diff --git a/recipes-ros/ros-comm/rosconsole_1.9.47.bb b/recipes-ros/ros-comm/rosconsole_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosconsole_1.9.47.bb
rename to recipes-ros/ros-comm/rosconsole_1.9.48.bb
diff --git a/recipes-ros/ros-comm/roscpp_1.9.47.bb b/recipes-ros/ros-comm/roscpp_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/roscpp_1.9.47.bb
rename to recipes-ros/ros-comm/roscpp_1.9.48.bb
diff --git a/recipes-ros/ros-comm/rosgraph-msgs_1.9.47.bb b/recipes-ros/ros-comm/rosgraph-msgs_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosgraph-msgs_1.9.47.bb
rename to recipes-ros/ros-comm/rosgraph-msgs_1.9.48.bb
diff --git a/recipes-ros/ros-comm/rosgraph_1.9.47.bb b/recipes-ros/ros-comm/rosgraph_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosgraph_1.9.47.bb
rename to recipes-ros/ros-comm/rosgraph_1.9.48.bb
diff --git a/recipes-ros/ros-comm/roslaunch_1.9.47.bb b/recipes-ros/ros-comm/roslaunch_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/roslaunch_1.9.47.bb
rename to recipes-ros/ros-comm/roslaunch_1.9.48.bb
diff --git a/recipes-ros/ros-comm/rosmaster_1.9.47.bb b/recipes-ros/ros-comm/rosmaster_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosmaster_1.9.47.bb
rename to recipes-ros/ros-comm/rosmaster_1.9.48.bb
diff --git a/recipes-ros/ros-comm/rosmsg_1.9.47.bb b/recipes-ros/ros-comm/rosmsg_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosmsg_1.9.47.bb
rename to recipes-ros/ros-comm/rosmsg_1.9.48.bb
diff --git a/recipes-ros/ros-comm/rosnode_1.9.47.bb b/recipes-ros/ros-comm/rosnode_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosnode_1.9.47.bb
rename to recipes-ros/ros-comm/rosnode_1.9.48.bb
diff --git a/recipes-ros/ros-comm/rosout_1.9.47.bb b/recipes-ros/ros-comm/rosout_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosout_1.9.47.bb
rename to recipes-ros/ros-comm/rosout_1.9.48.bb
diff --git a/recipes-ros/ros-comm/rosparam_1.9.47.bb b/recipes-ros/ros-comm/rosparam_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosparam_1.9.47.bb
rename to recipes-ros/ros-comm/rosparam_1.9.48.bb
diff --git a/recipes-ros/ros-comm/rospy_1.9.47.bb b/recipes-ros/ros-comm/rospy_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/rospy_1.9.47.bb
rename to recipes-ros/ros-comm/rospy_1.9.48.bb
diff --git a/recipes-ros/ros-comm/rosservice_1.9.47.bb b/recipes-ros/ros-comm/rosservice_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosservice_1.9.47.bb
rename to recipes-ros/ros-comm/rosservice_1.9.48.bb
diff --git a/recipes-ros/ros-comm/rostest_1.9.47.bb b/recipes-ros/ros-comm/rostest_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/rostest_1.9.47.bb
rename to recipes-ros/ros-comm/rostest_1.9.48.bb
diff --git a/recipes-ros/ros-comm/rostopic_1.9.47.bb b/recipes-ros/ros-comm/rostopic_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/rostopic_1.9.47.bb
rename to recipes-ros/ros-comm/rostopic_1.9.48.bb
diff --git a/recipes-ros/ros-comm/roswtf_1.9.47.bb b/recipes-ros/ros-comm/roswtf_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/roswtf_1.9.47.bb
rename to recipes-ros/ros-comm/roswtf_1.9.48.bb
diff --git a/recipes-ros/ros-comm/std-srvs_1.9.47.bb b/recipes-ros/ros-comm/std-srvs_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/std-srvs_1.9.47.bb
rename to recipes-ros/ros-comm/std-srvs_1.9.48.bb
diff --git a/recipes-ros/ros-comm/topic-tools_1.9.47.bb b/recipes-ros/ros-comm/topic-tools_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/topic-tools_1.9.47.bb
rename to recipes-ros/ros-comm/topic-tools_1.9.48.bb
diff --git a/recipes-ros/ros-comm/xmlrpcpp_1.9.47.bb b/recipes-ros/ros-comm/xmlrpcpp_1.9.48.bb
similarity index 100%
rename from recipes-ros/ros-comm/xmlrpcpp_1.9.47.bb
rename to recipes-ros/ros-comm/xmlrpcpp_1.9.48.bb