From 4f88ffb3ad39b13366232885f42e9e731ca580bf Mon Sep 17 00:00:00 2001
From: Kristof Robot <krirobo@gmail.com>
Date: Sat, 19 Apr 2014 22:41:39 +0200
Subject: [PATCH] sphinxbase: initial commit

---
 recipes-extended/cmusphinx/cmusphinx.inc      |  9 ++++++++
 .../sphinxbase/0001-TESTS-srcdir-remove.patch | 16 ++++++++++++++
 recipes-extended/cmusphinx/sphinxbase_0.8.bb  | 21 +++++++++++++++++++
 3 files changed, 46 insertions(+)
 create mode 100644 recipes-extended/cmusphinx/cmusphinx.inc
 create mode 100644 recipes-extended/cmusphinx/sphinxbase/0001-TESTS-srcdir-remove.patch
 create mode 100644 recipes-extended/cmusphinx/sphinxbase_0.8.bb

diff --git a/recipes-extended/cmusphinx/cmusphinx.inc b/recipes-extended/cmusphinx/cmusphinx.inc
new file mode 100644
index 0000000..0c46b66
--- /dev/null
+++ b/recipes-extended/cmusphinx/cmusphinx.inc
@@ -0,0 +1,9 @@
+SRC_URI = "http://sourceforge.net/projects/cmusphinx/files/${PN}/${PV}/${P}.tar.gz;downloadfilename=${P}.tar.gz"
+
+inherit autotools pythonnative python-dir
+
+# required for python binding
+export HOST_SYS
+export BUILD_SYS
+export STAGING_LIBDIR
+export STAGING_INCDIR
diff --git a/recipes-extended/cmusphinx/sphinxbase/0001-TESTS-srcdir-remove.patch b/recipes-extended/cmusphinx/sphinxbase/0001-TESTS-srcdir-remove.patch
new file mode 100644
index 0000000..3df5736
--- /dev/null
+++ b/recipes-extended/cmusphinx/sphinxbase/0001-TESTS-srcdir-remove.patch
@@ -0,0 +1,16 @@
+diff --git a/test/regression/Makefile.am b/test/regression/Makefile.am
+index d13d2a7..3bdb18a 100644
+--- a/test/regression/Makefile.am
++++ b/test/regression/Makefile.am
+@@ -33,9 +33,9 @@ CLEANFILES = test*.err test*.out		\
+ 
+ # Disable sphinx_fe tests for now if fixed-point due to imprecision
+ if FIXED_POINT
+-TESTS = $(srcdir)/test-cepview.sh $(srcdir)/test-sphinx_pitch.sh
++TESTS = test-cepview.sh test-sphinx_pitch.sh
+ else
+-TESTS = $(srcdir)/test-*.sh
++TESTS = test-*.sh
+ endif
+ 
+ EXTRA_DIST += $(TESTS)
diff --git a/recipes-extended/cmusphinx/sphinxbase_0.8.bb b/recipes-extended/cmusphinx/sphinxbase_0.8.bb
new file mode 100644
index 0000000..63becb0
--- /dev/null
+++ b/recipes-extended/cmusphinx/sphinxbase_0.8.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "This package contains the basic libraries shared by the CMU Sphinx \
+trainer and all the Sphinx decoders (Sphinx-II, Sphinx-III, and \
+PocketSphinx), as well as some common utilities for manipulating \
+acoustic feature and audio files."
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c550e8ca1106e5eeaf4e2b4cbf960fcf"
+
+SRC_URI[md5sum] = "7335d233f7ad4ecc4b508aec7b5dc101"
+SRC_URI[sha256sum] = "55708944872bab1015b8ae07b379bf463764f469163a8fd114cbb16c5e486ca8"
+
+require cmusphinx.inc
+
+SRC_URI += "file://0001-TESTS-srcdir-remove.patch"
+
+do_install_append () {
+    #remove egg-info
+    rm -rf ${D}/${PYTHON_SITEPACKAGES_DIR}/*.egg-info
+}
+
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/sphinxbase.so"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug/*"
-- 
GitLab