diff --git a/recipes-ros/packagegroups/packagegroup-ros-comm.bb b/recipes-ros/packagegroups/packagegroup-ros-comm.bb
index 6fa2a087176ad823edfebfa950fad052dc1c90fd..85fa1d92e4c6da3a5ffe6dc7016fa3d573916594 100644
--- a/recipes-ros/packagegroups/packagegroup-ros-comm.bb
+++ b/recipes-ros/packagegroups/packagegroup-ros-comm.bb
@@ -12,19 +12,41 @@ RDEPENDS_${PN} = "\
     genmsg \
     rosgraph \
     genpy \
+    rosbuild \
     rospack \
+    rosmake \
+    rosboost-cfg \
+    rosbash \
     roslib \
+    roscreate \
+    mk \
+    rosclean \
     rosunit \
+    roslang \
+    roscpp \
+    rosout \
     roscpp-serialization \
     roscpp-traits \
+    topic-tools \
     rostest \
+    rostopic \
     message-generation \
     cpp-common \
     genlisp \
+    message-filters \
+    rosservice \
+    rospy \
     rosgraph-msgs \
+    rosnode \
+    std-srvs \
     xmlrpcpp \
+    roslaunch \
+    rosmaster \
     roswtf \
+    rosbag \
+    rosmsg \
     std-msgs \
+    message-runtime \
     rostime \
     gencpp \
     "