diff --git a/recipes-ros/geometry-angles-utils/angles/0001-check-for-CATKIN_ENABLE_TESTING.patch b/recipes-ros/geometry-angles-utils/angles/0001-check-for-CATKIN_ENABLE_TESTING.patch
new file mode 100644
index 0000000000000000000000000000000000000000..73080d0a0771b03add173019d9ef8d68b4833a1c
--- /dev/null
+++ b/recipes-ros/geometry-angles-utils/angles/0001-check-for-CATKIN_ENABLE_TESTING.patch
@@ -0,0 +1,36 @@
+From 8b1879e93b8ae2f89df345edaf688521e5c0ab97 Mon Sep 17 00:00:00 2001
+From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date: Mon, 15 Jul 2013 14:04:43 +0200
+Subject: [PATCH] check for CATKIN_ENABLE_TESTING
+
+---
+ angles/CMakeLists.txt | 4 +++-
+ angles/package.xml    | 2 +-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/angles/CMakeLists.txt b/angles/CMakeLists.txt
+index a2cc37f..4026fc6 100644
+--- a/angles/CMakeLists.txt
++++ b/angles/CMakeLists.txt
+@@ -10,4 +10,6 @@ install(DIRECTORY include/${PROJECT_NAME}/
+ 
+ include_directories(include)
+ 
+-add_subdirectory(test)
++if(CATKIN_ENABLE_TESTING)
++  add_subdirectory(test)
++endif()
+diff --git a/angles/package.xml b/angles/package.xml
+index fe7f848..2409595 100644
+--- a/angles/package.xml
++++ b/angles/package.xml
+@@ -16,5 +16,5 @@
+ 
+   <url>http://ros.org/wiki/angles</url>
+ 
+-  <buildtool_depend>catkin</buildtool_depend>
++  <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
+ </package>
+-- 
+1.8.1.6
+
diff --git a/recipes-ros/geometry-angles-utils/angles_1.9.9.bb b/recipes-ros/geometry-angles-utils/angles_1.9.9.bb
index 3ee1f9f82c6098ee82cc38ee114110c2d15c978d..3f8eb531591467f6672c9320df49bf6fa7431625 100644
--- a/recipes-ros/geometry-angles-utils/angles_1.9.9.bb
+++ b/recipes-ros/geometry-angles-utils/angles_1.9.9.bb
@@ -7,9 +7,7 @@ SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilena
 SRC_URI[md5sum] = "c2a841dbeb1f3036449919773ac70876"
 SRC_URI[sha256sum] = "5e690bf611bead83c2fdcab5a9617b622a9869e55fd1742c00b4015ddf4f8cfc"
 
-SRC_URI += "https://github.com/bulwahn/${ROS_SPN}/commit/8b1879e93b8ae2f89df345edaf688521e5c0ab97.patch;striplevel=2;name=patch"
-SRC_URI[patch.md5sum] = "d55c70b7328ed6e9d00d3185ddf4b0bf"
-SRC_URI[patch.sha256sum] = "2b7303ca01e355680adadd18c3b97dfb1071715375c14a3759ad96f807fc09e5"
+SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"
 
 S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"