diff --git a/README.md b/README.md
index 70a9a5ef82abb468b32d44984a8b206b50965baa..76dc7fb90c931aaae7fa39e4df31f104671ea3b4 100644
--- a/README.md
+++ b/README.md
@@ -58,7 +58,11 @@ cross-compilation of the basic ros-comm packages.
 
   Using wildcards in bbappend versions part in name depends on
   31bc9af9cd56e7b318924869970e850993fafc5f@bitbake and
-  991cbeedbde8bd25ce08c669b1bfac8b99e33149@bitbake
+  991cbeedbde8bd25ce08c669b1bfac8b99e33149@bitbake.
+
+  octomap-ros and collada-urdf depend on
+  43073569cb67d98c11aa71211d77b566b64f9145@openembedded-core and
+  783fb88f476c94d5d4f4b954f7053464d9a6dff5@openembedded-core.
 
 ## INSTALLATION ##
 
diff --git a/recipes-ros/octomap-ros/octomap-ros_0.3.0.bb b/recipes-ros/octomap-ros/octomap-ros_0.3.0.bb
index c6c51653b9d659b22146bcade4a114717772f123..d7f11358ad07681076820584e7ee17fb8918f41b 100644
--- a/recipes-ros/octomap-ros/octomap-ros_0.3.0.bb
+++ b/recipes-ros/octomap-ros/octomap-ros_0.3.0.bb
@@ -16,5 +16,5 @@ inherit catkin
 do_configure_append() {
 	sed -i -e 's: /usr/lib/liboctomap.so: ${STAGING_LIBDIR}/liboctomap.so:g' \
 	  -e 's: /usr/lib/liboctomath.so: ${STAGING_LIBDIR}/liboctomath.so:g' \
-	  ${S}/build/CMakeFiles/octomap_ros.dir/build.make
+	  ${B}/CMakeFiles/octomap_ros.dir/build.make
 }
diff --git a/recipes-ros/robot-model/collada-urdf_1.10.18.bb b/recipes-ros/robot-model/collada-urdf_1.10.18.bb
index 1c1a4956c5180c3f6a44aa7f6b8fedd7028b2ebf..bf1e707f219ed01f2b419a5b429873d471f6263f 100644
--- a/recipes-ros/robot-model/collada-urdf_1.10.18.bb
+++ b/recipes-ros/robot-model/collada-urdf_1.10.18.bb
@@ -12,6 +12,6 @@ do_configure_append() {
 	do 
 	sed -i -e 's: /usr/lib/liboctomap.so: ${STAGING_LIBDIR}/liboctomap.so:g' \
 	  -e 's: /usr/lib/liboctomath.so: ${STAGING_LIBDIR}/liboctomath.so:g' \
-	  ${S}/build/CMakeFiles/$f/build.make
+	  ${B}/CMakeFiles/$f/build.make
 	done
 }