diff --git a/CONTENT b/CONTENT
new file mode 100644
index 0000000000000000000000000000000000000000..11111e83dc79be3cef108544c0d9566045a59908
--- /dev/null
+++ b/CONTENT
@@ -0,0 +1,10 @@
+CONTENT of the repository:
+
+* README                                                   the README file, which contains all important information
+* COPYING.MIT                                              MIT license
+* conf/layer.conf                                          configuration file for this layer
+* classes/catkin.bbclass                                   class for catkin-based packages
+* recipes-core/images                                      recipes of images for native compilation of ROS
+* recipes-devtools, recipes-support                        recipes of system prerequisites of ROS
+* recipes-ros                                              recipes for cross-compiling ROS packages
+                                                  
diff --git a/CONTENTS b/CONTENTS
deleted file mode 100644
index 630454f5dad7560bb8809bff8e7389a795f0ec00..0000000000000000000000000000000000000000
--- a/CONTENTS
+++ /dev/null
@@ -1,29 +0,0 @@
-
-CONTENT of the repository:
-
-  README                                                   this README file, which contains all important information
-  COPYING.MIT                                              MIT license
-  conf/layer.conf                                          configuration file for this layer
-  install.sh                                               installation script that runs within the virtual machine
-  recipes-core/images/core-image-ros.bb                    recipe for our own core image (derived from core-image-minimal)
-  recipes-devtools/python/python-pyyaml_3.10.bb            recipe for pyyaml python library
-  recipes-devtools/python/python-rospkg_1.0.15.bb          recipe for rospkg tool
-  recipes-devtools/python/python-empy_3.3.bb               recipe for empy python library
-  recipes-devtools/python/python-nose_1.2.1.bb             recipe for nose python library
-  recipes-devtools/python/python-rosinstall_0.6.21.bb      recipe for rosinstall tool
-  recipes-devtools/python/python-vcstools_0.1.26.bb        recipe required by rosinstall tool
-  recipes-devtools/python/python-dateutil_1.5.bb           recipe required by rosinstall tool
-  recipes-devtools/python/python-pyyaml-native_3.10.bb     native recipes for cross-compilation
-  recipes-devtools/python/python-rospkg-native_1.0.15.bb
-  recipes-devtools/python/python-empy-native_3.3.bb
-  recipes-devtools/python/python-nose-native_1.2.1.bb
-  recipes-devtools/log4cxx                                 recipes and patches for log4cxx 0.10.0
-  recipes-devtools/log4cxx/log4cxx_0.10.0.bb
-  recipes-devtools/log4cxx/log4cxx/0001-log4cxx_0-10-0_add-missing-includes.patch
-  recipes-devtools/log4cxx/log4cxx/0003-log4cxx-0.10.0-add_stdio_header.patch
-  recipes-devtools/log4cxx/log4cxx/0002-Remove-duplicates-from-makefile.patch
-  recipes-ros/ros/ros.bb                                   recipe for ros (incomplete)
-  recipes-ros/ros/ros/fuerte-ros-base.rosinstall           the .rosinstall file to download ros
-  classes/distutils.bbclass                                distutils recipe originated from oe-core (patch submitted to oe-core and accepted)
-  classes/setuptools.bbclass                               adjustments for python setuptools
-
diff --git a/README b/README
index 25e247f2059fe0f397087f6e02a6a0a352bd1440..8ef9d7eee0517deb2a700a9fcb50e28f3ae8a17f 100644
--- a/README
+++ b/README
@@ -31,6 +31,26 @@ STATE OF THIS WORK:
   - Native compilation of ROS-groovy
   - Cross compilation of ROS-groovy (under development)
 
+INSTALLATION/SETUP:
+  The repository only contains a layer for ROS that builds on top of the existing OpenEmbedded Core layer.
+  Currently, I work with
+    * commit 1dab754cb1ec942f86a7cf9758e6b5169e50bff3 of https://github.com/openembedded/oe-core
+    * commit 324ed96e28ec31cff8cef1824d20d40f9a5d46ad of git://git.openembedded.org/bitbake in the bitbake directory
+    * and this patch for boost: http://lists.linuxtogo.org/pipermail/openembedded-core/2013-March/036973.html
+
+
+USE for cross-compilation of ROS-groovy (in development):
+
+  Currently, we can cross-compile the ROS packages with the commands:
+  source oe-init-build-env
+  bitbake <package-name>
+
+  Look at the meta-ros test reports for the description of the current state.
+
+
+PREVIOUS USE CASES
+
+
 INSTALLATION:
 
   The repository only contains a layer for ROS that builds on top of the existing OpenEmbedded Core layer.
@@ -86,16 +106,6 @@ USE for native compilation of ROS-groovy on the qemu VM:
   The installation script installs ros and starts roscore.
 
 
-USE for cross-compilation of ROS-groovy (in development):
-
-  Currently, we can cross-compile 4 packages:
-  ros-cpp-common, rostime, roscpp-traits, roscpp-serialization (packages in roscpp_core)
-  
-  with the commands:
-  source oe-init-build-env
-  bitbake <package-name>
-
-
 LICENSE
 
 All metadata is MIT licensed unless otherwise stated. Source code included
@@ -117,9 +127,6 @@ The log4cxx recipe originated from the recipe in the OpenEmbedded (Classic) Deve
 The core-image-ros recipe originated from the core-image-minimal recipe in OpenEmbedded Core
   (cf. http://cgit.openembedded.org/openembedded-core/tree/meta/recipes-core/images/core-image-minimal.bb)
   licensed with the MIT License.
-The distutils class originated from the distutils class in OpenEmbedded Core
-  (cf. http://cgit.openembedded.org/openembedded-core/tree/meta/classes/distutils.bbclass)
-  licensed with the MIT License.
 The libtinyxml recipe originated from the recipe in the OpenEmbedded meta layer
   (cf. http://cgit.openembedded.org/meta-openembedded/tree/meta-oe/recipes-support/libtinyxml)
   licensed with the MIT License.