From 3f2a34361e10422494f196bc48a6761d71566860 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@bmw-carit.de>
Date: Thu, 31 Jan 2013 08:26:37 +0100
Subject: [PATCH] patching catkin to remove assertion for rt-library (this must
 revisited at some later point again when we have a better understanding of
 the issue.)

---
 ...tkin-remove_assertion_for_rt_library.patch | 21 +++++++++++++++++++
 recipes-ros/catkin/catkin_0.5.58.bb           |  4 +++-
 2 files changed, 24 insertions(+), 1 deletion(-)
 create mode 100644 recipes-ros/catkin/catkin/catkin-remove_assertion_for_rt_library.patch

diff --git a/recipes-ros/catkin/catkin/catkin-remove_assertion_for_rt_library.patch b/recipes-ros/catkin/catkin/catkin-remove_assertion_for_rt_library.patch
new file mode 100644
index 0000000..8042ce0
--- /dev/null
+++ b/recipes-ros/catkin/catkin/catkin-remove_assertion_for_rt_library.patch
@@ -0,0 +1,21 @@
+diff -crB a/cmake/tools/rt.cmake b/cmake/tools/rt.cmake
+*** a/cmake/tools/rt.cmake	2012-12-22 03:30:48.000000000 +0100
+--- b/cmake/tools/rt.cmake	2013-01-31 08:09:48.789321920 +0100
+***************
+*** 39,45 ****
+      set(RT_LIBRARY rt CACHE FILEPATH "Hacked find of rt for cmake < 2.8.4")
+    else()
+      find_library(RT_LIBRARY rt)
+!     assert_file_exists(${RT_LIBRARY} "RT Library")
+    endif()
+    #message(STATUS "RT_LIBRARY: ${RT_LIBRARY}")
+  endif()
+--- 39,45 ----
+      set(RT_LIBRARY rt CACHE FILEPATH "Hacked find of rt for cmake < 2.8.4")
+    else()
+      find_library(RT_LIBRARY rt)
+!     #assert_file_exists(${RT_LIBRARY} "RT Library")
+    endif()
+    #message(STATUS "RT_LIBRARY: ${RT_LIBRARY}")
+  endif()
+Only in b/cmake/tools: rt.cmake~
diff --git a/recipes-ros/catkin/catkin_0.5.58.bb b/recipes-ros/catkin/catkin_0.5.58.bb
index 08a7c87..3f3f647 100644
--- a/recipes-ros/catkin/catkin_0.5.58.bb
+++ b/recipes-ros/catkin/catkin_0.5.58.bb
@@ -4,7 +4,9 @@ SECTION = "devel"
 LICENSE = "CLOSED"
 
 SRC_URI = "https://github.com/ros/catkin/archive/0.5.58.tar.gz \
-  file://catkin-change_default_for_debsetuptools.patch"
+  file://catkin-change_default_for_debsetuptools.patch \
+  file://catkin-remove_assertion_for_rt_library.patch \
+"
 SRC_URI[md5sum] = "e4df85e60dc792af9324334547cc76aa"
 SRC_URI[sha256sum] = "dd99cc04eeaf16a13185dd0a2f576939fa997dfb16a40ba45068c4d2ebbcb44b"
 
-- 
GitLab