diff --git a/recipes-ros/catkin/catkin/catkin-remove_assertion_for_rt_library.patch b/recipes-ros/catkin/catkin/catkin-remove_assertion_for_rt_library.patch
new file mode 100644
index 0000000000000000000000000000000000000000..8042ce0d898a70e5c74e8e510e6ab1aea519617f
--- /dev/null
+++ b/recipes-ros/catkin/catkin/catkin-remove_assertion_for_rt_library.patch
@@ -0,0 +1,21 @@
+diff -crB a/cmake/tools/rt.cmake b/cmake/tools/rt.cmake
+*** a/cmake/tools/rt.cmake	2012-12-22 03:30:48.000000000 +0100
+--- b/cmake/tools/rt.cmake	2013-01-31 08:09:48.789321920 +0100
+***************
+*** 39,45 ****
+      set(RT_LIBRARY rt CACHE FILEPATH "Hacked find of rt for cmake < 2.8.4")
+    else()
+      find_library(RT_LIBRARY rt)
+!     assert_file_exists(${RT_LIBRARY} "RT Library")
+    endif()
+    #message(STATUS "RT_LIBRARY: ${RT_LIBRARY}")
+  endif()
+--- 39,45 ----
+      set(RT_LIBRARY rt CACHE FILEPATH "Hacked find of rt for cmake < 2.8.4")
+    else()
+      find_library(RT_LIBRARY rt)
+!     #assert_file_exists(${RT_LIBRARY} "RT Library")
+    endif()
+    #message(STATUS "RT_LIBRARY: ${RT_LIBRARY}")
+  endif()
+Only in b/cmake/tools: rt.cmake~
diff --git a/recipes-ros/catkin/catkin_0.5.58.bb b/recipes-ros/catkin/catkin_0.5.58.bb
index 08a7c87037dfac6d32f8155c3d71a363e6b7e75c..3f3f6470d4ea28c123b69bd9a59fdea5734f3916 100644
--- a/recipes-ros/catkin/catkin_0.5.58.bb
+++ b/recipes-ros/catkin/catkin_0.5.58.bb
@@ -4,7 +4,9 @@ SECTION = "devel"
 LICENSE = "CLOSED"
 
 SRC_URI = "https://github.com/ros/catkin/archive/0.5.58.tar.gz \
-  file://catkin-change_default_for_debsetuptools.patch"
+  file://catkin-change_default_for_debsetuptools.patch \
+  file://catkin-remove_assertion_for_rt_library.patch \
+"
 SRC_URI[md5sum] = "e4df85e60dc792af9324334547cc76aa"
 SRC_URI[sha256sum] = "dd99cc04eeaf16a13185dd0a2f576939fa997dfb16a40ba45068c4d2ebbcb44b"