diff --git a/recipes-ros/razor-imu-9dof/razor-imu-9dof_1.0.5.bb b/recipes-ros/razor-imu-9dof/razor-imu-9dof_1.0.5.bb
new file mode 100644
index 0000000000000000000000000000000000000000..e27691f4f14d5d1b61e89416b230599cd39e7975
--- /dev/null
+++ b/recipes-ros/razor-imu-9dof/razor-imu-9dof_1.0.5.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Provides a ROS driver for the Sparkfun Razor IMU 9DOF. \
+It also provides Arduino firmware that runs on the Razor board, and which must be \
+installed on the Razor board for the system to work. \
+A node which displays the attitude (roll, pitch and yaw) of the Razor board \
+(or any IMU) is provided for testing."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+SRC_URI = "https://github.com/KristofRobot/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
+SRC_URI[md5sum] = "3a05ce324d043400a2a214bcc040f843"
+SRC_URI[sha256sum] = "4a948cc34e36ce5be9c3e4a2e681eed713e1a5a3df674dd4761a0795e607da35"
+
+S = "${WORKDIR}/${ROS_SP}"
+
+inherit catkin
+
+RDEPENDS_${PN} = "rospy tf sensor-msgs python-pyserial"
diff --git a/recipes-ros/xv-11-laser-driver/xv-11-laser-driver_0.2.2.bb b/recipes-ros/xv-11-laser-driver/xv-11-laser-driver_0.2.2.bb
new file mode 100644
index 0000000000000000000000000000000000000000..531221614c4651632e4573ff94076a4c4e1b7c75
--- /dev/null
+++ b/recipes-ros/xv-11-laser-driver/xv-11-laser-driver_0.2.2.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Neato XV-11 Laser Driver. This driver works with the laser when it is removed \
+from the XV-11 Robot as opposed to reading scans from the Neato's USB port."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=16;endline=16;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "sensor-msgs roscpp boost"
+
+SRC_URI = "https://github.com/rohbotics/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
+SRC_URI[md5sum] = "2f60eab48f5b1d2a587b21887629fd0a"
+SRC_URI[sha256sum] = "ca62f2eac7f716bb1547914d2dee8d63459de34c12cea972f770a897dd704307"
+
+S = "${WORKDIR}/${ROS_SP}"
+
+inherit catkin