diff --git a/classes/catkin.bbclass b/classes/catkin.bbclass
index de1634daba7a128348e3c9aa81c115d3317cb548..a334141e9eac4a2f7e3276b29c6ee8c4d6a532e7 100644
--- a/classes/catkin.bbclass
+++ b/classes/catkin.bbclass
@@ -48,6 +48,12 @@ FILES_${PN}-dbg += "\
     ${libdir}/${ROS_BPN}/.debug/* \
     "
 
+PACKAGES += "${PN}-commonlisp"
+
+FILES_${PN}-commonlisp += " \
+    ${datadir}/common-lisp/ \
+    "
+
 SYSROOT_PREPROCESS_FUNCS += "catkin_sysroot_preprocess"
 
 catkin_sysroot_preprocess () {
diff --git a/recipes-ros/ros-comm/rostest_1.9.41.bb b/recipes-ros/ros-comm/rostest_1.9.41.bb
index 38f77b29d3e0d287ea844c04cf5a988f4473babf..877921be270f3ba01bc6e09e1a892d4a66815550 100644
--- a/recipes-ros/ros-comm/rostest_1.9.41.bb
+++ b/recipes-ros/ros-comm/rostest_1.9.41.bb
@@ -3,7 +3,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-DEPENDS = "boost rosunit-native"
+DEPENDS = "boost python-nose rosunit-native"
 
 require ros-comm.inc