diff --git a/recipes-ros/depthimage-to-laserscan/depthimage-to-laserscan/0001-check-for-CATKIN_ENABLE_TESTING.patch b/recipes-ros/depthimage-to-laserscan/depthimage-to-laserscan/0001-check-for-CATKIN_ENABLE_TESTING.patch
new file mode 100644
index 0000000000000000000000000000000000000000..1659c8e3004957a37091588e18dd36ab1f24b084
--- /dev/null
+++ b/recipes-ros/depthimage-to-laserscan/depthimage-to-laserscan/0001-check-for-CATKIN_ENABLE_TESTING.patch
@@ -0,0 +1,19 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7e73a89..60c4bff 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -30,9 +30,11 @@ target_link_libraries(DepthImageToLaserScanNodelet DepthImageToLaserScanROS ${ca
+ add_executable(depthimage_to_laserscan src/depthimage_to_laserscan.cpp)
+ target_link_libraries(depthimage_to_laserscan DepthImageToLaserScanROS ${catkin_LIBRARIES})
+ 
+-# Test the library
+-catkin_add_gtest(libtest test/DepthImageToLaserScanTest.cpp)
+-target_link_libraries(libtest DepthImageToLaserScan ${catkin_LIBRARIES})
++if(CATKIN_ENABLE_TESTING)
++  # Test the library
++  catkin_add_gtest(libtest test/DepthImageToLaserScanTest.cpp)
++  target_link_libraries(libtest DepthImageToLaserScan ${catkin_LIBRARIES})
++endif()
+ 
+ # add the test executable, keep it from being built by "make all"
+ add_executable(test_dtl EXCLUDE_FROM_ALL test/depthimage_to_laserscan_rostest.cpp)
diff --git a/recipes-ros/depthimage-to-laserscan/depthimage-to-laserscan_1.0.5.bb b/recipes-ros/depthimage-to-laserscan/depthimage-to-laserscan_1.0.5.bb
new file mode 100644
index 0000000000000000000000000000000000000000..e58c55f563e8386433fb0b43d54e0b19093b61ba
--- /dev/null
+++ b/recipes-ros/depthimage-to-laserscan/depthimage-to-laserscan_1.0.5.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Converts a depth image to a laser scan for use with navigation and localization."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "roscpp sensor-msgs nodelet image-transport image-geometry dynamic-reconfigure"
+
+SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
+SRC_URI[md5sum] = "484a0aa840c75a93907f2b4ccd767833"
+SRC_URI[sha256sum] = "07d078951dc125fb90248a1eb9b7d905701db151df897b99cfae56a91b59687e"
+
+SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch"
+
+S = "${WORKDIR}/${ROS_SP}"
+
+inherit catkin
+
+RRECOMMENDS_${PN} = "roscpp sensor-msgs nodelet image-transport image-geometry dynamic-reconfigure"