From 24be26d89b3cdd5ec75e670048ed0316cc4dc5cb Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sun, 13 Oct 2013 13:10:28 +0200
Subject: [PATCH] octomap-ros: preliminary solution for #176

After configuring octomap-ros, the recipe modifies the generated
files to address the problem in #176. However, it does not solve
the root of this cause.
As #176 is similar to #175, this preliminary solution is very
similar to the preliminary solution for #175.
---
 recipes-ros/octomap-ros/octomap-ros_0.2.6.bb | 6 ++++++
 1 file changed, 6 insertions(+)

diff --git a/recipes-ros/octomap-ros/octomap-ros_0.2.6.bb b/recipes-ros/octomap-ros/octomap-ros_0.2.6.bb
index 99bf3e2..8927982 100644
--- a/recipes-ros/octomap-ros/octomap-ros_0.2.6.bb
+++ b/recipes-ros/octomap-ros/octomap-ros_0.2.6.bb
@@ -12,3 +12,9 @@ SRC_URI[sha256sum] = "f39877bc3595f0d3808762042aee2c2cdc50ad8db6032beac31995da70
 S = "${WORKDIR}/${ROS_SP}"
 
 inherit catkin
+
+do_configure_append() {
+	sed -i -e 's: /usr/lib/liboctomap.so: ${STAGING_LIBDIR}/liboctomap.so:g' \
+	  -e 's: /usr/lib/liboctomath.so: ${STAGING_LIBDIR}/liboctomath.so:g' \
+	  ${S}/build/CMakeFiles/octomap_ros.dir/build.make
+}
-- 
GitLab