diff --git a/recipes-core/images/core-image-ros.bb b/recipes-core/images/core-image-ros.bb
index c45a174780f6dab8b8ca921a18241246041f8b61..be4b57ce233380f0d5c297093567ee6fa8f55310 100644
--- a/recipes-core/images/core-image-ros.bb
+++ b/recipes-core/images/core-image-ros.bb
@@ -14,7 +14,7 @@ IMAGE_FEATURES += "tools-sdk"
 
 # add own name to hosts
 augment_hosts_setting_file () {
-	echo '127.0.0.1\tqemux86-64.localdomain\t\tqemux86-64' >> ${IMAGE_ROOTFS}/etc/hosts
+	echo '127.0.0.1\tqemux86.localdomain\t\tqemux86' >> ${IMAGE_ROOTFS}/etc/hosts
 }
 
 # remove not needed ipkg informations