diff --git a/recipes-core/images/core-image-ros.bb b/recipes-core/images/core-image-ros.bb
index be4b57ce233380f0d5c297093567ee6fa8f55310..8ff31b7577f84167e7932da27d24fb2d6f2c01ea 100644
--- a/recipes-core/images/core-image-ros.bb
+++ b/recipes-core/images/core-image-ros.bb
@@ -24,4 +24,4 @@ ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setti
 IMAGE_INSTALL += "packagegroup-core-ssh-openssh git cmake \
   boost boost-dev log4cxx log4cxx-dev libbz2-dev \
   python-modules python-empy python-pyyaml python-nose \
-  python-setuptools python-rospkg python-dateutil python-vcstools python-rosinstall"
+  python-setuptools python-rospkg python-rosinstall"
diff --git a/recipes-devtools/python/python-rosinstall_0.6.21.bb b/recipes-devtools/python/python-rosinstall_0.6.21.bb
index 13fcb83b57b43f244e9e6f10a0ebf7820083abca..f0cc93c12374fe5b2fdddb519d9b1ff2ef02041a 100644
--- a/recipes-devtools/python/python-rosinstall_0.6.21.bb
+++ b/recipes-devtools/python/python-rosinstall_0.6.21.bb
@@ -10,7 +10,8 @@ SRC_URI[sha256sum] = "7163106c93460c8d092c5e74749cefd3fc17295f3a06c4f041fe83a772
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-DEPENDS += "python-vcstools"
+# install_requires=['vcstools', 'pyyaml'],
+DEPENDS += "python-vcstools python-pyyaml"
 
 inherit setuptools
 
diff --git a/recipes-devtools/python/python-vcstools_0.1.26.bb b/recipes-devtools/python/python-vcstools_0.1.26.bb
index e77c66ccc9a5481bcf1dfeace3a7f5fe549b4dbe..ac2a3bc0256b3ad0f50f694d8b0c210e651d9f76 100644
--- a/recipes-devtools/python/python-vcstools_0.1.26.bb
+++ b/recipes-devtools/python/python-vcstools_0.1.26.bb
@@ -10,5 +10,8 @@ SRC_URI[sha256sum] = "11cae4907609d3524655c7cdba66260821f69fd2ff2330ae93db35111c
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
+# install_requires=['pyyaml','python-dateutil']
+RDEPENDS_${PN} += "python-pyyaml python-dateutil"
+
 inherit setuptools