diff --git a/recipes-ros/actionlib/actionlib_1.10.2.bb b/recipes-ros/actionlib/actionlib_1.10.3.bb
similarity index 74%
rename from recipes-ros/actionlib/actionlib_1.10.2.bb
rename to recipes-ros/actionlib/actionlib_1.10.3.bb
index 7ca15911b68bf041f4f2b2b7916bf9424bf71c1b..846fd4d8dc32731be76c9755d8496ff501b8a89a 100644
--- a/recipes-ros/actionlib/actionlib_1.10.2.bb
+++ b/recipes-ros/actionlib/actionlib_1.10.3.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9de
 DEPENDS = "actionlib-msgs roscpp rostest"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "d16d2369554d8060beb4369b61d3cc68"
-SRC_URI[sha256sum] = "d0a5eac521832cf09ddff833d7c7965874e3a0bf837d9464c344f71147dabb4b"
+SRC_URI[md5sum] = "2e13067c3c85e81a3ab4b603ff15e45b"
+SRC_URI[sha256sum] = "f71df286552e6bf3a03ef83635342d3bdd6eef836e7b0565dccd2d341dbeaa11"
 
 inherit catkin
diff --git a/recipes-ros/geometry-experimental/geometry-experimental.inc b/recipes-ros/geometry-experimental/geometry-experimental.inc
index a8f4982000ad1e104ef0f79c9e58dbc155ae6bf6..bd70e11ebb0d7049fd49677c6aaf0ccadb6b9adf 100644
--- a/recipes-ros/geometry-experimental/geometry-experimental.inc
+++ b/recipes-ros/geometry-experimental/geometry-experimental.inc
@@ -1,6 +1,6 @@
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "530cbf52308427e15a0568f5226313aa"
-SRC_URI[sha256sum] = "10a95045136510c1db5743481930ced6d164c6990d9e1a7c2afd9d6fa5062d02"
+SRC_URI[md5sum] = "b60f166ea4dc68600984e43d176cd169"
+SRC_URI[sha256sum] = "15db02c9d8a28f2b0b3f234306722b96339e42d88c32ebaa404af246304095a7"
 
 S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
 
diff --git a/recipes-ros/geometry-experimental/tf2-msgs_0.4.5.bb b/recipes-ros/geometry-experimental/tf2-msgs_0.4.7.bb
similarity index 100%
rename from recipes-ros/geometry-experimental/tf2-msgs_0.4.5.bb
rename to recipes-ros/geometry-experimental/tf2-msgs_0.4.7.bb
diff --git a/recipes-ros/geometry-experimental/tf2-py_0.4.5.bb b/recipes-ros/geometry-experimental/tf2-py_0.4.7.bb
similarity index 100%
rename from recipes-ros/geometry-experimental/tf2-py_0.4.5.bb
rename to recipes-ros/geometry-experimental/tf2-py_0.4.7.bb
diff --git a/recipes-ros/geometry-experimental/tf2-ros_0.4.5.bb b/recipes-ros/geometry-experimental/tf2-ros_0.4.7.bb
similarity index 100%
rename from recipes-ros/geometry-experimental/tf2-ros_0.4.5.bb
rename to recipes-ros/geometry-experimental/tf2-ros_0.4.7.bb
diff --git a/recipes-ros/geometry-experimental/tf2_0.4.5.bb b/recipes-ros/geometry-experimental/tf2_0.4.7.bb
similarity index 100%
rename from recipes-ros/geometry-experimental/tf2_0.4.5.bb
rename to recipes-ros/geometry-experimental/tf2_0.4.7.bb
diff --git a/recipes-ros/geometry/geometry.inc b/recipes-ros/geometry/geometry.inc
index ebba3b5619fe9c6465331e76c54a96ccfdbfc245..c3bf67aef883ad7930c4f21f91c6dc2e18b13019 100644
--- a/recipes-ros/geometry/geometry.inc
+++ b/recipes-ros/geometry/geometry.inc
@@ -1,6 +1,6 @@
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "ccaadd38c183c2c257e75ac907868c87"
-SRC_URI[sha256sum] = "30527d91f182478b7819a947237c92ce1effe61cd11d2d710e0408c971f2bc74"
+SRC_URI[md5sum] = "32fd3bf4e85fdbf40a391daf32a8a91b"
+SRC_URI[sha256sum] = "8b0341d39391abfec2b3f72dad2ec0ce8c37bd4443822322a64eacb36f0ce7b6"
 
 S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
 
diff --git a/recipes-ros/geometry/tf_1.10.5.bb b/recipes-ros/geometry/tf_1.10.6.bb
similarity index 100%
rename from recipes-ros/geometry/tf_1.10.5.bb
rename to recipes-ros/geometry/tf_1.10.6.bb
diff --git a/recipes-ros/packagegroups/packagegroup-ros-world.bb b/recipes-ros/packagegroups/packagegroup-ros-world.bb
new file mode 100644
index 0000000000000000000000000000000000000000..7f9da5720ff82dcab18d755e667f5663fdc08336
--- /dev/null
+++ b/recipes-ros/packagegroups/packagegroup-ros-world.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "ros-world package group"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "${PN}"
+
+RDEPENDS_${PN} = "\
+    packagegroup-ros-comm \
+    actionlib \
+    bond \
+    bondcpp \
+    bondpy \
+    smclib \
+    chatter-msgs \
+    chatter-receiver \
+    chatter-sender \
+    class-loader \
+    actionlib-msgs \
+    diagnostic-msgs \
+    geometry-msgs \
+    nav-msgs \
+    sensor-msgs \
+    shape-msgs \
+    stereo-msgs \
+    trajectory-msgs \
+    visualization-msgs \
+    nodelet-tutorial-math \
+    pluginlib-tutorials \
+    console-bridge \
+    dynamic-reconfigure \
+    angles \
+    tf2-msgs \
+    tf2-py \
+    tf2-ros \
+    tf2 \
+    tf \
+    image-transport \
+    nodelet-topic-tools \
+    nodelet \
+    pluginlib \
+    roscpp-tutorials \
+    rospy-tutorials \
+    "