diff --git a/meta/recipes-extended/ros/ros.bb b/meta/recipes-extended/ros/ros.bb
index a8fea4222896054f67588acd6a69f46b0762ff5f..ce433d9eb0bbfa9657e4d39ee2ac91e9d57ed76a 100644
--- a/meta/recipes-extended/ros/ros.bb
+++ b/meta/recipes-extended/ros/ros.bb
@@ -1,30 +1,21 @@
 DESCRIPTION  = "ROS"
 HOMEPAGE = "http://ros.org"
 
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
+LICENSE = "CLOSED"
+# LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
 
 DEPENDS = "python-empy-native python-rospkg-native python-native python-pyyaml-native python-nose-native"
 
 PR = "r0"
 
-SRC_URI = "file://catkin \
-file://CMakeLists.txt \
-file://common_msgs \
-file://gencpp \
-file://genlisp \
-file://genmsg \
-file://genpy \
-file://ros \
-file://ros_comm \
-file://roscpp_core \
-file://rospack \
-file://std_msgs"
+SRC_URI = "file://ros_server.tar.gz \
+	file://fuerte-ros-base.rosinstall"
 
 S = "${WORKDIR}"
 
 EXTRA_OECMAKE = "-DSETUPTOOLS_DEB_LAYOUT=OFF"
 
+
 do_configure_prepend () {   
 cat > /home/lukas/af_yocto/build/tmp/sysroots/x86_64-linux/usr/lib/python2.7/site-packages/easy-install.pth << EOF
 import sys; sys.__plen = len(sys.path)
@@ -34,7 +25,49 @@ import sys; new=sys.path[sys.__plen:]; del sys.path[sys.__plen:]; p=getattr(sys,
 EOF
 }
 
+DEPENDS += " cmake-native "
+
+# We need to unset CCACHE otherwise cmake gets too confused
+CCACHE = ""
+
+# We want the staging and installing functions from autotools
+inherit autotools
+
+# Use in-tree builds by default but allow this to be changed
+# since some packages do not support them (e.g. llvm 2.5).
+OECMAKE_SOURCEPATH ?= "."
+
+# If declaring this, make sure you also set EXTRA_OEMAKE to
+# "-C ${OECMAKE_BUILDPATH}". So it will run the right makefiles.
+OECMAKE_BUILDPATH ?= ""
+
+# C/C++ Compiler (without cpu arch/tune arguments)
+OECMAKE_C_COMPILER ?= "`echo ${CC} | sed 's/^\([^ ]*\).*/\1/'`"
+OECMAKE_CXX_COMPILER ?= "`echo ${CXX} | sed 's/^\([^ ]*\).*/\1/'`"
+
+# Compiler flags
+OECMAKE_C_FLAGS ?= "${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS} ${CPPFLAGS}"
+OECMAKE_CXX_FLAGS ?= "${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS} ${CXXFLAGS} -fpermissive"
+OECMAKE_C_FLAGS_RELEASE ?= "${SELECTED_OPTIMIZATION} ${CPPFLAGS} -DNDEBUG"
+OECMAKE_CXX_FLAGS_RELEASE ?= "${SELECTED_OPTIMIZATION} ${CXXFLAGS} -DNDEBUG"
+OECMAKE_C_LINK_FLAGS ?= "${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS} ${CPPFLAGS} ${LDFLAGS}"
+OECMAKE_CXX_LINK_FLAGS ?= "${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS} ${CXXFLAGS} ${LDFLAGS}"
+
+OECMAKE_RPATH ?= ""
+OECMAKE_PERLNATIVE_DIR ??= ""
+OECMAKE_EXTRA_ROOT_PATH ?= ""
+
+
+do_install () {
+	echo "Installing ros"
+        mkdir -p ./ros-underlay
+	rosinstall --catkin ./ros-underlay fuerte-ros-base.rosinstall
+	cd ./ros-underlay
+	mkdir -p build
+	cd ./build
+	cmake .. -DCMAKE_INSTALL_PREFIX=/opt/ros/fuerte -DSETUPTOOLS_DEB_LAYOUT=OFF
+}
 
-inherit cmake pythonnative
+inherit pythonnative
 
 
diff --git a/meta/recipes-extended/ros/ros/fuerte-ros-base.rosinstall b/meta/recipes-extended/ros/ros/fuerte-ros-base.rosinstall
new file mode 100644
index 0000000000000000000000000000000000000000..e3c40c6c078964682f9e63d0d20287afae0e607b
--- /dev/null
+++ b/meta/recipes-extended/ros/ros/fuerte-ros-base.rosinstall
@@ -0,0 +1,44 @@
+- git:
+    local-name: catkin
+    uri: git://github.com/wg-debs/catkin-release.git
+    version: debian/ros-fuerte-catkin_0.4.4_lucid
+- git:
+    local-name: common_msgs
+    uri: git://github.com/wg-debs/common_msgs-release.git
+    version: debian/ros-fuerte-common-msgs_1.8.7_lucid
+- git:
+    local-name: gencpp
+    uri: git://github.com/wg-debs/gencpp-release.git
+    version: debian/ros-fuerte-gencpp_0.3.4_lucid
+- git:
+    local-name: genlisp
+    uri: git://github.com/wg-debs/genlisp-release.git
+    version: debian/ros-fuerte-genlisp_0.3.3_lucid
+- git:
+    local-name: genmsg
+    uri: git://github.com/wg-debs/genmsg-release.git
+    version: debian/ros-fuerte-genmsg_0.3.10_lucid
+- git:
+    local-name: genpy
+    uri: git://github.com/wg-debs/genpy-release.git
+    version: debian/ros-fuerte-genpy_0.3.7_lucid
+- git:
+    local-name: ros
+    uri: git://github.com/wg-debs/ros-release.git
+    version: debian/ros-fuerte-ros_1.8.9_lucid
+- git:
+    local-name: ros_comm
+    uri: git://github.com/wg-debs/ros_comm-release.git
+    version: debian/ros-fuerte-ros-comm_1.8.12_lucid
+- git:
+    local-name: roscpp_core
+    uri: git://github.com/wg-debs/roscpp_core-release.git
+    version: debian/ros-fuerte-roscpp-core_0.2.5_lucid
+- git:
+    local-name: rospack
+    uri: git://github.com/wg-debs/rospack-release.git
+    version: debian/ros-fuerte-rospack_2.0.13_lucid
+- git:
+    local-name: std_msgs
+    uri: git://github.com/wg-debs/std_msgs-release.git
+    version: debian/ros-fuerte-std-msgs_0.4.8_lucid