diff --git a/recipes-ros/geometry/tf/0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch b/recipes-ros/geometry/tf/0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch
new file mode 100644
index 0000000000000000000000000000000000000000..fac20da939f9052673b2623a95d19ce7f2da5f87
--- /dev/null
+++ b/recipes-ros/geometry/tf/0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch
@@ -0,0 +1,34 @@
+From 18e81e33c052e26ae60259708095a2a933f75fd1 Mon Sep 17 00:00:00 2001
+From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date: Tue, 4 Feb 2014 16:02:48 +0100
+Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
+
+---
+ tf/CMakeLists.txt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt
+index fa4a42f..c6988e1 100644
+--- a/tf/CMakeLists.txt
++++ b/tf/CMakeLists.txt
+@@ -4,7 +4,7 @@ project(tf)
+ find_package(catkin REQUIRED)
+ 
+ find_package(Boost REQUIRED thread signals)
+-find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostest rostime sensor_msgs std_msgs tf2_ros)
++find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostime sensor_msgs std_msgs tf2_ros)
+ 
+ catkin_python_setup()
+ 
+@@ -48,6 +48,8 @@ target_link_libraries(static_transform_publisher ${PROJECT_NAME})
+ # Tests
+ if(CATKIN_ENABLE_TESTING)
+ 
++find_package(rostest)
++
+ catkin_add_gtest(tf_unittest test/tf_unittest.cpp)
+ target_link_libraries(tf_unittest ${PROJECT_NAME})
+ 
+-- 
+1.8.3.2
+
diff --git a/recipes-ros/geometry/tf/0001-rostest-is-optional.patch b/recipes-ros/geometry/tf/0001-rostest-is-optional.patch
deleted file mode 100644
index fea37ec0a6fef208d3022df84d040d1421eb451d..0000000000000000000000000000000000000000
--- a/recipes-ros/geometry/tf/0001-rostest-is-optional.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 9f1e801c6de00287658f1bae21048f37bb9bb198 Mon Sep 17 00:00:00 2001
-From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-Date: Sat, 21 Sep 2013 16:13:16 +0200
-Subject: [PATCH] rostest is optional
-
----
- tf/CMakeLists.txt |    7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt
-index e8d3044..2d36df3 100644
---- a/tf/CMakeLists.txt
-+++ b/tf/CMakeLists.txt
-@@ -4,7 +4,12 @@ project(tf)
- find_package(catkin REQUIRED)
- 
- find_package(Boost REQUIRED thread signals)
--find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostest rostime sensor_msgs std_msgs tf2_ros)
-+
-+if(CATKIN_ENABLE_TESTING)
-+  find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostest rostime sensor_msgs std_msgs tf2_ros)
-+else()
-+  find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostime sensor_msgs std_msgs tf2_ros)
-+endif()
- 
- catkin_python_setup()
- 
--- 
-1.7.10.4
-
diff --git a/recipes-ros/geometry/tf_1.10.8.bb b/recipes-ros/geometry/tf_1.10.8.bb
index 82fe6e7e876b51f69916bb610a44ccd12b759a89..3a03627949805b327d0263bcd9e6d3a752e38d73 100644
--- a/recipes-ros/geometry/tf_1.10.8.bb
+++ b/recipes-ros/geometry/tf_1.10.8.bb
@@ -7,6 +7,6 @@ DEPENDS = "angles geometry-msgs message-filters sensor-msgs tf2-ros"
 
 require geometry.inc
 
-SRC_URI += "file://0001-rostest-is-optional.patch;striplevel=2"
+SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"
 
 RDEPENDS_${PN} = "python-numpy"