diff --git a/recipes-ros/gencpp/gencpp_0.4.11.bb b/recipes-ros/gencpp/gencpp_0.4.11.bb
index 394bed16a0c596bdff89803c2302beefc185e0c6..574530b1033d556bf9f4f87f0739b50530416cf0 100644
--- a/recipes-ros/gencpp/gencpp_0.4.11.bb
+++ b/recipes-ros/gencpp/gencpp_0.4.11.bb
@@ -3,23 +3,10 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-SRC_URI = "https://github.com/ros-gbp/gencpp-release/archive/release/gencpp/0.4.11.tar.gz;downloadfilename=gencpp_0.4.11.tar.gz"
-SRC_URI[md5sum] = "7a3e28fb0719805aa3a2059b6b0514fd"
-SRC_URI[sha256sum] = "63258067e6c2ba034bfbcf6aaf396eb36c3c407023d7db0de1af774bbb12b6a9"
+DEPENDS = "genmsg"
 
-S = "${WORKDIR}/gencpp-release-release-gencpp-0.4.11"
+SRC_URI = "https://github.com/ros/${BPN}/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz"
+SRC_URI[md5sum] = "be0b3986e98f3370fef4c1fffe3a69f4"
+SRC_URI[sha256sum] = "c68b4518dbc5d65fd19d43724e5c9b0e66c769ef6066e3d511a6ffce2623f3c7"
 
-DEPENDS = "catkin-native genmsg"
-
-FILES_${PN} += "${libdir}/*"
-
-inherit cmake pythonnative
-
-EXTRA_OECMAKE = " \
-  -Dgenmsg_DIR=${STAGING_DATADIR}/genmsg/cmake/ \
-  "
-
-export BUILD_SYS
-export HOST_SYS
-export STAGING_LIBDIR
-export STAGING_INCDIR
+inherit catkin